Search for something in message body does not work at all



11 years ago
9 years ago


(Reporter: Thomas Mittelstaedt, Unassigned)


Windows XP

Firefox Tracking Flags

(Not tracked)


(Whiteboard: [has protocol log])


(1 attachment)



11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv: Gecko/20070508 Firefox/
Build Identifier: Mozilla Thunderbird Version (20070604) and

We have imap here. Just upgraded from to and the search for text in message body still does not work, neither from the quicksearch dialog nor from Ctrl-Shift-F nor with a virtual folder. It does not work for online or offline search. The message is synced, i.e. is in the INBOX mailbox on my local disk. Grep  for the string in this file finds that text. search for subject does work.

Reproducible: Always

Steps to Reproduce:

Comment 1

11 years ago
still broke?
Version: unspecified → 2.0

Comment 2

11 years ago
Just installed and the problem is still there.

Comment 3

11 years ago
is text you are trying to find in an attachment?
need sample message attached as .eml file to bug, or emailed as attachment (to me)

Comment 4

11 years ago
It's not some mail where thunderbird does not find a string in the message text. It's any message. Maybe the problem is related to our imap server?

Comment 5

11 years ago
oh, right. can you send me your server? :) 
just kidding.

But, it worked on 1.5, right?

attach an smtp log file. instructions: 
NOTE: "imap" must be substituted where you see protocol underlined.

Click "Create a New Attachment" fill in the blanks and click submit. Make your test as short as possible so that the log file  is also short. 

Comment 6

11 years ago
No, it never worked. With no 1.x version!

Comment 7

11 years ago
Created attachment 279918 [details]
thunderbird imap protocol log

Comment 8

9 years ago
bienvenu, Tom's email address is invalid
Whiteboard: [has protocol log]

Comment 9

9 years ago
perhaps body search doesn't work on Kerio - the log shows us issuing the search and not getting any results back. I'll mark this incomplete, then.
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.