Closed Bug 386316 Opened 13 years ago Closed 12 years ago

Events not shown in month view

Categories

(Calendar :: Calendar Views, defect)

Lightning 0.5
x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: d.tazetdinov, Unassigned)

Details

(Whiteboard: [0.5 disappearing events])

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Lightning 0.5

Month view does not show any events, while week view and day view show these events. (screenshots are included)

Reproducible: Always
Attached image empty month view
Attached image week view with event
At 20th June there is an event. It is shown on week view, but not shown on month view.
Before upgrading to 0.5 month view shown these events.
Event is stored in local lightning calendar.
What else should I investigate?
Attachment #270320 - Attachment mime type: application/octet-stream → image/png
What version of Thunderbird do you use? Do you see any error messages in the Error Console?

It would help if you could export the calendar in question to iCalendar format and attach the (anonymized) .ics file in this bug.
Version: unspecified → Lightning 0.5
Thunderbird - 2.0.0.4, russian.

there are several error messages in error console. maybe, they releate to a problem.
---
Error: Failed to fetch todo items: 0x80004001
Source: chrome://lightning/content/calendar-todo-list.xml
Line: 130

--- 
Error: [Exception... "'Component does not have requested interface' when calling method: [nsIInterfaceRequestor::getInterface]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "<unknown>"  data: no]


more info: thunderbird crashed during weekend (I don't have talkback since I'm behind a proxy, so I don't know, why it crashed), now after restart all items are shown in month view. I restarted it before several times and it did not help.
so, for now - I don't know if I can find the problem again. 
maybe, this bug should be closed as INVALID. if I see it next time, I'll try to get more details before posting a bug...
I've just noticed a similar problem with Sunbird 0.5. I launched Sunbird and I left it open. And after a while my events&tasks disappeared from main calendar view. I switched between multiweek view and month view many times. Some of the events were sometimes displayed and sometimes not. I use 4 local calendars and 3 remote calendars (Google calendar, Firefox Team Calendar, Calendar Team calendar). Provider for Google Calendar extension is also installed. Not sure what cause it. I noticed that this kind of problems were caused by subscriptions to remote calendars in the past.
Unfortunately I'm going for my holiday tomorrow and I can't continue testing it. But I'll try to reproduce it when I'm back. I didn't see any error in console
I've got this error again.
It seems, that it happens after some period of uptime.
Error console shows:
===
Ошибка: Failed to fetch todo items: 0x80004001
Источник: chrome://lightning/content/calendar-todo-list.xml
Строка: 130
===
and agenda under mini-calendar shows incorrect dates for "today" and "tomorrow".
for "today" it shows yesterday's date, and for "tomorrow" it shows today's.

I've got installed google desktop search, if it matters (I've seen some errors in console from that extension) and google calendar extension.
Whiteboard: [0.5 disappearing events]
Deniska: the failed to fetch todo-items is, afaik, caused by the google-calendar plugin and doesn't have anything to do with the problem of disappearing events.
If the todo-items error has to do with Google Calendar, please file a bug in the Provider: GData component. I thought I just returned an empty set of todo items, which should not produce an error. Deniska, apart from this bug, could you try a fresh profile with only the extension for google calendar and see if the todo-items error message persists?
(In reply to comment #5)
> I've just noticed a similar problem with Sunbird 0.5. 

I've found steps to reproduce (Sunbird 0.5):
1)Create new profile
2)Install Provider for Google Calendar
3)Setup remote calendar: http://www.google.com/calendar/ical/bfu5nfrmploglr2j4k0bkbg45o%40group.calendar.google.com/public/basic.ics  ----> call it Culture
4)Create 2nd local calendar "Work"
5)Switch to multiweek
6) Create 3 different events for first calendar
7)Go offline and turn task in view
8)Restart Sunbird
9)Create 2 events for "work"calendar (remember you are still offline)
10) Switch to month view and back to multiweek view

Result---> the events disappeared in multiweek view
Events only disappeared when Provider for Google Calendar is installed, a google calendar is set and task in view is enabled
(In reply to comment #8)
> If the todo-items error has to do with Google Calendar, please file a bug in
> the Provider: GData component. 

Do you want me to create a new bug about the things I wrote above?
Philipp, please mind my comment <https://bugzilla.mozilla.org/show_bug.cgi?id=393387#c5>: Could you please verify whether you always send an onOperationComplete even in case an error has occurred?
I believe so. The getItems call and getItems_response call are both wrapped in a try/catch block, calling onOperationComplete if an exception is caught.

I can't reproduce this bug, but if someone could try it in sunbird (where the todo-exceptions don't happen for some reason) that might help.

Also (I thought I changed this at some point), calGoogleCalendar.js, line #471 returns NS_ERROR_NOT_IMPLEMENTED with the onOperationComplete listener for todo items. I guess theoretically I could change this to NS_OK, but I think the onOperationComplete handler should accept error messages. I remember at some point seing a check with  if(!Components.isSuccessCode(result)) { return; } in an onOperationComplete hanlder. If this is happening and maybe blocking some processing, then that could be the root of the problem.

Omar, feel free to create a bug for the todo-items exception, I don't think there is one.

(In reply to comment #13)
> onOperationComplete handler should accept error messages. I remember at some
> point seing a check with  if(!Components.isSuccessCode(result)) { return; } in
> an onOperationComplete hanlder. If this is happening and maybe blocking some
> processing, then that could be the root of the problem.
If that's code in onOperationComplete, then IMO it's no problem. It's just if some calendar operation doesn't fire onOperationComplete at all, but keeps pending, the composite won't fire its onOperationComplete, thus the views are hanging.
Bug 393387 was fixed a few days ago and might help with the issue reported here too. I'd like you to retest with a Sunbird or Lightning 0.7pre (20070918) or newer build if your issue still exists.
Does the issue still exists using Lightning 0.7 Release Candidate 1?
<http://releases.mozilla.org/pub/mozilla.org/calendar/lightning/releases/0.7rc1/>
Reporter, please post the retest results with Sunbird 0.7 resp. Lightning 0.7.
Otherwise I assume the issue is fixed now and this bug can be resolved.
No response from reporter in several months. Resolving as WFM assuming that the issue has been solved in 0.7. Feel free to reopen the bug if the issue can be reproduced in a recent 0.8pre nightly build.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.