bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Status

Camino Graveyard
Bookmarks
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: Tim Bray, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.4) Gecko/20070509 Camino/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.4) Gecko/20070509 Camino/1.5

It used to on previous Camino releases and it works in other apps as you'd expect  I had my "most important" bookmark over at the left and used to access it all the time with Cmd-1, but now Camino just makes a burping sound.  Cmd-2 and higher all work, just Cmd-1 has gone missing.

Reproducible: Always

Steps to Reproduce:
1.Press Cmd-1
2.
3.
Actual Results:  
Camino makes a burping sound

Expected Results:  
Open the first bookmark
Tim, do you happen to have any third-party "add-ons" (input managers) installed that might be interfering here?  Or any Services that claim Cmd-1 as their shortcut (iirc, Services get first shot at shortcuts, before apps)?
(Reporter)

Comment 2

11 years ago
Yeah, I know, that's the obvious thing to ask, and I looked around, but I don't think so.  And I can switch back and forth between Terminal windows with cmd-1 and cmd-2 and so on.  This seemed to happen when I switched from the previous Camino (1.1b I think) to 1.5.  The "burp" sound suggests that *something* is trying to deal with the cmd-1.  Is there a way to find out which app/handler/whatever is looking for cmd-1?

Comment 3

11 years ago
Tim, is your bookmark bar hidden?
If so, see bug 365270.
(Reporter)

Comment 4

11 years ago
Yeah, I saw that.  Nope, it's visible, sigh.  Still looking...
(In reply to comment #2)
> trying to deal with the cmd-1.  Is there a way to find out which
> app/handler/whatever is looking for cmd-1?

Not that I know of, sadly.

Two things to try/check for:

  1. New profile. Use http://pimpmycamino.com/parts/troubleshoot-camino
  2. Check for any input managers (Camino-related or not) that might be around.
     I'm thinking... CaminoSession, 1Passwd, etc etc... Move them aside and
     try and see if it works after that.
(Reporter)

Comment 6

11 years ago
OK, that did it; start up with an empty profile and I have cmd-1 back.  So in the upgrade to 1.5, somehow something buried in my profile woke up and is grabbing cmd-1.  

I guess you can retire this bug, but I'd appreciate any advice as to how to dig around in my profile to figure out what's wrong, I'd like cmd-1 back.
(In reply to comment #6)
> I guess you can retire this bug, but I'd appreciate any advice as to how to dig
> around in my profile to figure out what's wrong, I'd like cmd-1 back.

Ideally, we'd like to know what ate it, too.  Unfortunately we don't have any automated tool to help with this step, so it's a matter of moving files in/out one at a time :( (and, for prefs.js/user.js, removing/adding prefs one line at a time). 

Comment 8

11 years ago
Alternatively, you could upload the various profile files here and someone else could test them. Bear in mind that some of those files may contain private data, and that the most likely candidate for having caused this is prefs.js/user.js (which shouldn't contain any private data, if you want to start there).

I'm going to close this bug WORKSFORME since we don't have a specific cause; if we can determine a specific cause and reproduce it, a new bug should be filed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.