Firefox stops responding and hangs when accessing a specific page from the StarCraft II website.

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: michaelk, Unassigned)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

When loading the attached URL on Windows Vista, Firefox starts rendering the page but hangs halfway through. Other pages on the same site work fine. There are no Problems with IE/Vista or FF/WinXP.

Reproducible: Always

Steps to Reproduce:
1. Load URL (http://eu.starcraft2.com/features/protoss/index.xml?tab=colossus) in FF/Vista
2. Wait for the cool Vista/Aero effect to show up where the unresponsive application fades to gray.
Actual Results:  
Firefox hangs halfway through rendering the page. It even freezes my entire system one time, when i did not take the focus from it.

Expected Results:  
Firefox should have displayed the cool animations properly and not hang.

Default theme, no extensions, using windows Aero, Flash 8 installed.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
It dies indeed here (didn't try Vista) with very low CPU usage, but not in trunk.

Comment 2

12 years ago
No problem here on Vista, with Flash 9.0 r45

Try upgrading your flash plugin

WFM 
Mozilla/5.0 (Windows; U; Windows NT 6.0; it; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

Comment 3

12 years ago
Problem seen here (XP Pro) and also using XP Home.  Latest flash + firefox.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

Problem is fixed by visiting SC2 home page first, then navigating to unit pages.  Further visits are then ok too, must be something cached as clearing cache causes the problem to come back.

Once frozen seems to be no activity by firefox - CPU/Memory stay the same.
This was fixed on trunk between 2006-05-10 10 and 2006-05-10 22, presumably by bug 326273, a trunk only patch that is not likely to be applied to branch I think.
Indeed, that patch is not going to land on the branch. Fixing this bug might not require that entire patch, though.
Component: General → General
Product: Firefox → Core
QA Contact: general → general

Comment 6

11 years ago
(In reply to comment #5)
> Indeed, that patch [bug 326273] is not going to land on the branch. Fixing this bug might
> not require that entire patch, though.

worth further investment?
Keywords: hang
(Reporter)

Comment 7

10 years ago
(Un)fortunately, I do not have access to a vista machine currently. I can only tell that everything works fine with FF 3.0.3, XP or OSX with the latest Flash player. As Ria Klaassen seems not to have problems anymore either, this issue is probably done with.

Comment 8

10 years ago
=> WFM then.  Thanks Michael
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.