Closed Bug 386526 Opened 13 years ago Closed 12 years ago

[FIX]Mochitest creates nodes using createElement, not createElementNS

Categories

(Testing :: Mochitest, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bzbarsky, Assigned: sayrer)

References

Details

(Keywords: autotest-issue)

Attachments

(2 files)

As a result, the nodes created in non-HTML files are not HTML, and the output table doesn't get styled (because the "class" attribute on random nodes doesn't match CSS classes).
Blocks: 396776
Actually, this is worse than I thought.  The test framework relies on the nodes it creates having classes to function properly, as far as I can tell.  See bug 396776.  So it's possible that this issue will cause us to miss regresions.
Severity: normal → major
So I think I have a fix if I can get packed.js regenerated somehow....
We'd still need to regenerate packed.js after checking this in, though.
Assignee: nobody → bzbarsky
Status: NEW → ASSIGNED
Attachment #281547 - Flags: review?(sayrer)
OS: Linux → All
Priority: -- → P1
Hardware: PC → All
Summary: Mochitest creates nodes using createElement, not createElementNS → [FIX]Mochitest creates nodes using createElement, not createElementNS
Target Milestone: --- → mozilla1.9 M9
Attachment #281547 - Flags: review?(sayrer) → review+
Checked in.  Robert. do you want another bug on regenerating packed.js?  Or should I assign this one to you?
So not marking fixed yet, since it's not until packed.js is regenerated.
Just assign this to me.
Assignee: bzbarsky → sayrer
Status: ASSIGNED → NEW
Blocks: 367390
Ignoring the results of all .xml mochitests is really bad, IMO.
Severity: major → blocker
Flags: blocking1.9?
Doin as sayre says..
Flags: blocking1.9? → blocking1.9+
Duplicate of this bug: 367390
Keywords: checkin-needed
Keywords: checkin-needed
Whiteboard: [needs landing]
Severity: blocker → normal
Priority: P1 → P2
Flags: tracking1.9+ → blocking1.9+
Sayre - final thoughts on this?
(In reply to comment #10)
> Sayre - final thoughts on this?
> 

It is a blocker, it needs to be fixed. Working on it.
Attachment #281547 - Flags: approval1.9+
Keywords: checkin-needed
Sayre, progress?  Time is up.
I'll get this today
I'll check this in later tonight
Attachment #318489 - Flags: review+
Attachment #318489 - Attachment description: largely automaticly generated, npotb → generated, npotb
Comment on attachment 318489 [details] [diff] [review]
generated, npotb
[Checkin: Comment 17]

a1.9+=damons
Attachment #318489 - Flags: approval1.9+
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Moving a bunch of Core :: Testing bugs to Testing :: Mochitest to clear out the former, which is obsolete now that we have more specialized categories for such bugs; filter on the string "MochitestMmMm" to delete all these notifications.
Component: Testing → Mochitest
Flags: blocking1.9+
Product: Core → Testing
QA Contact: testing → mochitest
Target Milestone: mozilla1.9beta1 → ---
Version: Trunk → unspecified
Attachment #281547 - Attachment description: Proposed fix → Proposed fix [Checkin: Comment 4]
Comment on attachment 318489 [details] [diff] [review]
generated, npotb
[Checkin: Comment 17]


http://hg.mozilla.org/mozilla-central/rev/f04505b82293
Attachment #318489 - Attachment description: generated, npotb → generated, npotb [Checkin: Comment 17]
(In reply to comment #17)
> http://hg.mozilla.org/mozilla-central/rev/f04505b82293

Iiuc, the (only) actual change (in this 185 kB patch) was the block at
http://hg.mozilla.org/mozilla-central/rev/f04505b82293#l1.3337

*****

Is this bug/fix specific to Mozilla tree,
or could/should it be upstreamed to MochiKit (too)?
Blocks: 427500
No longer blocks: 367390
Keywords: autotest-issue
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.