All users were logged out of Bugzilla on October 13th, 2018

Chinese characters in such blog pages written in UTF format cannot be displayed correctly

RESOLVED INCOMPLETE

Status

()

RESOLVED INCOMPLETE
11 years ago
8 years ago

People

(Reporter: hyedward, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01], URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

Nearly all chinese blog pages containing both traditional and simplified chinese characters, cannot be fully displayed correctly, with many characters in between displayed as "?", such as "关于车辆号码牌字体" is shown as "??车辆?码?字体". All the encoding settings were tried and cannot be solved. While using other browswes such as safari no problem was found.

Reproducible: Always

Steps to Reproduce:
1.Open firefox
2.Go to "http://www.upshine.net/type/"

Actual Results:  
You can see chinese characters are not fully displayed correctly
such as "关于车辆号码牌字体" is shown as "??车辆?码?字体".

Expected Results:  
such as "关于车辆号码牌字体" is shown as "关于车辆号码牌字体".

This problem is not found in my previously version of firefox, and firefox in PC platform, and other browsers in my same computers.

Comment 1

11 years ago
(Just to be clear the text referred to in 'actual results' above was the title of this article: http://www.upshine.net/type/2007/06/95 )

WFM 

old...
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-GB; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3 
new...
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-GB; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
intel...
Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-GB; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
and a minefield build I had from a couple of weeks back...
Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a6pre) Gecko/20070615 Minefield/3.0a6pre

It sounds more like you're missing glyphs in the font that firefox has selected for you. I see output like you describe in fontbook when I use the LiHei Pro font, but with several other fonts I have sitting here  it reads fine (Hei, Kai, STFangsong, STHeiti, STKaiti, STSong). You might want to try changing your font preferences?
(Reporter)

Comment 2

11 years ago
Hi,

Can you teach me how to change the display font in preference? I didn't change the default font and this problem never happened before.......
thanks

Edward
(Reporter)

Comment 3

11 years ago
Sorry, I have tried to change different fonts in Preference > Content > Font and Color,
that cannot change the font of the display text in such blog pages.
Problem still exist. Perhaps this is a bug happen only for seldom computer like mine
(Reporter)

Comment 4

11 years ago
Please note that changing font in preference only affect fonts in other webpages
like http://forum.hkgolden.com

but blog pages like
http://badtastesmellgood.blogspot.com/
texts are not affected and in this page there are about 1/20 of chinese characters cannot be shown. 楊德昌 is shown as 楊?昌
this is annoying and I am gonna given up using firefox if things can't be solved

Comment 5

11 years ago
I can verify this bug.  For example, the url http://www.myetone.com/review29904.htm is particularly distorted; I have taken a screenshot of Firefox 2.0.0.6 rendering the page on Mac OS X 10.4.10, which is available here:

http://csbd.org/~atp/firefox.png

and another, of the same page as rendered by Safari, available here:

http://csbd.org/~atp/safari.png

I use Linux primarily, and this problem does not manifest itself; similarly, Firefox on Windows works fine.  It appears to be a Mac OS X only problem.

The problem is not one of not having the right fonts installed, as Safari clearly demonstrates -- not only does it show every glyph on exactly the same system, but it also chooses 1 font for most of the text.  While it is not particularly easy to see on the screenshot I've provided, Firefox is in fact mixing a number of different fonts to produce the text.

It appears as though the characters Firefox fails to find a glyph for are always simplified characters, but the behavior is not consistent: not all simplified glyphs fail to render, just some.  At first I thought that perhaps the simplified glyphs it was displaying properly were ones that also happened to be Japanese characters (there's a fair bit of overlap), but on the top of the page, the white characters in the green bar that precede the text entry widget show otherwise: the "词" in "请输入关键字词" is a simplified form found only on the mainland, but not in Japan.  Perhaps it is worth noting in passing that as I type this in the entry form, the above displays as "??入关?字词", just like on the screenshot I've provided.  This suggests that the bug is relatively repeatable and consistent, and not tied to this web page particularly.

For Chinese speaking audiences, this bug is a show-stopper -- it makes reading even simple Chinese web pages impossible.  As you'll note from the screenshot, Firefox already fails to display the formatting of the page properly -- probably a result of IE-centrism on the part of the web developer.  That much, I can perhaps overlook, as I know the fault lies with them and not with Firefox.  But when I can't even read an article because a great number of glyphs do not display, well -- imagine if the letters "u", "v", and "l" just didn't display!  Would you still use Firefox?

This bug is a big deal, and it's been around for as long as I've used Firefox on the Mac.

Comment 6

11 years ago
I just downloaded the most recent nightly of firefox 3.0, and this glyph selection problem, along with other formatting issues (such as bug 393904), is fixed in that build.  If you are experiencing these problems, try one of the builds at

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/

我刚下载了FIREFOX3了,新版本里该问题不存在了,若您想如此解决,请点以上的连结而下载苹果管用的FIREFOX3-MAC。警戒:新版本不一定稳定,最新的稳定版本为FIREFOX2,FIREFOX3可能还会有一些错误。但是,从我个人的角度来看,它已经很好使了,在看中文网站的情况下已经比FIREFOX2好一百倍了。
(Reporter)

Comment 7

11 years ago
is the firefox 3.0 a tested version and will not cause any error on my computer? I will try, as the latest version 2.0.0.7 still cannot get rid of this annoying error when I browse through chinese blog pages in blogspot.com
This is a mass search for bugs that are in the Firefox General component, are UNCO, and have not been changed for 1000 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10, create a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you still see the bug, please update this bug. If the issue is gone, please set the resolution to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
No reply from reporter, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.