Crash at startup [@ strgcmps.dll] [@ nsCookieService::CreateTable]

RESOLVED WORKSFORME

Status

Thunderbird
Installer
--
critical
RESOLVED WORKSFORME
11 years ago
7 years ago

People

(Reporter: Chef Chaudart, Unassigned)

Tracking

({crash})

Trunk
x86
Windows XP
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: INVALID, crash signature)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a6pre) Gecko/20070702 Minefield/3.0a6pre
Build Identifier: version 3.0a1pre (20070630)

Just click on Thunderbird icon,  and direct crash, with no TB

Reproducible: Always

Steps to Reproduce:
1.click on Thunderbird
2.
3.
Actual Results:  
Crash

Expected Results:  
to open Thunderbird

Comment 1

11 years ago
WFM version 3.0a1pre (20070701)
Version: unspecified → Trunk
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> WFM version 3.0a1pre (20070701)
> 

Today partial update works fine,  and TB starts like a charm.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
not clear what fixed this -> works for me
Resolution: FIXED → WORKSFORME
(Reporter)

Comment 4

11 years ago
I was wrong, it still crashes, but now with tb : TB33699132Y
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
strgcmps.dll + 0x37f4 (0x017837f4)
nsCookieService::CreateTable  [mozilla/netwerk/cookie/src/nscookieservice.cpp, line 548]
nsCookieService::InitDB  [mozilla/netwerk/cookie/src/nscookieservice.cpp, line 444]
nsCookieService::Init  [mozilla/netwerk/cookie/src/nscookieservice.cpp, line 406]
nsCookieService::GetSingleton  [mozilla/netwerk/cookie/src/nscookieservice.cpp, line 358]
nsComponentManagerImpl::GetService  [mozilla/xpcom/components/nscomponentmanager.cpp, line 1928]
CallGetService  [mozilla/xpcom/build/nscomponentmanagerutils.cpp, line 84]
nsCOMPtr<nsICookieService>::operator=  [mozilla/dist/include/xpcom/nscomptr.h, line 748]
nsHttpChannel::AsyncOpen  [mozilla/netwerk/protocol/http/src/nshttpchannel.cpp, line 3552]
nsXMLHttpRequest::Send  [mozilla/content/base/src/nsxmlhttprequest.cpp, line 1721]
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash
Summary: Crash at startup → Crash at startup [@ strgcmps.dll] [@ nsCookieService::CreateTable]

Comment 6

11 years ago
reporter: i suspect strgcmps isn't supposed to exist how did you install  ThunderbirdTrunk/2007070204? and what version did you have before?
Component: General → Installer
QA Contact: general → installer
Whiteboard: INVALID

Comment 7

11 years ago
strgcmps.dll appears to be a seamonkey component.
I see it in all my seamonkey builds, but not in the Thunderbird folders.
(Reporter)

Comment 8

10 years ago
(In reply to comment #6)
> reporter: i suspect strgcmps isn't supposed to exist how did you install 
> ThunderbirdTrunk/2007070204? and what version did you have before?
> 

I used to install it thru the update procedure.  But sorry, this problem has disappeared.
(Reporter)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago10 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
(Assignee)

Updated

7 years ago
Crash Signature: [@ strgcmps.dll] [@ nsCookieService::CreateTable]
You need to log in before you can comment on or make changes to this bug.