Persona is no longer an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 386604 - test case does not display HI
: test case does not display HI
Status: RESOLVED DUPLICATE of bug 122795
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: Jet Villegas (:jet)
Depends on:
  Show dependency treegraph
Reported: 2007-07-02 10:39 PDT by Ray Kiddy
Modified: 2007-07-03 10:04 PDT (History)
6 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---

the test using   instead of padding (644 bytes, text/html)
2007-07-02 22:42 PDT, dolphinling
no flags Details
Testcase that shows the problem a little more clearly (299 bytes, text/html)
2007-07-03 10:03 PDT, Boris Zbarsky [:bz] (still a bit busy)
no flags Details

Description Ray Kiddy 2007-07-02 10:39:21 PDT
I am on a 2.16 GHz Intel Core Duo with Mac OS X 10.4.9 with 2 GB RAM.

This test case, in both a MinefieldDebug build and with, does not display "HI" as it should.

In Opera 9.20, this displays "HI".
Comment 1 Boris Zbarsky [:bz] (still a bit busy) 2007-07-02 21:35:35 PDT
As far as I can tell, the test is wrong...  Certainly the first two lines we're rendering as we should, as far as I see.  I'm not sure why the 4em right padding is not affecting the third line to give even more blue, but in any case I wouldn't expect "HI" here.
Comment 2 dolphinling 2007-07-02 22:42:27 PDT
Created attachment 270693 [details]
the test using   instead of padding

Boris: It seems to me the test is correct. In the attached testcase I removed the padding and added three  s after the span, and there's a very visible "HI".

The CSS 2.1 spec says (
"... the right-most generated box of the last line box in which the element appears has the right padding, right border and right margin."

It seems to me then that the 3em of padding after the span should take up exactly the same space the 3  s do in the modified test.
Comment 3 Boris Zbarsky [:bz] (still a bit busy) 2007-07-03 10:03:25 PDT
Created attachment 270747 [details]
Testcase that shows the problem a little more clearly

Ah, it seems I can't count to 11.  :(

This testcase clearly shows that the issue is that the padding affects line breaking in all the lines, even though it's only applied to the last line.
Comment 4 Boris Zbarsky [:bz] (still a bit busy) 2007-07-03 10:04:39 PDT
And this is a duplicate.

*** This bug has been marked as a duplicate of bug 122795 ***

Note You need to log in before you can comment on or make changes to this bug.