Closed Bug 386639 Opened 13 years ago Closed 13 years ago

All day event dates are not displayed due to missing entitiy "AllDay" in dateFormat.properties

Categories

(Calendar :: Calendar Views, defect)

defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ssitter, Assigned: martinschroeder)

References

Details

(Keywords: regression)

Attachments

(1 file)

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.5pre) Gecko/2007070212 Calendar/0.7pre

Steps to reproduce:
1. Create all day event.

Actuall result:
No dates displayed in unifinder, tooltip, agenda, ... Console shows:

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.GetStringFromName]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///D:/Programme/sunbird/js/calDateTimeFormatter.js :: formatTime :: line 176"  data: no]
Source File: file:///D:/sunbird/js/calDateTimeFormatter.js
Line: 176

Works in Sunbird 0.7pre (2007070208)
Fails in Sunbird 0.7pre (2007070212)

Regression from Bug 352433 that removed AllDay from dateFormat.properties.
Summary: All day events are not displayed in due to missing entitiy "AllDay" → All day event dates are not displayed due to missing entitiy "AllDay" in dateFormat.properties
Attached patch Patch v1Splinter Review
Absolutely my fault. I should have checked MXR for the use of this string.
Assignee: nobody → mschroeder
Status: NEW → ASSIGNED
Attachment #270710 - Flags: review?
Attachment #270710 - Flags: review? → review+
Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.7
Verified using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.7pre) Gecko/20070825 Calendar/0.7pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.