control-shift click on a bookmark should open new tab in background

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
12 years ago
9 years ago

People

(Reporter: abillings, Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
In the current trunk builds, if a user in Windows does a control-shift click on a bookmark, the context menu for the bookmark link comes up. According to Litmus and my test on 2.0.0.4, this should open the link in the background as a new tab.

Steps to Reproduce

1. Open Firefox and load a page.
2. Select a bookmark link (from the Bookmark toolbar or bookmark sidebar) by holding down control and shift while clicking on it.

Expected Result: New tab should open in background and load the bookmark's url.

Actual Result: right click context menu comes up for bookmark link. No tab is opened.

Found in the A6 candidate build:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a6) Gecko/20070629 GranParadiso/3.0a6
(Reporter)

Comment 1

12 years ago
This happens with the History sidebar as well.
Component: Tabbed Browser → Places
QA Contact: tabbed.browser → places
This WFM here with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007070222 Minefield/3.0a7pre

Comment 3

11 years ago
WFM too
Mozilla/5.0 (Windows; U; Windows NT 6.0; it; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Resolving WFM, looks like it all works right here...
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

11 years ago
I'm still seeing this is OS X.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b3pre) Gecko/2007122604 Minefield/3.0b3pre

If I hold down control and shift and click on a link in my sidebar, I get a context menu.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 6

11 years ago
Doh. This was a windows issue. Behavior is by design on the Mac.

Closing.
Status: REOPENED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

11 years ago
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.