Can not build firefox from jhbuild

RESOLVED DUPLICATE of bug 387239

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 387239
11 years ago
11 years ago

People

(Reporter: Ariel Rios, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.4) Gecko/20061201 Firefox/2.0.0.4 (Ubuntu-feisty)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.4) Gecko/20061201 Firefox/2.0.0.4 (Ubuntu-feisty)

Mozilla: Cannot build 
System Details: ariel@dell:~$ uname -a
Linux dell 2.6.20-16-generic #2 SMP Thu Jun 7 20:19:32 UTC 2007 i686 GNU/Linux
GNOME 2.19 svn 
Ubuntu 7.04

Compilation problem:
make[4]: Entering directory `/opt/svn/gnome2-20/mozilla/content/canvas/src'
nsCanvasRenderingContext2D.cpp
c++ -o nsCanvasRenderingContext2D.o -c  -DMOZILLA_INTERNAL_API
-DOSTYPE=\"Linux2.6\" -DOSARCH=\"Linux\" -DBUILD_ID=0000000000
-D_IMPL_NS_LAYOUT  -I../../../dist/include/xpcom -I../../../dist/include/string
-I../../../dist/include/gfx -I../../../dist/include/layout
-I../../../dist/include/widget -I../../../dist/include/dom
-I../../../dist/include/js -I../../../dist/include/locale
-I../../../dist/include/unicharutil -I../../../dist/include/webshell
-I../../../dist/include/uriloader -I../../../dist/include/htmlparser
-I../../../dist/include/necko -I../../../dist/include/view
-I../../../dist/include/pref -I../../../dist/include/docshell
-I../../../dist/include/xpconnect -I../../../dist/include/xuldoc
-I../../../dist/include/caps -I../../../dist/include/editor
-I../../../dist/include/imglib2 -I../../../dist/include/mimetype
-I../../../dist/include/exthandler -I../../../dist/include/uconv
-I../../../dist/include/intl -I../../../dist/include/plugin
-I../../../dist/include/cairo -I../../../dist/include/libpixman
-I../../../dist/include/content -I../../../dist/include
-I../../../dist/include/nspr    -I../../../dist/sdk/include    -fPIC  
-fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align
-Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor
-Wno-long-long -pedantic -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -O
-I../../../dist/include/cairo -I/opt/gnome2-20/include/gtk-2.0
-I/opt/gnome2-20/lib/gtk-2.0/include -I/opt/gnome2-20/include/atk-1.0
-I/opt/gnome2-20//include/cairo -I/opt/gnome2-20/include/pango-1.0
-I/opt/gnome2-20/include/glib-2.0 -I/opt/gnome2-20/lib/glib-2.0/include
-I/opt/gnome2-20/include -I/usr/include/freetype2 -I/usr/include/libpng12    
-DMOZILLA_CLIENT -include ../../../mozilla-config.h
-Wp,-MD,.deps/nsCanvasRenderingContext2D.pp nsCanvasRenderingContext2D.cpp
/opt/gnome2-20/include/pango-1.0/pango/pangocairo.h:58: error:
‘cairo_font_type_t’ was not declared in this scope
/opt/gnome2-20/include/pango-1.0/pango/pangocairo.h:60: error:
‘cairo_font_type_t’ does not name a type
make[4]: *** [nsCanvasRenderingContext2D.o] Error 1
make[4]: Leaving directory `/opt/svn/gnome2-20/mozilla/content/canvas/src'
make[3]: *** [libs] Error 2
make[3]: Leaving directory `/opt/svn/gnome2-20/mozilla/content/canvas'
make[2]: *** [libs] Error 2

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Updated

11 years ago
Component: Build Config → GFX: Thebes
Product: Firefox → Core
QA Contact: build.config → thebes
Most likely not a mozilla bug; if pangocairo.h needs cairo.h included or whatever, it should include it itself (if that's what's going on).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID

Updated

11 years ago
Duplicate of this bug: 400416

Comment 3

11 years ago
Lots of people have hit this and it's actually a dup of bug 387239. Reopening to dup it there.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 387239
You need to log in before you can comment on or make changes to this bug.