Closed Bug 386713 Opened 13 years ago Closed 12 days ago

reftest text-font-weight-01.svg fails on linux

Categories

(Core :: SVG, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla79
Tracking Status
firefox79 --- fixed

People

(Reporter: longsonr, Assigned: longsonr)

Details

(Keywords: testcase)

Attachments

(1 file)

 
Looks like lighter does not work on that platform. The text seems to be all bold.
This worked in firefox 2.0 as the SVG text implementation used cairo directly rather than thebes then.
Keywords: regression, testcase
This works on my machine, so I think the test should really be marked random rather than failing.
In that case it probably isn't a regression then. Perhaps some change to the font-family would fix it on the linux tinderboxes.
Keywords: regression
I changed it to random-if rather than fails-if since I'm tired of hitting it every time I run reftests.
Assignee: nobody → longsonr
Status: NEW → ASSIGNED
Pushed by longsonr@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/921a30cac33b
Mark text-font-weight-01.svg passing on linux r=dholbert
Status: ASSIGNED → RESOLVED
Closed: 12 days ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla79
You need to log in before you can comment on or make changes to this bug.