Refresh crash reporter icons on Windows and OS X

VERIFIED FIXED in mozilla1.9.2a1

Status

()

Toolkit
Crash Reporting
--
enhancement
VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: marcia, Assigned: faaborg)

Tracking

({verified1.9.1})

Trunk
mozilla1.9.2a1
verified1.9.1
Points:
---
Bug Flags:
wanted1.9.1 ?
blocking1.9 -
wanted1.9 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [icon-3.1][icon-complete][icon-3.6])

Attachments

(3 attachments, 3 obsolete attachments)

Seen using Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a7pre) Gecko/200707030404 Minefield/3.0a7pre.

STR:
1. Crash
2. On the Mac I get the Software Update icon in the dock when I crash. confusing for a moment since I thought i was getting a software update

luser indicates the icon would have to be cross platform icon. I guess there is an icon on windows but I never notice it.
nominating to get this on the radar, not sure if the icon is being refreshed as part of the UI piece.
Flags: blocking1.9?
There was mention of icons at today's meeting - I want to make sure this gets on the Icon Radar. adding alex...
(Assignee)

Comment 3

10 years ago
Thanks, adding the icon inventory

Updated

10 years ago
Assignee: nobody → faaborg
Flags: blocking1.9? → blocking1.9+

Comment 4

10 years ago
This doesn't look like a blocker to me, will revisit if there is an uproar :)
Flags: blocking1.9+ → blocking1.9?

Updated

10 years ago
Flags: blocking1.9? → blocking1.9-
Whiteboard: wanted-1.9

Updated

10 years ago
Flags: wanted1.9+
Whiteboard: wanted-1.9
If we're not going to get a new icon in time, what would people think about using the Minefield bomb icon here?  No good for a shipping product?
Good idea - much better than the updater's icon. Although devs and nightly users may be momentarily confused...
I don't see the Crash Reporter icon called out on the latest icon inventory - http://people.mozilla.com/~faaborg/files/20080210-iconsM2i4/m2i4.png_large.png. I personally think it is confusing to see the same icon you see for software update that you see when you crash.
(Assignee)

Comment 8

10 years ago
>I don't see the Crash Reporter icon called out on the latest icon inventory -
>http://people.mozilla.com/~faaborg/files/20080210-iconsM2i4/m2i4.png_large.png.
>I personally think it is confusing to see the same icon you see for software
>update that you see when you crash.

The sheets are used just to compare the icons we have and are a little out of date, full inventory is here:

http://people.mozilla.com/~faaborg/files/granParadisoUI/icons/iconInventoryStatus.html

>what would people think about using the Minefield bomb icon here?

A cartoon bomb feels a little too flippant since the user may have just experienced data loss.

I was thinking maybe a red cross icon, some kind of disaster relief connotation.  Other ideas that came up when I talked to Sam included a stethoscope (kind of complicated) and a magnifying glass and puff of clouds (a bit ephemeral).
I kind of like the smart crash reporter icon on this page - http://www.icondrawer.com/icons.php. Perhaps a variation of that could be worked at, since it gives the impression of something being sent. Just a thought.

Comment 10

10 years ago
please stay away from crosses. thanks.
Yeah, the Red Cross is finicky about people using the logo, and in any case the metaphor's wrong anyway.
Keywords: icon
OS: Mac OS X → All
Hardware: PC → All
Will this be in next theme update for Mac or will it make it for final? Just want to keep it on my radar.
(Assignee)

Comment 13

10 years ago
Unfortunately I don't believe this has any chance of making final at this point.
Flags: wanted1.9.1?
For Firefox 3.1 we are going to try to finally get around to creating a crash reporter icon (current it just uses a copy of the software update icon).  This leads to the question of what metaphor to use.  I was thinking about maybe a puff of smoke or a black box, but I haven't landed on an idea that I think is particularly good.

A couple aspects we need to consider:

-Since the user might have just been interrupted while doing something important, we probably don't want to be too flippant (Crash! Bang! Boom!).

-I'm not sure if we want to create something that is too memorable since it will inevitably become the symbol of our failure (blue screen of death).  Instead of people saying "I'm sick of Firefox crashing" they will say "I'm sick of the [insert metaphor we select here]"

Ideas?

Comment 15

9 years ago
A black-and-white sad fox? :-)

Being serious, if you don't want something memorable then I suggest the Firefox logo (or whatever branding logo is in use with the program, eg. the globe or thunderbird) with the red-circle and white-line "wrong way" or "restricted area" symbol on top in the lower corner to indicate an error.
I admit that its a good idea to have something similar to the application icon because of an additional reason. If we would use a totally different icon, users wont probably assign that one to one of our applications. So we could place the bullet error icon at the bottom right corner on top of the applications default icon?

http://mxr.mozilla.org/mozilla-central/source/toolkit/themes/winstripe/global/console/bullet-error.png
I was thinking something parallel to the updater icon, which uses two arrows in a circle on top of the blank globe icon. Perhaps an exclamation icon or something badged on top of the globe?
I should note that since this icon is part of the mozilla platform, we can't make any direct reference to Firefox in the icon itself.  Or we could make two icons like we do in other places (DMG icon, html document), one branded and one unbranded.

Comment 19

9 years ago
(In reply to comment #18)
> I should note that since this icon is part of the mozilla platform, we can't
> make any direct reference to Firefox in the icon itself.  Or we could make two
> icons like we do in other places (DMG icon, html document), one branded and one
> unbranded.

In that case (and assuming you still want something that doesn't have a chance of becoming a meme like BSoD or Sad Mac) I side with the unbranded globe with an exclamation sign badged on top in the lower right corner, like Ted suggested.
Created attachment 340915 [details]
unbranded icon with exclamation mark or error bullet

Proposal with unbranded logo and exclamation mark or error bullet on top. Having two arrows under the overlay icon looks a bit cramped IMHO.
Now that Alex has put up this post -> http://blog.mozilla.com/faaborg/2008/12/16/new-os-x-icons-made-by-sofa/, it looks like the icon issue will be resolved for 3.1.  Perhaps this bug can now be closed out even though it was filed back in the 3.0 days.
That only shows a Mac icon. Hopefully we can get one for each platform.
(In reply to comment #22)
> That only shows a Mac icon. Hopefully we can get one for each platform.

Tango versions are done and in Alex' possession for about a month now :)
(Assignee)

Updated

9 years ago
Whiteboard: [icon-3.1]
Created attachment 356659 [details]
Crash Reporter icon for OS X

This file should replace the current file at toolkit/crashreporter/client/macbuild/contents/resources/crashreporter.icns

I'll be posting a new file once I can confirm that icons in the dock can not exceed 128x128, but we can fix that in a follow up bug, and I want to get the new artwork in for beta 3.
Created attachment 356660 [details]
Crash Reporter icon for Windows

This file should replace toolkit/crashreporter/client/crashreporter.ico
Created attachment 356664 [details]
Crash Reporter icon for Linux

I actually have no idea how icons are packaged on linux, or where the current linux crash reporter icon is checked in (and I have to admit I'm getting rather curious).  Attached are png source images, in case anyone knows where these are supposed to land.
(Assignee)

Updated

9 years ago
Keywords: checkin-needed
(In reply to comment #26)
> I actually have no idea how icons are packaged on linux, or where the current
> linux crash reporter icon is checked in (and I have to admit I'm getting rather
> curious).

That's because we don't currently have a crash reporter icon on Linux. Somebody should file a bug to get crashreporter_linux.cpp using gtk_window_set_icon().
(Assignee)

Updated

9 years ago
Attachment #356659 - Flags: ui-review+
(Assignee)

Updated

9 years ago
Attachment #356660 - Flags: ui-review+
r=me to check in these new icons. Thanks! They go here:
http://mxr.mozilla.org/mozilla-central/source/toolkit/crashreporter/client/macbuild/Contents/Resources/crashreporter.icns
http://mxr.mozilla.org/mozilla-central/source/toolkit/crashreporter/client/crashreporter.ico

I filed bug 473363 on making the Linux crash reporter use an icon.
http://hg.mozilla.org/mozilla-central/rev/89de1e025c5a
Severity: normal → enhancement
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Keywords: checkin-needed, icon
Resolution: --- → FIXED
Summary: Improve crash reporter icon for FF 3 → Improve crash reporter icons on Windows and OS X
Target Milestone: --- → mozilla1.9.2a1

Updated

9 years ago
Attachment #356659 - Flags: approval1.9.1?

Updated

9 years ago
Attachment #356660 - Flags: approval1.9.1?

Updated

9 years ago
Attachment #340915 - Attachment is obsolete: true
Will the Windows icon be updated to 256x256?
Firefox support Windows 2000.
Windows 2000 does not support 32-bit icons.

8-bit icons are not included in crashreporter.exe (32-bit icons only). 
I think that 8-bit icons are necessary.

Updated

9 years ago
Attachment #356660 - Flags: approval1.9.1?
>Will the Windows icon be updated to 256x256?

We have source artwork up to that size, however it seems unlikely that the crash reporter would currently need an icon of this resolution.  It primarily appears in the task bar and title bar (16x16), and possible in a UAC window (32x32).  User's aren't likely to place a shortcut to crash reporter on their desktop, or look at the application in windows explorer (I actually couldn't find it myself, so I'm not sure where it is packaged).  So I think it makes sense to only include smaller resolutions to reduce our download size, am I missing an important use case for high resolution icons? 

>8-bit icons are not included in crashreporter.exe (32-bit icons only). 
>I think that 8-bit icons are necessary.

Yeah, I need to fix the file to include those.  Reopening and assigning to myself.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
crashreporter.exe lives next to firefox.exe. I don't think it's important to have high-resolution icons for it.
Also, do we really need approval to land these on 1.9.1? It's an icon-only change. I'd say just land them.
Regarding the Mac Crash Reporter icon, I just wanted to note that while the design is nice, it does not really stand out in the dock because of the color scheme.
Comment on attachment 356659 [details]
Crash Reporter icon for OS X

a191=beltzner
Attachment #356659 - Flags: approval1.9.1? → approval1.9.1+

Updated

9 years ago
Keywords: checkin-needed
That goes for all the icons; yeah, they can just land (though that's not the general rule; just mean to say that that approval goes for all the new crash reporter icons)
Keywords: checkin-needed
It's really hard to recognize anything in the 16x16 version for Windows. :/
(Assignee)

Updated

9 years ago
Whiteboard: [icon-3.1] → [icon-refresh][icon-3.1]
What's left do to here? Can we please get a clear statement of what's left to land, and who's on deck to land it, and then get those landings done and have this bug marked FIXED and fixed-1.9.1?
Keywords: checkin-needed
The resolution of the Mac icon looks fine using the latest trunk version Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090414 Minefield/3.6a1pre.

The resolution of the Windows Vista icon looks funky as it appears in the task bar (does not look symmetrical), but if we are okay with that I say go ahead and land the icons.
>What's left do to here? Can we please get a clear statement of what's left to
>land, and who's on deck to land it, and then get those landings done and have
>this bug marked FIXED and fixed-1.9.1?

I'm planning on recreating the .icns and .ico files to not include the larger resolutions so we don't bloat our download size.  However, this won't result in any user perceptible change so we can handle it with a follow up bug that just swaps the files.  Not sure what the lag is in getting these to even initially land.
Summary: Improve crash reporter icons on Windows and OS X → Refresh crash reporter icons on Windows and OS X
Can you recreate those icons today?  Let's get this done.

What about Marcia's comment 40 regarding the Vista task bar appearance?
yep, working on it now.  I'll be creating the new icon files from scratch so that should fix the alignment problem marcia mentioned.
The 16x16 source artwork really isn't that great, as a few people have pointed out.  I'm going to mark this [icon-3.6] so we can create a brand new set for Windows next time.  On the bright side, these are at least more applicable than the old software update icon.

I'll post the new files soon, just working on low bit versions for our windows 95 users.
(Assignee)

Updated

9 years ago
Whiteboard: [icon-refresh][icon-3.1] → [icon-refresh][icon-3.1][icon-3.6]
Created attachment 373046 [details]
Updated icon file for OS X

This reduces the size of the file, including on resolutions up to 128x128 (the maximum display size in the dock)
Attachment #356659 - Attachment is obsolete: true
Created attachment 373047 [details]
Updated icon file for Windows

This reduces the size of the file, only including resolutions up to 48x48 (tile display mode in XP).  Also, this icon file now includes 8-bit and 4-bit versions for backwards compatibility.

The artwork for crash reporter on Windows will likely be replaced in a future release, instead of just copying the OS X artwork over like we are currently doing (also the 16x16 version is a little hard to decipher).
Attachment #356660 - Attachment is obsolete: true
(Assignee)

Updated

9 years ago
Whiteboard: [icon-refresh][icon-3.1][icon-3.6] → [icon-3.1][icon-complete][icon-3.6]
checkin-needed for OS X and Windows
What is there to check in? Is there a applyable Hg diff?
http://hg.mozilla.org/mozilla-central/rev/0b785f2a7960
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Attachment #373046 - Flags: approval1.9.1?
Attachment #373047 - Flags: approval1.9.1?

Updated

9 years ago
Attachment #373046 - Flags: approval1.9.1? → approval1.9.1+

Updated

9 years ago
Attachment #373047 - Flags: approval1.9.1? → approval1.9.1+
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/68e0511ecb02
Keywords: fixed1.9.1
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090508 Minefield/3.6a1pre {Build ID: 20090508155925}
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1b5pre) Gecko/20090508 Shiretoko/3.5b5pre {Build ID: 20090508043756}

This looks good on Windows 2000.
Verified fix on trunk and 191 nightly.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1pre) Gecko/20090528 Shiretoko/3.5pre Ubiquity/0.1.5

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090528 Shiretoko/3.5pre
Status: RESOLVED → VERIFIED
Keywords: fixed1.9.1 → verified1.9.1
You need to log in before you can comment on or make changes to this bug.