WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed: nsMsgDBFolder.cpp, line 4130

RESOLVED WORKSFORME

Status

MailNews Core
Database
RESOLVED WORKSFORME
11 years ago
6 years ago

People

(Reporter: Scott MacGregor, Unassigned)

Tracking

Trunk
x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2012-07-01])

(Reporter)

Description

11 years ago
I frequently get a warning in the console from:

nsMsgDBFolder::ApplyRetentionSettings

  if (!mDatabase)
  {
    rv = GetDatabase(nsnull);
    NS_ENSURE_SUCCESS(rv, rv);
    weOpenedDB = PR_TRUE;
  }

because we are unable to get the database for a folder.

* The folder in question is the Trash folder for my RSS account.
* tbird is configured to empty trash on exit for RSS.
* I frequently find that I don't have a .msf file for my RSS trash folder.

Periodically the purge service calls nsMsgDBFolder::ApplyRetentionSettings on the RSS trash folder which triggers the attempt to get the database and since it doesn't exist and we asked not to create it, we trigger the warning in the console.
(Reporter)

Comment 1

11 years ago
I don't know if this is the intended behavior or not, but when ApplyRetentionSettings fires for my RSS trash folder, I always have a Trash folder with 0 bytes and a .msf file of 0 bytes. These two files were created with 0 bytes at startup.

When we try to open the database, even though we call GetDatabaseWOReparse (aCreate is 0, aleaveInvalidDB is 1), we delete the summary file because it has 0 bytes. nsMsgDatabase::Open sets deleteInvalidDB and removes the file.

so when I'm done I'm left with a folder called Trash and no corresponding .msf file.

oh and the error code returned to ApplyRetentionSettings is NS_MSG_ERROR_FOLDER_SUMMARY_MISSING.

(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Comment 2

6 years ago
Is this still happening in current TB?

Comment 3

6 years ago
David Bienvenu, what do you think of this? Outdated?
Component: Backend → Database
QA Contact: backend → database
Whiteboard: [CLOSEME 2012-07-01]

Comment 4

6 years ago
(In reply to :aceman from comment #3)
> David Bienvenu, what do you think of this? Outdated?

oh, yes, I think alta88 fixed this at some point.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.