If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash [@ libthebes.so + 0x4352e] [@ libsuitetypeaheadfind.so + 0x86ea] during Find As You Type

VERIFIED WORKSFORME

Status

()

Core
Graphics
--
critical
VERIFIED WORKSFORME
10 years ago
6 years ago

People

(Reporter: tonymec, Unassigned)

Tracking

({crash, stackwanted})

Trunk
x86
Linux
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a7pre) Gecko/2007070301 SeaMonkey/2.0a1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a7pre) Gecko/2007070301 SeaMonkey/2.0a1pre - Build ID: 2007070301

TB33711031W


Reproducible: Didn't try

Steps to Reproduce:
I don't expect this to happen "every time". What I did was:
1. browse to http://fr.wikipedia.org/wiki/G%C3%A9n%C3%A9alogie_g%C3%A9n%C3%A9rale_des_Cap%C3%A9tiens
2. Hit /
3. Type "Amboise" (without the quotes)
Actual Results:  
crash (at some point while typing the search key)


Expected Results:  
FAYT should have proceeded normally


Crash data follows:

Incident ID: 33711031
Stack Signature	libthebes.so + 0x4352e (0xb668b52e) cf867379
Product ID	MozillaTrunk
Build ID	2007070301
Trigger Time	2007-07-03 19:13:50.0
Platform	LinuxIntel
Operating System	Linux 2.6.18.8-0.3-default
Module	libthebes.so + (0004352e)
URL visited	http://fr.wikipedia.org/wiki/G%C3%A9n%C3%A9alogie_g%C3%A9n%C3%A9rale_des_Cap%C3%A9tiens
User Comments	(Find As You Type) /Amboise
Since Last Crash	5 sec
Total Uptime	5 sec
Trigger Reason	SIGSEGV: Segmentation Fault: (signal 11)
Source File, Line No.	N/A
Stack Trace 	
libthebes.so + 0x4352e (0xb668b52e)
libthebes.so + 0x21709 (0xb6669709)
libwidget_gtk2.so + 0x1d307 (0xb5cfe307)
libgkgfxthebes.so + 0x5a34 (0xb5ba2a34)
libgkgfxthebes.so + 0x51f6 (0xb5ba21f6)
libgklayout.so + 0x15b7d6 (0xb68257d6)
libgklayout.so + 0x15db76 (0xb6827b76)
libgklayout.so + 0x160ee8 (0xb682aee8)
libgklayout.so + 0x161045 (0xb682b045)
libgklayout.so + 0x15ad59 (0xb6824d59)
libgklayout.so + 0x10758b (0xb67d158b)
libsuitetypeaheadfind.so + 0x86ea (0xb57e06ea)
libsuitetypeaheadfind.so + 0x91e9 (0xb57e11e9)
libsuitetypeaheadfind.so + 0x9842 (0xb57e1842)
libgklayout.so + 0x2c4221 (0xb698e221)
libgklayout.so + 0x2de385 (0xb69a8385)
libgklayout.so + 0x2de524 (0xb69a8524)
libgklayout.so + 0x2de62d (0xb69a862d)
libgklayout.so + 0x2defb0 (0xb69a8fb0)
libgklayout.so + 0x10ae35 (0xb67d4e35)
libgklayout.so + 0x10b70b (0xb67d570b)
libgklayout.so + 0x3eb053 (0xb6ab5053)
libgklayout.so + 0x3ec789 (0xb6ab6789)
libgklayout.so + 0x3e6786 (0xb6ab0786)
libwidget_gtk2.so + 0x23b6e (0xb5d04b6e)
libwidget_gtk2.so + 0x1f9d4 (0xb5d009d4)
libwidget_gtk2.so + 0x1fe1c (0xb5d00e1c)
libgtk-x11-2.0.so.0 + 0x1321b0 (0xb7b961b0)
libgobject-2.0.so.0 + 0x9c0b (0xb792bc0b)
libgobject-2.0.so.0 + 0x1ad3d (0xb793cd3d)
libgobject-2.0.so.0 + 0x1c00f (0xb793e00f)
libgobject-2.0.so.0 + 0x1c415 (0xb793e415)
libgtk-x11-2.0.so.0 + 0x245b18 (0xb7ca9b18)
libgtk-x11-2.0.so.0 + 0x255ba7 (0xb7cb9ba7)
libgtk-x11-2.0.so.0 + 0x258c0c (0xb7cbcc0c)
libgtk-x11-2.0.so.0 + 0x1321b0 (0xb7b961b0)
libgobject-2.0.so.0 + 0x8407 (0xb792a407)
libgobject-2.0.so.0 + 0x9c0b (0xb792bc0b)
libgobject-2.0.so.0 + 0x1b383 (0xb793d383)
libgobject-2.0.so.0 + 0x1c00f (0xb793e00f)
libgobject-2.0.so.0 + 0x1c415 (0xb793e415)
libgtk-x11-2.0.so.0 + 0x245b18 (0xb7ca9b18)
libgtk-x11-2.0.so.0 + 0x12b68a (0xb7b8f68a)
libgtk-x11-2.0.so.0 + 0x12c857 (0xb7b90857)
libgdk-x11-2.0.so.0 + 0x4202a (0xb7a0802a)
libglib-2.0.so.0 + 0x2dde2 (0xb78bade2)
libglib-2.0.so.0 + 0x30e1f (0xb78bde1f)
libglib-2.0.so.0 + 0x31385 (0xb78be385)
libwidget_gtk2.so + 0x22195 (0xb5d03195)
libwidget_gtk2.so + 0x34fb6 (0xb5d15fb6)
libwidget_gtk2.so + 0x353cc (0xb5d163cc)
libxpcom_core.so + 0x6a928 (0xb7e51928)
libxpcom_core.so + 0x2dd2f (0xb7e14d2f)
libwidget_gtk2.so + 0x35123 (0xb5d16123)
libtoolkitcomps.so + 0x278f (0xb7f9478f)
libxul.so + 0x2a4b8 (0xb7eb54b8)
seamonkey-bin + 0x97f (0x0804897f)
libc.so.6 + 0x15f9c (0xb749ff9c)
Keywords: crash
Version: unspecified → Trunk

Comment 1

10 years ago
This looks more like a GFX: Thebes / Widget: GTK issue, given the stack. Can you try crashing in a nightly build (as opposed to an hourly build) so we have symbols for the stack?
Component: Keyboard: Find as you Type → GFX: Thebes
Keywords: stackwanted
QA Contact: keyboard.fayt → thebes
(In reply to comment #1)
> This looks more like a GFX: Thebes / Widget: GTK issue, given the stack. Can
> you try crashing in a nightly build (as opposed to an hourly build) so we have
> symbols for the stack?
> 

1. I only use nightly builds. This build, in particular, was downloaded from ftp://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/latest-trunk/ . Can you arrange that SeaMonkey trunk nightlies be built "with symbols"?
2. I use Find As You Type a lot, but this is a once-off event. I don't know how many times I'll have to retry before it happens again.

Comment 3

8 years ago
Works fine for me using Firefox trunk and Seamonkey 2.0. (Ubuntu 9.10)

For future bug reports, you should be able to use about:crashes, now that both Firefox and Seamonkey use Breakpad.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.6pre) Gecko/20091114 SeaMonkey/2.0.1pre - Build ID: 20091114000507

Been a long time since last I saw this. I'm marking VERIFIED but with the usual caveats on a sporadic bug now marked WFM: anyone sees this in a _current_ build, feel free to REOPEN with a Breakpad stack and as much info as possible to reproduce the bug.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

6 years ago
Crash Signature: [@ libthebes.so + 0x4352e] [@ libsuitetypeaheadfind.so + 0x86ea]
You need to log in before you can comment on or make changes to this bug.