Closed Bug 386838 Opened 15 years ago Closed 15 years ago

Cannot select text twice in readonly textboxes

Categories

(Core :: DOM: Editor, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla1.9alpha8

People

(Reporter: ventnor.bugzilla, Assigned: peterv)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

After the landing of bug 237964, you can only select text once in readonly textareas. When you try to select text again in the same textbox, there is no "selection" background colour, but other than that everything seems to work.
Flags: blocking1.9?
Duplicate of this bug: 386825
Attached patch v1Splinter Review
The main fix is in FindEditableRoot/FindSelectionRoot, it needs to return a root for readonly editors too to allow selection. The other changes are because inputs have their own selection controller, which can't be QI'ed to the presshell.
Assignee: nobody → peterv
Status: NEW → ASSIGNED
Attachment #271531 - Flags: superreview?(jst)
Attachment #271531 - Flags: review?(jst)
Attachment #271531 - Flags: superreview?(jst)
Attachment #271531 - Flags: superreview+
Attachment #271531 - Flags: review?(jst)
Attachment #271531 - Flags: review+
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
OS: Linux → All
Hardware: PC → All
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9beta1
Flags: blocking1.9?
Flags: in-testsuite?
Depends on: 432025
You need to log in before you can comment on or make changes to this bug.