nsSVGSVGElement doesn't initialize all of its members

RESOLVED FIXED

Status

()

Core
SVG
RESOLVED FIXED
11 years ago
5 years ago

People

(Reporter: Robert Sayre, Assigned: Robert Sayre)

Tracking

unspecified
x86
Windows XP
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

11 years ago
Created attachment 270937 [details]
Purify UMR

This could be a symptom of other bugs filed on nsSVGOuterSVGFrame:

https://bugzilla.mozilla.org/buglist.cgi?query_format=specific&order=relevance+desc&bug_status=__open__&content=nsSVGOuterSVGFrame

but the members should probably be initialized anyway.
(Assignee)

Updated

11 years ago
Summary: nsSVGOuterSVGFrame doesn't initialize all of its members → nsSVGSVGElement doesn't initialize all of its members
(Assignee)

Comment 1

11 years ago
Created attachment 270938 [details] [diff] [review]
initialize members
Assignee: nobody → sayrer
Status: NEW → ASSIGNED
Attachment #270938 - Flags: superreview?(tor)
Attachment #270938 - Flags: review?(tor)

Updated

11 years ago
Attachment #270938 - Flags: superreview?(tor)
Attachment #270938 - Flags: superreview+
Attachment #270938 - Flags: review?(tor)
Attachment #270938 - Flags: review+
(Assignee)

Comment 2

11 years ago
Checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Flags: in-testsuite-
Duplicate of this bug: 381200
You need to log in before you can comment on or make changes to this bug.