User interface is much larger than usual.

RESOLVED DUPLICATE of bug 394103

Status

()

RESOLVED DUPLICATE of bug 394103
12 years ago
11 years ago

People

(Reporter: jleedev, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a7pre) Gecko/2007070404 Minefield/3.0a7pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a7pre) Gecko/2007070404 Minefield/3.0a7pre

Everything is really big.

The menubar, toolbar, tab bar, and status bar are much taller than these elements in other programs on the system.
Menus have a wide left gutter.
Toolbar images appear to be scaled up twice their normal size.
Images on web pages are zoomed in, but the page zoom, even at 100%, does not change this.

Reproducible: Always

Steps to Reproduce:
1. Set your system DPI setting to 147
2. Launch firefox
Actual Results:  
Everything is really big.

Expected Results:  
Firefox should not enlarge user interface elements more than other programs.
(Reporter)

Comment 1

12 years ago
Created attachment 270939 [details]
Screenshot on Linux
(Reporter)

Comment 2

12 years ago
Created attachment 270941 [details]
Screenshot on Windows

Comment 3

12 years ago
bug 350194 ?
(Reporter)

Comment 4

12 years ago
Perhaps, but not exactly. In the screenshot of bug 350194, the toolbar images are shown at their normal size and the tab bar is not scaled vertically. Here, increasing the DPI setting does cause these effects.
Created attachment 286683 [details]
Seems to be ok with 2007103104 nightly build

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a9pre) Gecko/2007103004 Minefield/3.0a9pre

WFM, maybe?
(Reporter)

Comment 6

11 years ago
Created attachment 286685 [details]
After lowing the gconf DPI

I just downloaded <Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a9pre) Gecko/2007103004 Minefield/3.0a9pre>.

There are two places to set the DPI setting. One is in gconf and the other is set by the X server from the monitor itself.

$ xdpyinfo |grep resolution
  resolution:    147x145 dots per inch
$ gconftool -g /desktop/gnome/font_rendering/dpi
147

Lowering the gconf DPI results in smaller fonts in the UI, but the toolbar icons, the menubar, and the contents of web pages are still zoomed in.
(Reporter)

Comment 7

11 years ago
Created attachment 303106 [details]
Firefox 3 Beta 3 in Linux

Just to note, this is still here in Firefox 3 Beta 3 in a clean installation of Ubuntu.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 394103
You need to log in before you can comment on or make changes to this bug.