external protocol request crashes when opening an avi

RESOLVED INCOMPLETE

Status

--
critical
RESOLVED INCOMPLETE
11 years ago
2 years ago

People

(Reporter: djpnewton, Unassigned)

Tracking

({crash, testcase})

Trunk
x86
Windows XP
crash, testcase

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007070404 Minefield/3.0a7pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007070404 Minefield/3.0a7pre

I am using the nsIExternalProtocolService to open an avi file and it crashes firefox/xulrunner on the latest trunk :(

It may be how it is interacting with windows media player on my machine (??), I am not sure.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

11 years ago
Created attachment 270974 [details]
testcase (needs to be able to get UniversalXPConnect privileges)
(Reporter)

Updated

11 years ago
Attachment #270974 - Attachment description: testcase → testcase (needs to be able to get UniversalXPConnect privileges)
(Reporter)

Comment 2

11 years ago
Created attachment 270992 [details]
windbg exeception analysis
(Reporter)

Comment 3

11 years ago
Created attachment 270994 [details]
nvcpl.dll info

The exception seems to be comming from nvcpl.dll (NVidia Control Panel applet)

Comment 4

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007070504 Minefield/3.0a7pre

This works for me on current trunk. I saved the file locally, chose an AVI video to open, then clicked "open file". Looks like you didn't get an actual stacktrace from the windbg analysis. Can you try again? You might also want to check out http://developer.mozilla.org/en/docs/Using_the_Mozilla_symbol_server.
Keywords: crash
(Reporter)

Comment 5

11 years ago
(In reply to comment #4)
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007070504
> Minefield/3.0a7pre
> 
> This works for me on current trunk. I saved the file locally, chose an AVI
> video to open, then clicked "open file". Looks like you didn't get an actual
> stacktrace from the windbg analysis. Can you try again? You might also want to
> check out http://developer.mozilla.org/en/docs/Using_the_Mozilla_symbol_server.
> 

The stack trace doesnt seem to show much.

From WinDbg:
    0:000> k
    ChildEBP RetAddr  
    WARNING: Stack unwind information not available. Following frames may be wrong.
    00000000 00000000 nvcpl!DllCanUnloadNow+0xc7a

Do you have an nvidia graphics card?
I get no crash with a current nightly build, do you still get this crash with 3.01 ?
Keywords: testcase
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
(Assignee)

Updated

2 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.