[Proto] wrong days highlighted in the pattern preview

RESOLVED WORKSFORME

Status

--
minor
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: andreas.treumann, Assigned: berend.cornelius09)

Tracking

Details

(Reporter)

Description

12 years ago
STEPS TO REPRODUCE:
===================

- create a new event
- open the 'edit event' dialog
- open the custom recurrence dialog
- choose daily repeat pattern and 'create 5 appointments'
- check the preview

RESULT:
=======

- the are some wrong days highlighted. If the first day of the pattern is the 10th of the month, the 10th of the next two moths are also highlighted in the pattern preview  

EXPECTED RESULT:
================

- only the days which match with the pattern should highlighted

REPRODUCIBLE:
=============

- always
(In reply to comment #0)
> If the first day of the pattern is the 10th of the month, the 10th of
> the next two moths are also highlighted in the pattern preview

This might be the similar issue as in Bug 386563 caused by Bug 386502 depending on how you get the occurrences for each minimonth preview. 
Could you check the regression range for this issue?
(Reporter)

Comment 2

12 years ago
The first version with both bugs, this and Bug 386563, was build 20070629.

Comment 3

12 years ago
I have a similar (but different) problem with the prototype event dialog.  This is with the 0.5 release, not the pre0.7 nightlies.  To reproduce:

1) Create a new event for 10 July 2007.  Don't change anything in the dialog except Category and "recurs weekly".  Save.

2) Edit (all occurrences), click on "Repeat" dropdown, choose Custom.


31 July 2007 is not highlighted, but should be.
31 August 2007 is highlighted, but shouldn't be.
(Reporter)

Comment 4

12 years ago
Bug 386502 is fixed and verified since a few days and I could not reproduce this issue anymore. I mark this issue 'worksforme'.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.