Run Filters on Folder not working correctly

RESOLVED WORKSFORME

Status

Thunderbird
General
--
major
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: Robert Joy, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

1.95 KB, text/plain
Details
(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; InfoPath.1)
Build Identifier: 1.5.0.12

I have a message filter that has been working for well over a year. Just recently it has stopped working. Not sure what changed but if I use "Message Filters..." on the Tools menu and hit the "Run Now" button it still works but it does not work as the email is coming into the inbox nor does it work if I do "Run Filters on Folder" from the Tools menu. Actually I'm not even sure it is limited to just this one filter. It may be all the filters.

Reproducible: Always

Steps to Reproduce:
1. Tools -> Run Filters on Folder
Actual Results:  
No filtering.

Expected Results:  
Should move offending email to Junk folder.

This is the filter text: OTHR_WAM1681512
What is your filter trying to do? Please give us your match criteria and the actions which are performed. And what version of Thunderbird are you using? We cannot help with such less information. Thanks.
(Reporter)

Comment 2

11 years ago
Body contains WAM1681512 move message to Junk on Local Folders

As I said before this used to work and now it doesn't. The filter was not changed.

The version of Thunderbird is included above now and I'll state it here as well: 1.5.0.12

Thanks!
Version: unspecified → 1.5
Can you run a test or better upgrade to Thunderbird 2.0.0.4? Can you reproduce it with our last official release? Could you attach the msgFilterRules.dat which is not working? I'll then try to reproduce.
Oh, does that happen with the automatically update to a more secure version? Perhaps it could be a regression. If you know which version of Thunderbird 1.5 was working you should also try out that one.
(Reporter)

Comment 5

11 years ago
Created attachment 271452 [details]
Message Filter file

Here's the file you requested.
Attachment #271452 - Attachment mime type: application/octet-stream → text/plain
Comment on attachment 271452 [details]
Message Filter file

There are no filters in it. Do you have attached the correct file?
(Reporter)

Comment 7

11 years ago
Created attachment 271519 [details]
The real message filter file

Sorry, I grabbed the wrong one before.
Attachment #271452 - Attachment is obsolete: true
Attachment #271519 - Attachment mime type: application/octet-stream → text/plain

Comment 8

11 years ago
haven't examined the filter file, but the description is reminiscent of bug 201244 / bug 355537.

Comment 9

10 years ago
Robert, 
What do you see in tools>options>advanced>update-tab>show update history?  
Did you determine in which update it started failing, and whether it affects just one or ALL filters?
(Reporter)

Comment 10

10 years ago
I'm sorry Wayne. I should have ask you guys to closed this bug as it seems only related to ver 1.5. I upgraded to version 2.0 and it all seems to be working again.
(Reporter)

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.