Closed Bug 387013 Opened 13 years ago Closed 13 years ago

Cursor does not appear in Gmail rich text message box (since contentEditable)

Categories

(Camino Graveyard :: HTML Form Controls, defect)

PowerPC
macOS
defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED
Camino2.0

People

(Reporter: hbridge+bugzilla, Assigned: stuart.morgan+bugzilla)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.9a6pre) Gecko/20070701 Camino/2.0a1pre (like Firefox/3.0a6pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.9a6pre) Gecko/20070701 Camino/2.0a1pre (like Firefox/3.0a6pre)

On the 2.0 nightlies, the cursor does not appear at all in the rich formatting text box (it does appear in the Plain text compose view).  This makes it very hard to use gmail, and to test against bug 377104 (ghost cursors.)  

Reproducible: Always

Steps to Reproduce:
1. Install 2.0 Nightly
2. Open Gmail (or Docs and Spreadsheets)
3. Click New Mail
4. Switch to rich text formatting
5. Click inside the window and type text
Actual Results:  
No cursor appears in the box to let you know your insertion point.

Expected Results:  
Cursor should appear at insertion point.
This is probably fall-out from bug 237964. 
Am I missing something here? I thought rich text mode was a Firefox only feature of GMail. Why is this set to Product set to Camino?
Sorry, ignore that comment. TroblueshootCamino was opening the wrong app. 
Does Firefox trunk have this problem?
(In reply to comment #4)

There have been various reports in the forums about similar problems in Minefield, although I don't see the problem (with Gmail) in the 2007070420 Minefield build (I do see the issue in Camino 2007070210 (2.0a1pre) - the latest available build).

Can we get a regression range on this?  And if it turns out to have appeared when contentEditable landed, is it the same as bug 387534?
Regressed between 2007062712 and 2007062722.

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-06-27+11%3A00%3A00&maxdate=2007-06-27+22%3A00%3A00&cvsroot=%2Fcvsroot 

That's bug 237964. I suspect it is the same as bug 387534; but someone with more knowledge about rich-text editors should confirm that. (although 2 of the 3 testcases there crash my Minefield build.).
...which is in turn a dupe of bug 387380, for posterity.
(In reply to comment #9)

Yes. 

fwiw, there appears to be a similar bug report about XULRunner: bug 391429.
Let's go ahead and confirm this, then, and twiddle all the flags and whatnot.  If it turns out this is also bug 391429, we can do duping then.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking1.9?
Keywords: regression
Summary: Cursor does not appear in rich formatting compose text box → Cursor does not appear in Gmail rich text message box (since contentEditable)
Target Milestone: --- → Camino2.0
Erm, I see that peterv added                                                                                 

res/contenteditable.css
res/designmode.css

to basebrowser-mac-macho when bug 237964  landed. I'm not sure that will fix this bug, but we'll need to package them, too.                                                    
I'm still experiencing this issue with Version 2007081901 (2.0a1pre).
(In reply to comment #13)

Good catch.
I added those 2 files to my res folder. Gmail's rich text editor now shows the cursor correctly.
I did a quick comparative test between Camino and Minefield (sending myself rtf messages) and see no other problem in Camino. Disclaimer: I never use the rich text mode, it is possible I missed something.


Let's see if we can't get a project patch in for this quickly and then everyone can make sure that Rich Text Mode is working fine (and then cancel our blocking request).
Whiteboard: [needs project patch]
This gives me a cursor in Google Docs again, so it's got my vote.
Attachment #277354 - Flags: superreview?(mark)
Flags: blocking1.9?
Whiteboard: [needs project patch]
Patch looks right to me ;)
Assignee: nobody → stuart.morgan
Attachment #277354 - Flags: superreview?(mark) → superreview+
Landed
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Now works for me (although I'm still getting some ghost cursors, I'll reopen that bug).  Thanks!
You need to log in before you can comment on or make changes to this bug.