Closed Bug 387041 Opened 13 years ago Closed 13 years ago

Livemark of Mono Feed is not handled correctly

Categories

(Firefox :: Bookmarks & History, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 381357

People

(Reporter: polidobj, Unassigned)

References

()

Details

Attachments

(1 file)

The feed from Mono doesn't load when I make a Livemark for it.  The Feed Preview works ok.  

Actual Results:
My pre-existing livemark always says 'Live Bookmark loading...' three times.
A newly created livemark is just empty.  

Expected results:
Either show the contents of the feed or say it failed to load.  Also the feed preview and livemarks should handle feeds consistently.  

Here's the feed validator output:
This feed does not validate.

    *      line 22, column 44: author must include an email address: Mono Project (mono@novell.com) (30 occurrences) [help]

                <author>Mono Project (mono@novell.com)</author>
                                                      ^

In addition, this feed has an issue that may cause problems for some users. We recommend fixing this issue.

    *    Feeds should not be served with the "text/plain" media type [help]

The issue isn't so much if there's a problem with their as it is handling the situation correctly.
Flags: blocking-firefox3?
Attachment #271131 - Attachment mime type: application/octet-stream → text/plain
Also the feed works with Firefox 2.  
Status: NEW → RESOLVED
Closed: 13 years ago
Flags: blocking-firefox3?
Resolution: --- → DUPLICATE
Duplicate of bug: 360705
Well, no, it's only a duplicate of that if you don't actually care about having a working livemark, and your only interest in filing the bug was to ask that the feed preview only work on less than half the feeds on the web.
Duplicate of bug: 381357
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.