recovery from install to a nearly full disk fails

VERIFIED FIXED in mozilla0.9.1

Status

P1
major
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: slogan, Assigned: samir_bugzilla)

Tracking

({helpwanted, relnote})

Trunk
mozilla0.9.1
x86
Linux
helpwanted, relnote

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-] relnote-user Fix in hand)

(Reporter)

Description

19 years ago
I tried the Linux installer on a nearly full disk. At some point I got a dialog
stating that the install failed. The dialog could not be dismissed with its ok
button, and the UI appeared to not refresh indicating that the Gtk+ main loop
was not getting serviced.

Comment 1

19 years ago
reassigning to Samir
Assignee: ssu → sgehani
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M17

Comment 2

18 years ago
nsbeta3->helpwanted + accepting patches
relnotertm: ~If you don't have enough disk space the installer will give you 
a warning and stop responding.~
Keywords: helpwanted, nsbeta3, relnote, relnoteRTM
Is this still an issue given the updated space checking you added? I guess if 
there were other programs writing to disk you could still run out even if we 
appeared to have enough space to start with.

This is an edge case I could live with at this point (unfortunately).
Whiteboard: [nsbeta3-]
Whiteboard: [nsbeta3-] → [nsbeta3-] relnote-user
(Assignee)

Comment 4

18 years ago
*** Bug 59342 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
Priority: P3 → P1
Unsetting missed milestones to aid triage queries.
Target Milestone: M17 → ---
(Assignee)

Comment 6

18 years ago
*** Bug 74662 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

18 years ago
*** Bug 77130 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
Whiteboard: [nsbeta3-] relnote-user → [nsbeta3-] relnote-user Fix in hand
(Assignee)

Updated

18 years ago
Target Milestone: --- → mozilla0.9.1
(Assignee)

Comment 8

18 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 9

17 years ago
verified code fix (installer.ini)
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.