camino stops allowing creation of new windows

RESOLVED DUPLICATE of bug 393562

Status

Camino Graveyard
General
--
critical
RESOLVED DUPLICATE of bug 393562
11 years ago
11 years ago

People

(Reporter: Jay Rubin, Unassigned)

Tracking

Details

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.4) Gecko/20070509 Camino/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.4) Gecko/20070509 Camino/1.5

like the subject says. it's usually (but not always) after visiting a page with javascript. i will first lose the ability to open a new window with cmd-N, however, new windows still can be created from the menubar. every time after a few minutes and new windows that way, camino loses all ability to create new windows. restart is necessary.

Reproducible: Always

Steps to Reproduce:
i haven't seen a smoking gun, except some pages with javascript.

Comment 1

11 years ago
Are you running any haxies or input managers (in particular, something like CaminoSession)? If so, make sure to remove them, then try again.

If that still doesn't work, see if a fresh profile makes any difference:

http://pimpmycamino.com/parts/troubleshoot-camino

If that still doesn't work, we're going to need specific URLs where this happens in order to try to reproduce it.
(Reporter)

Comment 2

11 years ago
There isn't anything running like CaminoSession. I'm currently trying with Troubleshoot Camino.

Something I forgot to mention which just happened: after the lack of window events, clicking on links (sometimes, like i said, so far there's no pattern) will not follow the link. nothing happens. also, images refuse to load on pages as well.

there isn't any specific place or time it happens. i know that's not helpful for bug work, but that's what i've got now.

Comment 3

11 years ago
When you run into that, does resizing the window allow the contents to display? This might be a dupe of bug 350331.

cl
(Reporter)

Comment 4

11 years ago
resizing the window has no effect on new window creation, image loading or links. these might be three different issues, but quite odd that they all show up in succession.

checked 350331, it doesn't appear, from that description, to be the same bug.

Comment 5

11 years ago
Can you check console.log from the Console application in your Utilities folder, and see if Camino is logging messages when you have these issues?
(Reporter)

Comment 6

11 years ago
this is old, as i've been running for most of the afternoon with a new profile, with no trouble. i just switched back to the original profile. 

here are the latest camino log entries (from earlier):

2007-07-06 00:22:19.744 Camino[290] CFLog (21): GetDiskFragment returns -2851 for <Flash Player> when trying to load /Library/Internet Plug-Ins/Flash Player.plugin/Contents/MacOS/Flash Player
2007-07-06 00:22:19.747 Camino[290] CFLog (21): GetDiskFragment returns -2851 for <Default Plugin> when trying to load /Applications/Camino.app/Contents/MacOS/plugins/Default Plugin.plugin/Contents/MacOS/Default Plugin
2007-07-06 00:22:48.530 Camino[290] CFLog (21): GetDiskFragment returns -2851 for <Flash Player> when trying to load /Library/Internet Plug-Ins/Flash Player.plugin/Contents/MacOS/Flash Player
2007-07-06 00:22:48.534 Camino[290] CFLog (21): GetDiskFragment returns -2851 for <Default Plugin> when trying to load /Applications/Camino.app/Contents/MacOS/plugins/Default Plugin.plugin/Contents/MacOS/Default Plugin
2007-07-06 00:23:16.743 Camino[290] CFLog (21): GetDiskFragment returns -2851 for <Default Plugin> when trying to load /Applications/Camino.app/Contents/MacOS/plugins/Default Plugin.plugin/Contents/MacOS/Default Plugin
2007-07-06 00:23:52.576 Camino[290] -[BrowserWindowController loadWindow]: failed to load window nib file '/Applications/Camino.app/Contents/Resources/English.lproj/BrowserWindow.nib'.
2007-07-06 00:23:55.335 Camino[290] -[BrowserWindowController loadWindow]: failed to load window nib file '/Applications/Camino.app/Contents/Resources/English.lproj/BrowserWindow.nib'.
2007-07-06 00:25:51.554 Camino[290] -[BrowserWindowController loadWindow]: failed to load window nib file '/Applications/Camino.app/Contents/Resources/English.lproj/BrowserWindow.nib'.
2007-07-06 00:25:52.977 Camino[290] -[BrowserWindowController loadWindow]: failed to load window nib file '/Applications/Camino.app/Contents/Resources/English.lproj/BrowserWindow.nib'.
2007-07-06 00:25:53.753 Camino[290] -[BrowserWindowController loadWindow]: failed to load window nib file '/Applications/Camino.app/Contents/Resources/English.lproj/BrowserWindow.nib'.
2007-07-06 00:25:57.668 Camino[290] -[BrowserWindowController loadWindow]: failed to load window nib file '/Applications/Camino.app/Contents/Resources/English.lproj/BrowserWindow.nib'.
2007-07-06 00:26:00.052 Camino[290] -[BrowserWindowController loadWindow]: failed to load window nib file '/Applications/Camino.app/Contents/Resources/English.lproj/BrowserWindow.nib'.

Comment 7

11 years ago
That looks like your copy of Camino is physically damaged; try re-downloading Camino.
(Reporter)

Comment 8

11 years ago
I'm going to redownload now, but here's the log as it happened. same thing.
2007-07-07 12:25:06.673 Camino[3171] CFLog (21): GetDiskFragment returns -2851 for <Default Plugin> when trying to load /Applications/Camino.app/Contents/MacOS/plugins/Default Plugin.plugin/Contents/MacOS/Default Plugin
2007-07-07 12:25:08.452 Camino[3171] writePropertyListFile: Cocoa error 512. ((null))
2007-07-07 12:25:08.452 Camino[3171] writePropertyList: Failed to write file /Users/jay/Library/Application Support/Camino/bookmarks.plist
2007-07-07 12:25:12.997 Camino[3171] -[BrowserWindowController loadWindow]: failed to load window nib file 'BrowserWindow'.
2007-07-07 12:25:18.847 Camino[3171] writePropertyListFile: Cocoa error 512. ((null))
2007-07-07 12:25:18.847 Camino[3171] writePropertyList: Failed to write file /Users/jay/Library/Application Support/Camino/bookmarks.plist
2007-07-07 12:27:58.836 Camino[3171] -[BrowserWindowController loadWindow]: failed to load window nib file 'BrowserWindow'.
2007-07-07 12:28:01.033 Camino[3171] -[BrowserWindowController loadWindow]: failed to load window nib file 'BrowserWindow'.
2007-07-07 12:28:05.054 Camino[3171] -[BrowserWindowController loadWindow]: failed to load window nib file 'BrowserWindow'.
(Reporter)

Comment 9

11 years ago
using a brand new copy of Camino 1.5: just visited eHarmony, at least that's a specific URL and received the same no-window, no-images errors.

log entry:
2007-07-08 10:05:57.185 Camino[7254] writePropertyListFile: Cocoa error 512. ((null))
2007-07-08 10:05:57.185 Camino[7254] writePropertyList: Failed to write file /Users/jay/Library/Application Support/Camino/bookmarks.plist
2007-07-08 10:05:57.192 Camino[7254] writePropertyListFile: Cocoa error 512. ((null))
2007-07-08 10:05:57.192 Camino[7254] writePropertyList: Failed to write file /Users/jay/Library/Application Support/Camino/bookmarks.plist
2007-07-08 10:05:57.204 Camino[7254] writePropertyListFile: Cocoa error 512. ((null))
2007-07-08 10:05:57.204 Camino[7254] writePropertyList: Failed to write file /Users/jay/Library/Application Support/Camino/bookmarks.plist
2007-07-08 10:08:06.326 Camino[7254] Failed to save site icon cache index
2007-07-08 10:08:11.095 Camino[7254] -[BrowserWindowController loadWindow]: failed to load window nib file '/Applications/Camino.app/Contents/Resources/English.lproj/BrowserWindow.nib'.
2007-07-08 10:08:11.717 Camino[7254] -[BrowserWindowController loadWindow]: failed to load window nib file '/Applications/Camino.app/Contents/Resources/English.lproj/BrowserWindow.nib'.
2007-07-08 10:08:12.126 Camino[7254] -[BrowserWindowController loadWindow]: failed to load window nib file '/Applications/Camino.app/Contents/Resources/English.lproj/BrowserWindow.nib'.
2007-07-08 10:08:12.486 Camino[7254] -[BrowserWindowController loadWindow]: failed to load window nib file '/Applications/Camino.app/Contents/Resources/English.lproj/BrowserWindow.nib'.
2007-07-08 10:08:12.790 Camino[7254] -[BrowserWindowController loadWindow]: failed to load window nib file '/Applications/Camino.app/Contents/Resources/English.lproj/BrowserWindow.nib'.
2007-07-08 10:08:13.086 Camino[7254] -[BrowserWindowController loadWindow]: failed to load window nib file '/Applications/Camino.app/Contents/Resources/English.lproj/BrowserWindow.nib'.
2007-07-08 10:08:13.350 Camino[7254] -[BrowserWindowController loadWindow]: failed to load window nib file '/Applications/Camino.app/Contents/Resources/English.lproj/BrowserWindow.nib'.
2007-07-08 10:08:13.614 Camino[7254] -[BrowserWindowController loadWindow]: failed to load window nib file '/Applications/Camino.app/Contents/Resources/English.lproj/BrowserWindow.nib'.
2007-07-08 10:08:13.838 Camino[7254] -[BrowserWindowController loadWindow]: failed to load window nib file '/Applications/Camino.app/Contents/Resources/English.lproj/BrowserWindow.nib'.
2007-07-08 10:08:14.054 Camino[7254] -[BrowserWindowController loadWindow]: failed to load window nib file '/Applications/Camino.app/Contents/Resources/English.lproj/BrowserWindow.nib'.
2007-07-08 10:08:28.670 Camino[7254] -[BrowserWindowController loadWindow]: failed to load window nib file '/Applications/Camino.app/Contents/Resources/English.lproj/BrowserWindow.nib'.
2007-07-08 10:08:31.141 Camino[7254] -[BrowserWindowController loadWindow]: failed to load window nib file '/Applications/Camino.app/Contents/Resources/English.lproj/BrowserWindow.nib'.
2007-07-08 10:08:32.843 Camino[7254] -[BrowserWindowController loadWindow]: failed to load window nib file '/Applications/Camino.app/Contents/Resources/English.lproj/BrowserWindow.nib'.

Comment 10

11 years ago
It looks like something is seriously hosed with either Camino (possibly a corrupted download twice in a row, which seems unlikely) or your hard drive. I'd run Disk Utility and see if it finds anything wrong.
(Reporter)

Comment 11

11 years ago
the odds of a corrupted download 2x/row? that's near impossible. why do you say hard drive issue? i've run diskwarrior and disk utility and they both show nothing wrong...but i've been having general "weirdness" with the drive.

just saw this in the log:
2007-07-08 10:09:32.057 Camino[7254] Failed to archive image for https://bugzilla.mozilla.org/mozilla-16.png to file
2007-07-08 10:09:32.592 Camino[7254] Failed to save site icon cache index
2007-07-08 10:17:27.761 Camino[7254] Failed to archive image for https://secure.matchmaker.com/favicon.ico to file
2007-07-08 10:17:28.231 Camino[7254] Failed to save site icon cache index
2007-07-08 10:17:29.180 Camino[7254] Failed to archive image for http://www.matchmaker.com/favicon.ico to file
allocated at key 30801921

(yes, i'm single. lol.)

Comment 12

11 years ago
The fact that you both can't write files in the caches directory and can't read parts of Camino's bundle does indeed suggest a drive issue.
(Reporter)

Comment 13

11 years ago
so, it's not a camino issue at all, we think, but a sporadic, physical drive issue...

Comment 14

11 years ago
Right. Which makes this INVALID as far as being a Camino bug is concerned.

The fact that DiskWarrior and Disk Utility both fail to find anything is mildly worrying; you might want to try TechTool Pro and/or Apple's discussion forum for further troubleshooting.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
(Reporter)

Comment 15

11 years ago
i just want to understand this, for myself and for reported future camino issues. most recent log entry shows this:
2007-07-12 10:44:34.866 Camino[3316] CFLog (21): GetDiskFragment returns -2806 for <Flash Player> when trying to load /Library/Internet Plug-Ins/Flash Player.plugin/Contents/MacOS/Flash Player
2007-07-12 10:58:56.770 Camino[3316] CFLog (21): GetDiskFragment returns -2806 for <Flash Player> when trying to load /Library/Internet Plug-Ins/Flash Player.plugin/Contents/MacOS/Flash Player
2007-07-12 10:59:02.465 Camino[3316] CFLog (21): GetDiskFragment returns -2806 for <Flash Player> when trying to load /Library/Internet Plug-Ins/Flash Player.plugin/Contents/MacOS/Flash Player


that _still_ means it is a drive error? thanks for your help.

Jay Rubin

Updated

11 years ago
Duplicate of this bug: 390309

Comment 17

11 years ago
Other things to try before re-opening this:
- (re-)install the latest version of the Flash plugin
- try to reproduce this with a nightly build (<http://www.caminobrowser.org/download/releases/nightly/>)
(Reporter)

Comment 18

11 years ago
now camino is doing this EXACT same thing on a completely different machine. i no longer believe the hard drive on the powerbook where the problem initially began is in any way related.

happened when i visited nytimes.com, then msnbc.com with Version 2007050909 (1.5).

here's log file:
2007-08-04 03:45:35.275 Camino[616] writePropertyListFile: Cocoa error 512. ((null))
2007-08-04 03:45:35.275 Camino[616] writePropertyList: Failed to write file /Users/jay/Library/Application Support/Camino/bookmarks.plist
2007-08-04 03:47:47.722 Camino[616] Failed to archive image for http://nytimes.com/favicon.ico to file
2007-08-04 03:47:47.830 Camino[616] Failed to save site icon cache index
2007-08-04 03:47:51.105 Camino[616] -[BrowserWindowController loadWindow]: failed to load window nib file '/Applications/Camino.app/Contents/Resources/English.lproj/BrowserWindow.nib'.
2007-08-04 03:47:52.985 Camino[616] -[BrowserWindowController loadWindow]: failed to load window nib file '/Applications/Camino.app/Contents/Resources/English.lproj/BrowserWindow.nib'.


there IS a problem with javascript and camino.
Resolution: INVALID → INCOMPLETE

Comment 19

11 years ago
> there IS a problem with javascript and camino.

We have no concrete evidence of any kind that this is even remotely related to JS. Please don't derail the debugging process by asserting things we don't know about the cause.

From the wide spectrum of areas where disk access are failing, I wonder if *all* reads and writes are failing, and we are just seeing the places that log. Once you have reproduced this, if you visit a site with java, do you see output like comment 15 related to Java plugins instead of Flash?

Also, please run the following command in Terminal while Camino is running, and attach the resulting camino_mapped_libraries.txt file here using "Add an attachment" above.
vmmap Camino -w | grep __DATA > camino_mapped_libraries.txt
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
I am also seeing the same messages, both the "Failed to write" and, once Camino is unable to open new windows, the same 'failed to load window nib file' log messages. Restarting Camino fixes all.

I will run the vmmap command on the next failure.

Comment 21

11 years ago
If those of you seeing this could download and run:
escapedthoughts.com/camino/CaminoDiagnostics.zip
and attach the file it creates (using "Add an attachment"), it would help us start to narrow down (or at least eliminate) possible causes. (it includes the vmmap command I mentioned in comment #19, so there's no need to do that). It's fine to run while Camino is working normally, as long as you haven't added or removed any system/app modifiers or internet plugins since it last happened.

For my own reference, a report of this on IRC had the following:
Hacks: Menu Extra Enabler, Smart Crash Reports, ClearDock.ape, WindowShade X.ape, menufela.ape
(And the machine was PPC, on the offchance that turns out to be interesting)
Non-standard Plugins: eMusic, net.juniper.DSSafariExtensions, WebEx

Comment 22

11 years ago
Cameron and inbox@letterten.com, have you had a chance to run the diagnostic app yet?
I did run it against 1.5 when it bugged the last time, but 1.5.1 came out, so I deleted it and am waiting to see if it happens again with this version. (If you just want me to run it even while operating normally, I can do that right now.)

APE is not on this machine, fwiw.
(Reporter)

Comment 24

11 years ago
Have not had a chance yet. Will install later tonight. fyi, I moved from a PPC Powerbook to an Intel MBP and am seeing the exact same issues.
Created attachment 278000 [details]
Camino Diagnostics output

It happened tonight on 1.5.1 stable. Here is the Camino Diagnostics output.

Comment 26

11 years ago
On a hunch, I made a test app that runs through all available file descriptors, then tried the same call the bookmarks code makes and the error was indeed 512. That may or may not be a specific enough error number that it's telling, but it's certainly worth investigating.

The next time anyone get into this state, please run the following from the Terminal:
lsof | egrep '^Camino' > ~/Desktop/camino-lsof.txt
And then attach the camino-lsof.txt file from your Desktop here.

Thanks for your patience.
Created attachment 278159 [details]
lsof during new window lockout

I seem to be getting this more often recently. Here is the lsof output from tonight's.
Can someone blow away these attachments? I posted the wrong files.

Comment 30

11 years ago
This looks right to me, and it does show the file descriptor space almost completely saturated. Are the many documents under "Documents" things you downloaded, that are in your Downloads window still?
Status: UNCONFIRMED → NEW
Ever confirmed: true
I've privatized comment 28 as well as attachment 278159 [details], per the request of the reporter. They contain private information that wasn't meant to be exposed.
Thanks, Samuel!

Stuart: many are downloaded files, but not all of them. Some are just files I was browsing earlier, but they weren't open in any window when the lsof was run.

Curiously, if I keep banging on Camino for awhile, it will eventually overcome the issue. I noticed that tonight while I was playing with the options.

Comment 33

11 years ago
You beat me by a few seconds.

My sincere apologies for not considering the fact that this would gather
potentially sensitive information. Jay, if you (or anyone else) runs this
command, rather than posting the output if you could just answer the follow
questions about it:
1) In the fourth column from the left, in the column of numbers followed by a
letter, what is the last one (e.g, 46r, or 213u)?
2) Are the majority of the files in the list files that you have in your
Downloads window? If not, what are they (excluding all the entries that are
either /System/Library/... or /Library/Internet Plugins/...)

Comment 34

11 years ago
So in Cameron's case at least, this is, as I had hoped, largely covered by bug 393562, which I'll have a fix for shortly. It does sound like we may be leaking file descriptors of locally viewed files though (although that may be related to bfcache, and not an actual leak).

Leaving open for now to make sure other people's issues are primarily bug 393562, and to investigate locally opened files to see if there's another bug there that needs filing.
(In reply to comment #33)
> My sincere apologies for not considering the fact that this would gather
> potentially sensitive information.

No worries.

I think that bug 393562 seems the most likely explanation, because when I cleared my downloads list the number of files in the lsof listing dropped in half. Perhaps this could be a partial workaround?
(Reporter)

Comment 36

11 years ago
Created attachment 278195 [details]
diagnostic text output

expert user/tech, not expert debugger--kinda flying blind here. whole file posted, if you see anything sensitive, please kill the file (yes, i know how dumb that is, but i want to fix this).

this was run when camino was working just fine.

for the record: APE, Logitech Control Ctr, Growl, Flip4Mac, WindowShade, Silk and SmartScroll are installed.

I will rerun the diag when it goes kaflooey for comparison. sorry i can't interpret this files.

(also, when this happens, images either don't load or load really messed up. leaving camino to the finder and coming back in 10-15 seconds usually clears it up at least the first 2-3 times. after that, relaunch is necessary.)

Comment 37

11 years ago
(In reply to comment #36)
> I will rerun the diag when it goes kaflooey for comparison.

There's no need to do that, just the command in comment 26.

In the meantime, assuming you haven't cleared your downloads recently, how many do you have in the Downloads window? You can use:
grep sourceURL ~/Library/Application\ Support/Camino/downloads.plist | wc -l
rather than counting by hand if there are a lot.

(As an unrelated note, using CamiTools with 1.5 is asking for trouble; you can easily render Camino completely unusable with it.)
(Reporter)

Comment 38

11 years ago
Created attachment 278233 [details]
the latest output file...on an MBP.
(Reporter)

Comment 39

11 years ago
the download list is clear, sorry. i'm not using cami tools now, but i still have camitools installed .cep files in my search window. the output from 26 is attached.

Comment 40

11 years ago
(In reply to comment #38)
> the latest output file...on an MBP.

This is output from while you are having the problem (specifically, while you are seeing the log messages about being unable to load BrowserWindow.nib)? If so it's a completely different cause, and I'd suggest you remove all of your Input Managers, APE modules, etc. and try to reproduce it.

Comment 41

11 years ago
It looks like local files aren't a problem, so I'm going to close this as a duplicate of bug 393562. If anyone still has this problem after that lands, and on a non-haxied system, please file a new bug so we can start from a clean slate; this bug has a of information that's specific to what's now 393562.
Status: NEW → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 393562
You need to log in before you can comment on or make changes to this bug.