Crash on startup with existing Profile

VERIFIED FIXED

Status

Thunderbird
General
--
blocker
VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: Jim, Unassigned)

Tracking

({crash, regression})

Trunk
x86
Windows XP
crash, regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007070604 Minefield/3.0a7pre
Build Identifier: version 3.0a1pre (2007070605)

Trunk builds after 2007-07-05-05 are faulting at startup with an existing profile. Fault occurs in safemode. Fault occurs when starting using -profilemanager. After changing the name of the Thunderbird folder, forcing the creation of a new profile folder, Thunderbird starts. With the 2007-07-05-05 I was able to get Thunderbird to work with the old profile after having successfully started using a new profile. I have not been able to use this trick with the 2007070605 build.

Reproducible: Always

Steps to Reproduce:
1.Install build
2. Start Thunderbird
3.
Actual Results:  
Thunderbird faults (get a windows request to report the fault to Microsoft). No talkback generated.

Expected Results:  
Open existing profile.
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk
Jim, is talkback definitely activated? If yes, could you provide a better regression range? Which is the last official nightly which doesn't crash for you?
Keywords: crash

Comment 2

11 years ago
As far as I remember last good was 2007070303(or 04). The 2007070403(04?)-nightly didn't start then, that's why I can't provide the correct build-id. However, the tinderbox builds still start without any problems; currently I'm using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007070606 Thunderbird/3.0a1pre ID:2007070606

Comment 3

11 years ago
Confirmed under vista. It doesn't crash. It simply closes in tenths of seconds, in fact no talkback generated.
(Reporter)

Comment 4

11 years ago
I can't tell if it is activated at the time of the crash. It faults before any
window opens. All I get is the windows fault reporter, not talkback.

I am currently using 20070505 with my old profile but it took several
uninstall/reinstall cycles and creating a new profile folder structure before I
could get my old profile (the entire old profile folder structure) to work with
that build. I don't know what I did to make it work.

I haven't been able to find the secret sequence to get 2007070605 to work.

From the forum discussions I am not the only one seeing the problem of the
latest nightlies failing.

I know the 2007070316 build worked. I think the 7/4 nightly failed but I didn't
fool with it very loing as I (auto) installed it on Thursday morning and the
07/5 build was a soon available. In the process of trying to come up on the 7/5
build I went back to the 7/3/16 build and removed NTT (the only addon other
than talkback installed) but that didn't help.

Is there some debug option that can be set at run time that would gather more
information? It is obviously related to the profile folder structure. I was
hoping that knowing that "thunderbird -profilemanager" also faults would point
closer to where the problem is.
(Reporter)

Comment 5

11 years ago
As a test I started Thunderbird -profilemanager and created a new profile with just an RSS and Blogs account. I checked for updates and let the current (2007070605 I think) update download and install. At the completion of the update it looked like Thunderbird started and ended. Checking task manager, Thunderbird wasn't running. I started Thunderbird again and this time I got the Windows popup to report Thunderbird's fault to Microsoft. I then installed 2007070505 over top of the 20070706?? and Thunderbird came up OK. 

Comment 6

11 years ago
Confirming (Vista) and upping severity since it's a crash on startup
Severity: critical → blocker
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-thunderbird3?
Keywords: regression

Comment 7

11 years ago
Created attachment 271363 [details]
Stack trace

Stack trace from opt build + symbol server

Comment 8

11 years ago
Created attachment 271366 [details] [diff] [review]
add null check

The image suggests that the crash is caused here. Not sure if that's the same bug that Jim is seeing but let's see.
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Attachment #271366 - Flags: superreview?(roc)
Attachment #271366 - Flags: review?(roc)

Comment 9

11 years ago
(In reply to comment #5)
> As a test I started Thunderbird -profilemanager

I can't get the 20070706 build to run with or without the Profile Manager and have tried deleting the profile structure completely.

Comment 10

11 years ago
I just copied my old profile folder off to the side, uninstalled everything and then went back to a fresh install of the current trunk (2007070804). Once I installed, I copied the contents of the old default profile folder into the new one and Thunderbird then it opened fine with all my old messages.
Comment on attachment 271366 [details] [diff] [review]
add null check

+  NS_IF_RELEASE(sInstance);
   sInstance = nsnull;

Lose sInstance = nsnull, NS_IF_RELEASE does that
Attachment #271366 - Flags: superreview?(roc)
Attachment #271366 - Flags: superreview+
Attachment #271366 - Flags: review?(roc)
Attachment #271366 - Flags: review+

Updated

11 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 12

11 years ago
I cannot confirm that the bug is 'Resolved Fixed'. Today's, 12 July 2007 (2007071206?), nightly crashes immediately after start, without CrashReporter coming up, after clean install. However, the tinderbox build, 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007071208 Thunderbird/3.0a1pre ID:2007071208
runs without problems with my existing profile.
The fix was only checked in a few hours ago. The fix won't be apparent until tomorrow's nightly (or a current hourly build).
From Bonsai:

2007-07-12 06:57
enndeakin%sympatico.ca
mozilla/layout/xul/base/src/nsXULPopupManager.cpp
1.9
Component: General → Layout
Flags: blocking-thunderbird3?
Product: Thunderbird → Core
QA Contact: general → layout
Target Milestone: --- → mozilla1.9beta1

Comment 15

11 years ago
So I guess that means it missed today's nightly.

WINNT 5.2 tb-win32-tbox Depend release
Started 05:04, finished 08:13

Just another observation on the fact that hourly builds have worked consistently
throughout the last week.Could it be the fact that the houry build does not produce "Talkback" have some significance on what we are seeing.


Comment 16

11 years ago
Finally I got today's nightly
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007071305 Thunderbird/3.0a1pre ID:2007071305
to work with my standard profile. But only after I deleted manually every entry for "Thunderbird" / "ThunderbirdTrunk" etc. from the windows registry. The first attempt before, just download the nightly and install it in a fresh directory, without manipulating the registry first, wasn't successfull.

Comment 17

11 years ago
I couldn't get today's nightly to work (071305) after updated from 071223 hourly. It wouldn't even start.
Thomas, have you made a backup of all old entries from the ThunderbirdTrunk? Could you try to find out which entry causes the crash? 

Comment 19

11 years ago
Today's nightly doesn't crash on startup anymore (thanks Neil), but neither does it start up...

Scott - any chance you could take a look at this?
Status: RESOLVED → REOPENED
Flags: blocking1.9?
Resolution: FIXED → ---

Comment 20

11 years ago
(In reply to comment #18)
> Thomas, have you made a backup of all old entries from the ThunderbirdTrunk?

I'm sorry, but I didn't thought about that.

But I've tried to check, based on my memories, which entries Thunderbird made again to the registry after the re-install. What makes me wonder is that a certain pattern of entries is missing now, all like:
HKEY_LOCAL_MACHINE\SOFTWARE\FullCircle\TalkBack\MozillaOrgThunderbirdTrunkWin32200707070
There was a key for each nightly, and that means each and every day, I've installed. *Now* there's no such key at all. Of course, that does not necessarily mean that this key was the culprit.
(In reply to comment #20)
> again to the registry after the re-install. What makes me wonder is that a
> certain pattern of entries is missing now, all like:
> HKEY_LOCAL_MACHINE\SOFTWARE\FullCircle\TalkBack\MozillaOrgThunderbirdTrunkWin32200707070

Mmh, AFAIK Breakpad isn't already enabled on trunk for WinXP. Or have I missed something. Thomas you could install a nightly build from the last days and could try again to upgrade to the newest build. Perhaps you can reproduce the crash and find out which registry entries causes this bug.

Comment 22

11 years ago
(In reply to comment #21)
> could try again to upgrade to the newest build. Perhaps you can reproduce the
> crash and find out which registry entries causes this bug.

It's not that easy. Now as I've "cleaned up" the registry also the older, so far failing builds, e.g. Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007070705 Thunderbird/3.0a1pre ID:2007070705, now run fine...
Now trying to get Thunderbird to *not* start.
Assignee: enndeakin → nobody
Status: REOPENED → NEW
Component: Layout → General
Flags: blocking1.9?
Product: Core → Thunderbird
QA Contact: layout → general
Target Milestone: mozilla1.9beta1 → ---

Comment 23

11 years ago
OK, what I've found:
- the key I've mentioned in comment #20 has got nothing to do with the problem (I'm just running Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007071305 Thunderbird/3.0a1pre ID:2007071305 with the key still present in registry)
- whenever I upgrade from an 1.9a6 build to an 1.9a7 build Thunderbird does not start at all (-profilemanager or -safe-mode)
- when I download a full installer build I first have to start my standard profile in safe-mode, afterwards it starts in normal mode also

I don't have a clue what that might mean.

Comment 24

11 years ago
Seeing as you folks have done some work on this, I just tried updating from the old edition (nightly from 18th April) that I've been using for the last week or so, to the Thunderbird nightly for the 13th.  Watching what happens in Process Explorer, Thunderbird appears briefly and then disappears.  Same happens if I click my Thunderbird icon.  

Thunderbird doesn't appear on the computer screen at all, but it is briefly visible in Process Explorer (a fancy version of Task Manager that Microsoft endorse) .

Will revert to my trusty 18th April standby till y'all can get this sorted out!
(In reply to comment #23)
> - whenever I upgrade from an 1.9a6 build to an 1.9a7 build Thunderbird does not
> start at all (-profilemanager or -safe-mode)

Which builds are this exactly? Please give us the date.

> - when I download a full installer build I first have to start my standard
> profile in safe-mode, afterwards it starts in normal mode also

And that also appears when you create a fresh profile with the 1.9a6 build and upgrade to 1.9a7? Do you use always an installer? Does that also happen when using a zip archive?

Comment 26

11 years ago
Created attachment 272315 [details]
Process Monitor log

This is a process monitor log of a 20070714 trunk build as it starts up and then crashes. The last line of the log containing dwwin.exe is the windows crash reporting tool that pops up after Thunderbird has crashed.

Comment 27

11 years ago
It's not completely clear to me what exactly was causing this crash.
For the past week, I have been using the hourly builds with no problem.
However latest-trunk builds have reacted just as the above reporters.
Today I tried a partial update, which would not startup at all,
then overlaid with an houry build which worked normally as usual.
(the hourly builds apparantly do not install Talkback)
I then overlaid with the latest-trunk and everything worked fine.
I'm pretty sure the problem was that Talkback and breakpad can't coexist.
Scott's checkin for: # 379396 probably fixed this bug, but I won't be convinced
that extra steps won't be neccessary for nightly testers until the next update.

Comment 28

11 years ago
After installing the nightly from 20070714 over the top of a problem-free build from 20070704, Thunderbird still wouldn't start up until I ran it safe mode. Doing that once allows it to start up just fine. Note that safe-mode didn't fix the problem for nightly builds without the checkin for 379396.

I believe running in safe mode allows TB to 'fix' something talkback related that it can't do when run normally since talkback is running.

Are there some talkback files that the installer/updater should be cleaning up but aren't?
Could you run a diff on your profile folder and the registry path to see which data gets modified by starting Thunderbird in Safe Mode? 

Comment 30

11 years ago
Updating from 'fixed' 20070714 nightly to 20070715 via auto-update results in non-startup behaviour again.

I'll see if the installer works better - my previous upgrade in comment 28 was done via the installer, not auto update.

Comment 31

11 years ago
(In reply to comment #30)
> Updating from 'fixed' 20070714 nightly to 20070715 via auto-update results in
> non-startup behaviour again.
> 
> I'll see if the installer works better - my previous upgrade in comment 28 was
> done via the installer, not auto update.
> 

Installer build worked fine (straight off). There's something wrong with the auto update.

Comment 32

11 years ago
It's not just auto-update. If I clean out my Thunderbird directory and unzip a nightly build, it doesn't run at all. If I unzip a nightly build OVER a working install, then it also works. That says to me that a file(s) are missing from the build process. Further investigation reveals that indeed, extensions/talkback@mozilla.org is not being created with the auto-update, and it isn't included with the nightlies. Once you place the extensions/talkback@mozilla.org directory and subdirectories from another build it works fine.

Comment 33

11 years ago
Scott removed talkback from the builds. Bug 379396
So I think the logic should be that we should not be looking for talkback to be there. Hourly builds don't need talkback. Latest-trunk seems to be looking for it.
(Reporter)

Comment 34

11 years ago
After Autoupdate Thunderbird failed to start for me this morning, but I am not sure which nightly was downloaded (yesterdays {7/15} or todays {7/16}).

Did an uninstall (Windows add/remove programs) and an install with 7/16 trunk build.

Thunderbird started without fault on my existing profile. I didn't try any of last weeks builds. This is the first build since 2007-07-06-05 that has worked for me.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007071604 Thunderbird/3.0a1pre ID:2007071604
Nightly Tester Tools 1.3b2

Comment 35

11 years ago
Yep I can confirm uninstall Thunderbird through add/remove programs in control panel then install the latest nightly (071604) works. It started normal and no crash.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a7pre) Gecko/2007071604 Thunderbird/3.0a1pre ID:2007071604

Comment 36

11 years ago
I just found that over this same period of time that tbird has been crashing, I've also had some add-ons go bad, and it was throwing me off during troubleshooting.  It's been so long since that's happened to me in thunderbird, I didn't even think about it.  Sometimes when trying an update, I'd get a crash notification and an offer to send to microsoft, and other times, it would just exit.  I think the non-crash untimely exit was caused by add-ons? I don't know for sure.  I just thought I'd mention it in case anyone else is in the same situation while looking at this bug.   

NestedQuote Remover (some old version, i forgot to write down; newest works though, maybe the older one would have too)
Nightly Tester Tools 1.3b1
Remove Duplicate Messages 0.1.0.2
Update Channel Selector (I think this was disabled, now its uninstalled).

Comment 37

11 years ago
I have no extensions installed for Thunderbird.

I am able to unzip 20070715 trunk and run it fine, but if I autoupdate to 20070716 it won't start. Unizipping 20070716 over an unzipped 20070715 works. Deleting everything and unzipping a fresh 20070716 also works. However, autoupdating from 20070715 to 20070716 breaks. Not only that, but if I unzip a 20070716 over the 20070716 created by autoupdate, it is still broken. I'm confused.

20070715 --autoupdate-->20070716 BROKEN --unzip--> 20070716 = BROKEN
20070715 --unzip------->20070716 WORKING

Comment 38

11 years ago
(In reply to comment #37)

Based on evidence so far:

 - Auto update breaks TB
 - A clean full install/unzip works
 - An upgrade full install/unzip will fix a broken install if first run in safemode.

So, the following should work

20070715 --autoupdate-->20070716 BROKEN --unzip--> 20070716 = BROKEN --> start in safe mode -->WORKING --> start normally --> WORKING

(don't forget part of talkback installed as an extension, so safe-mode vs normal have slightly different code paths)

Comment 39

11 years ago
your different flows to get TB working are not working in my case.

Comment 40

11 years ago
Update from 20070716 to 20070717 through autoupdate --> FAILED

Uninstall 20070717 then install 20070717 again through installer --> FAILED

Uninstall 20070717 then install 20070716 through installer --> WORKING

Also can someone please change the OS field to Windows? It is effecting Windows Vista as well, not sure about other OS.

Comment 41

11 years ago
Sorry about the spam. I didn't read Doug Wright's post properly.

After installing 20070717 and start in safe mode, it worked. Then after starting Thunderbird normally, it also worked.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a7pre) Gecko/2007071705 Thunderbird/3.0a1pre ID:2007071705

Comment 42

11 years ago
Is this trunk only? I am getting a repeated attempt to update on startup with today's (last night's) "nightly" build on branch.

Comment 43

11 years ago
(In reply to comment #42)
> Is this trunk only? I am getting a repeated attempt to update on startup with
> today's (last night's) "nightly" build on branch.
> 

Don't know what bug you really want, but it's clearly not this one.

Comment 44

11 years ago
Actually, I think it is. I found this bug by reading up on the symptoms here:
http://forums.mozillazine.org/viewtopic.php?t=565839&postdays=0&postorder=asc&postsperpage=15&start=15

and downloaded a .zip build, which works fine.

Comment 45

11 years ago
A little more info
It appears xpcom.xpt is not created after an update
see http://forums.mozillazine.org/viewtopic.php?p=2970626#2970626

Comment 46

11 years ago
cc to ted to see if this is a packaging problem

Comment 47

11 years ago
Created attachment 272742 [details] [diff] [review]
possible fix

I just checked in this packaging change that I think might fix it based on some analysis work Joes did.
I totally don't understand the updater, but, those? Including xpcom_obsolete? Based on some questioning of bsmedberg, I would have said the problem was that he added xpcom.xpt to our removed-files.in, but unlike Firefox we actually have and use it, because in packages-static we have the xpts listed in the [xpcom] section.

Comment 49

11 years ago
Yes, note that the browser packages-static lists all the .xpt files in the [browser] section:

http://mxr.mozilla.org/mozilla/source/browser/installer/windows/packages-static#61

While the mail packages-static lists some in the [xpcom] section:
http://mxr.mozilla.org/mozilla/source/mail/installer/windows/packages-static#21

Moving those .xpt files to the [mail] section will probably fix the issues here. And attachment 272742 [details] [diff] [review] is definitely incorrect.

Comment 50

11 years ago
Created attachment 272807 [details] [diff] [review]
[checked in]possible fix

Thanks guys.

Based on Benjamin's comment. Moves the xpcom xpt files from [xpcom] to [mail].

One thing I'm not sure of, why does Thunderbird list these xpt files in our removed-files list? These files aren't listed for Firefox.
Attachment #272742 - Attachment is obsolete: true
Attachment #272807 - Flags: superreview?(benjamin)

Comment 51

11 years ago
Comment on attachment 272807 [details] [diff] [review]
[checked in]possible fix

Because tbird-windows at one point didn't xpt_link them together, while Firefox always has.
Attachment #272807 - Flags: superreview?(benjamin) → superreview+

Comment 52

11 years ago
Comment on attachment 272807 [details] [diff] [review]
[checked in]possible fix

I've checked this in, but folks won't see the fix until tomorrow's build.
Attachment #272807 - Attachment description: possible fix → [checked in]possible fix
Actually, they probably will: the Windows tinderbox has been hung since 2pm yesterday afternoon, so once it comes back (bug 388599) and stops burning from bug 388542, it should build a nightly.

Comment 54

11 years ago
Still not working right on branch either.

Comment 55

11 years ago
Trunk software update 17th to 18th downloaded 981kb
Worked fine. I'd say this bug is fixed.
My affected computer didn't manage to apply the partial (probably because I'd "experimented" a little too much with it), but the full update worked fine, so I'd agree, FIXED as far as I can tell.

Comment 57

11 years ago
I was bugged by this over the last two weeks. But I can confirm that with the 2007071815 build this bug is fixed. Thanks to all!

Comment 58

11 years ago
Based on comments and testing, marking fixed.
Status: NEW → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → FIXED
(Reporter)

Comment 59

11 years ago
Auto-update started without any problems. I would agree that this looks to be fixed.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007071815 Thunderbird/3.0a1pre ID:2007071815

Comment 60

11 years ago
Working here as well
Status: RESOLVED → VERIFIED

Comment 61

11 years ago
Working for Vista as well. Let's put this to bed. Thanks everybody.
You need to log in before you can comment on or make changes to this bug.