Crash dropping a abook card address in addressing pane

VERIFIED FIXED in M18

Status

MailNews Core
Composition
P2
critical
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: esther, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({crash, pp})

Trunk
x86
Linux
crash, pp

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-][cut 8/31][nsbeta2-])

(Reporter)

Description

18 years ago
Using build 2000-05-09 on linux if you drag an email address from the results 
pane of the Address Book to the Addressing pane of a New Msg you will crash if:

1. After the drop if drop in the wrong place 
2. Of if you close the compose window after a sucessful drop 
3. Or if you drop a 2nd address. 

Note: a separate bug has been logged for the drop location being flakey (bug
(Reporter)

Comment 1

18 years ago
Linux only 
Keywords: nsbeta2, pp
(Reporter)

Updated

18 years ago
QA Contact: lchiang → esther

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M16

Comment 2

18 years ago
Mass moving M16 to M17 - look for nsbeta2 before anything else.
Target Milestone: M16 → M17

Comment 3

18 years ago
Adding crash keyword
Keywords: crash

Comment 4

18 years ago
Putting on [nsbeta2+] radar for beta2 fix.   Can you get a stack trace from 
Talkback?
Whiteboard: [nsbeta2+]

Updated

18 years ago
OS: Windows 98 → Linux
Hardware: HP → PC

Updated

18 years ago
Priority: P3 → P2
change priority to P2 as it's a crash

Updated

18 years ago
Whiteboard: [nsbeta2+] → [nsbeta2+]Fix in hand
Fixed and checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Whiteboard: [nsbeta2+]Fix in hand → [nsbeta2+]
(Reporter)

Comment 7

18 years ago
Using build 2000-06-26 this is fixed when you drag and drop a card from the 
Address Book to the New Msg window addressing pane.  However, linux still 
crashes on the 2nd or 3rd  drop and because of a differrent scrolling bug the 
addresses you drop using win98 and mac are lost during scrolling.  Will verify 
based on original scenrio and open a new bug for the linux crash.  Verified
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

18 years ago
Sorry, I got this one confused with 38716.  This is still happening on linux, 
will reopen and add talkback (13137606) 
0x00000000 
js_GetProperty() 
js_Interpret() 
js_Invoke() 
js_InternalInvoke() 
JS_CallFunctionValue() 
nsJSContext::CallEventHandler() 
nsJSEventListener::HandleEvent() 
nsEventListenerManager::HandleEventSubType() 
nsEventListenerManager::HandleEvent() 
nsXULElement::HandleDOMEvent() 
nsXULElement::HandleDOMEvent() 
nsXULElement::HandleDOMEvent() 
nsXULElement::HandleDOMEvent() 
nsXULElement::HandleDOMEvent() 
nsXULElement::HandleDOMEvent() 
PresShell::HandleEventInternal() 
PresShell::HandleEvent() 
nsView::HandleEvent() 
nsView::HandleEvent() 
nsView::HandleEvent() 
nsViewManager2::DispatchEvent() 
HandleEvent() 
nsWidget::DispatchEvent() 
nsWidget::DispatchWindowEvent() 
nsWidget::DispatchMouseEvent() 
nsWindow::OnToplevelDragMotion() 
nsWindow::ToplevelDragMotionSignal() 
libgtk-1.2.so.0 + 0x8d7f5 (0x4066d7f5) 
libgtk-1.2.so.0 + 0xbafdd (0x4069afdd) 
libgtk-1.2.so.0 + 0xba422 (0x4069a422) 
libgtk-1.2.so.0 + 0xb8899 (0x40698899) 
libgtk-1.2.so.0 + 0x5e63f (0x4063e63f) 
libgtk-1.2.so.0 + 0x5e0d0 (0x4063e0d0) 
libgtk-1.2.so.0 + 0x5d9cf (0x4063d9cf) 
libgtk-1.2.so.0 + 0x8c9ea (0x4066c9ea) 
handle_gdk_event() 
libgdk-1.2.so.0 + 0x1700b (0x4071700b) 
libglib-1.2.so.0 + 0xfbe6 (0x40744be6) 
libglib-1.2.so.0 + 0x101a1 (0x407451a1) 
libglib-1.2.so.0 + 0x10341 (0x40745341) 
libgtk-1.2.so.0 + 0x8c209 (0x4066c209) 
nsAppShell::Run() 
nsAppShellService::Run() 
main1() 
main() 
libc.so.6 + 0x181eb (0x402451eb) 
                                                 

Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Seth, could you take a look at this bug for me. Thanks
Status: REOPENED → ASSIGNED
taking from jfd while I investigate.
Assignee: ducarroz → sspitzer
Status: ASSIGNED → NEW
adding ducarroz back to the cc list.

Comment 12

18 years ago
removing nsbeta2+ and asking for consideration to cut from beta2.

It appears this is only Linux.  It also is an action that we don't think is too
common (most people don't address by dragging a card from the AB to the compose
window).  There is definitely possible data loss if someone has composed a
message and then drags an ab card. But I don't think that will happen too often.
Keywords: relnote2
Whiteboard: [nsbeta2+]

Comment 13

18 years ago
Putting on [nsbeta2-] radar. Not critical to beta2.  Adding "nsbeta3" keyword 
for consideration of a fix for that milestone. 
Keywords: nsbeta3
Whiteboard: [nsbeta2-]

Comment 14

18 years ago
Adding mail2 triage nomination keyword.
Keywords: mail2

Comment 15

18 years ago
+ per mail triage
Whiteboard: [nsbeta2-] → [nsbeta3+][nsbeta2-]
Target Milestone: M17 → M18

Comment 16

18 years ago
second pass: - per mail triage unfortunately
Whiteboard: [nsbeta3+][nsbeta2-] → [nsbeta3-][cut 8/31][nsbeta2-]
I noticed that blizzard landed a bunch of linux d&d changes recently, so this
may be fixed.

either way, I'm cc'ing blizzard who is the linux d&d expert.
I can't reproduce any of these problems.  It might have been fixed as a result
of the rewrite.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Updated

18 years ago
QA Contact: esther → laurel

Comment 19

18 years ago
I can't reproduce using sept15 commercial build linux rh6.0, NT 4.0 or mac OS
9.0
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.