[TEXT] Text overlaps with links

VERIFIED WORKSFORME

Status

()

Core
Layout
P3
major
VERIFIED WORKSFORME
18 years ago
13 years ago

People

(Reporter: Alex, Assigned: Erik van der Poel)

Tracking

Trunk
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
SUMMARY
Text overlaps with text in certain, but not all, situations, usually the text
that overlaps are links.

STEPS TO REPRODUCE
1. Launch Mozilla.
2. Visit any one of the following URLs:

http://www.mozilla.org/quality/most-frequent-bugs/
http://www.theforce.net/
http://news.cnet.com/news/0-1003-200-1844957.html?tag=st.ne.1002.tgif.ni

EXPECTED RESULT
All text should appear properly spaced without any overlap.

ACTUAL RESULT
Some text, usually links, overlap with the preceeding text.

SYSTEM TESTED
MacOS 9.0, G3 266MHz, 64MB RAM

BUILD TESTED
2000050908
Reassigning to buster@netscape.com. Triaging Troy's bug list.
Assignee: troy → buster

Comment 2

18 years ago
I'm not sure if this is a Mac text measurement bug or not.  Chris, does this 
occur on other platforms, or just on the Mac?
Assignee: buster → erik
Severity: normal → major
Summary: Text overlaps with links → [TEXT] Text overlaps with links
Nom. nsbeta2, recc. nsbeta2+. Overlapping text with links in basic HTML 3.2 
layout--b.c. with that is key b2 criterion. Also, we're seeing it on CNET.com, a 
major content site.
Keywords: nsbeta2

Comment 4

18 years ago
Yes, this was a mac only bug. However, I can no longer reproduce this problem 
with the June 05 Mac build (2000060508). 

Comment 5

18 years ago
since this was Mac only, and it can no longer be reproduced, I'd bet you a donut 
it was the broken Mac text measurement code that was fixed by Robert O'Callahan.  
Marking WorksForMe (since I don't have any proof that it was actually fixed.)
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 6

18 years ago
Agreed. The problem described was very noticeable before. Marking verified 
worksforme.
Status: RESOLVED → VERIFIED

Updated

13 years ago
OS: Mac System 9.x
You need to log in before you can comment on or make changes to this bug.