copy link/content, then click in textfield hangs browser

VERIFIED FIXED

Status

()

P3
critical
VERIFIED FIXED
19 years ago
17 years ago

People

(Reporter: bugzilla, Assigned: pavlov)

Tracking

({crash, platform-parity, regression})

Trunk
Other
Linux
crash, platform-parity, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: have fix, URL)

(Reporter)

Description

19 years ago
found this using today's linux comm bits, 2000.05.09.08. not a problem on Mac or
winNT.

1. load the above URL.
2. do any of the following:
   * bring up context menu over a link and select Copy Link
   * highlight webpage content, select Edit > Copy
   * highlighy webpage content, bring up context menu over a link and select
Copy
3. click in a textfield, eg:
   * Location textfield in nav toolbar
   * textfield for Mozilla bug # in the above URL

result: browser hangs, ie, becomes unresponsive. unable to access textfields,
buttons, menus... (is this already known?)
(Reporter)

Comment 1

19 years ago
oops, this is supposed to go to the editor group!
Assignee: pinkerton → beppe
Component: XP Toolkit/Widgets: Menus → Editor
Keywords: crash, pp, regression
QA Contact: sairuh → sujay

Updated

19 years ago
Assignee: beppe → pavlov

Comment 2

19 years ago
I'm pretty sure this is pavlov -- it's hanging at 


gdb) thread 2
[Switching to thread 2 (Thread 20810 (initial thread))]
#0  0x409a06a8 in XCheckTypedWindowEvent () from /usr/X11R6/lib/libX11.so.6
(gdb) bt
#0  0x409a06a8 in XCheckTypedWindowEvent () from /usr/X11R6/lib/libX11.so.6
#1  0x407b5d89 in nsClipboard::GetTargets (this=0x8364c28, aSelectionAtom=224)
    at nsClipboard.cpp:1164
#2  0x407b4cad in nsClipboard::HasDataMatchingFlavors (this=0x8364c28, 
    aFlavorList=0x87fe078, aWhichClipboard=1, outResult=0xbfffb7d4)
    at nsClipboard.cpp:731
#3  0x41cba91c in nsHTMLEditor::CanPaste (this=0x8615f70, aSelectionType=1, 
    aCanPaste=@0xbfffbab8) at nsHTMLEditor.cpp:4539
#4  0x41c6ce33 in nsPasteCommand::IsCommandEnabled (this=0x86db5a8, 
    aCommand=0x8473ae8, refCon=0x8615f70, outCmdEnabled=0xbfffbab8)
    at nsEditorCommands.cpp:150
#5  0x40b5de42 in nsControllerCommandManager::IsCommandEnabled (
    this=0x86b8880, aCommandName=0x8473ae8, aCommandRefCon=0x8615f70, 
    aResult=0xbfffbab8) at nsControllerCommandManager.cpp:118
#6  0x41c6abd4 in nsEditorController::IsCommandEnabled (this=0x86dc498, 
    aCommand=0x8473ae8, aResult=0xbfffbab8) at nsEditorController.cpp:186
#7  0x4011d3a9 in XPTC_InvokeByIndex (that=0x86dc498, methodIndex=3, 
    paramCount=2, params=0xbfffbaa8) at xptcinvoke_unixish_x86.cpp:159
#8  0x40630dad in nsXPCWrappedNativeClass::CallWrappedMethod (this=0x8767aa0, 
    cx=0x82fa520, wrapper=0x8769000, desc=0x8767b04, callMode=CALL_METHOD, 
    argc=1, argv=0x871c458, vp=0xbfffbc2c) at xpcwrappednativeclass.cpp:914
#9  0x40632db7 in WrappedNative_CallMethod (cx=0x82fa520, obj=0x86c5080, 
    argc=1, argv=0x871c458, vp=0xbfffbc2c) at xpcwrappednativejsops.cpp:200
#10 0x401a5fa6 in js_Invoke (cx=0x82fa520, argc=1, flags=0) at jsinterp.c:686
#11 0x401b706b in js_Interpret (cx=0x82fa520, result=0xbfffc5f8)
    at jsinterp.c:2483
#12 0x401a6005 in js_Invoke (cx=0x82fa520, argc=1, flags=2) at jsinterp.c:702
#13 0x401a633c in js_InternalInvoke (cx=0x82fa520, obj=0x8432cc0, 
    fval=138620472, flags=0, argc=1, argv=0xbfffc8a4, rval=0xbfffc770)
    at jsinterp.c:775
#14 0x40179b07 in JS_CallFunctionValue (cx=0x82fa520, obj=0x8432cc0, 
    fval=138620472, argc=1, argv=0xbfffc8a4, rval=0xbfffc770) at jsapi.c:2794
#15 0x4035c407 in nsJSContext::CallEventHandler (this=0x80d9678, 
    aTarget=0x8432cc0, aHandler=0x8432e38, argc=1, argv=0xbfffc8a4, 
    aBoolResult=0xbfffc7f4, aReverseReturnResult=0) at nsJSEnvironment.cpp:787
#16 0x403a2bfc in nsJSEventListener::HandleEvent (this=0x85bd748, 
    aEvent=0x87fdb9c) at nsJSEventListener.cpp:154
#17 0x410f84f1 in nsEventListenerManager::HandleEventSubType (this=0x85bd6f8, 
    aListenerStruct=0x85bd770, aDOMEvent=0x87fdb9c, aSubType=32, aPhaseFlags=7)
    at nsEventListenerManager.cpp:703
#18 0x410fa4ee in nsEventListenerManager::HandleEvent (this=0x85bd6f8, 
    aPresContext=0x81bf660, aEvent=0xbfffce90, aDOMEvent=0xbfffcd70, aFlags=7, 
    aEventStatus=0xbfffce0c) at nsEventListenerManager.cpp:1477
#19 0x40b7bf85 in nsXULElement::HandleDOMEvent (this=0x8478a50, 
    aPresContext=0x81bf660, aEvent=0xbfffce90, aDOMEvent=0xbfffcd70, aFlags=1, 
    aEventStatus=0xbfffce0c) at nsXULElement.cpp:3329
#20 0x40bb4a32 in nsXULCommandDispatcher::UpdateCommands (this=0x81bd2c8, 
    aEventName=@0xbfffcf7c) at nsXULCommandDispatcher.cpp:309
#21 0x40bb3de4 in nsXULCommandDispatcher::SetFocusedElement (this=0x81bd2c8, 
    aElement=0x864f718) at nsXULCommandDispatcher.cpp:148
#22 0x40bb4f19 in nsXULCommandDispatcher::Focus (this=0x81bd2c8, 
    aEvent=0x87fdb64) at nsXULCommandDispatcher.cpp:375
#23 0x410f9482 in nsEventListenerManager::HandleEvent (this=0x8352220, 
    aPresContext=0x81bf660, aEvent=0xbfffe078, aDOMEvent=0xbfffde44, aFlags=4, 
    aEventStatus=0xbfffe0b8) at nsEventListenerManager.cpp:1081
#24 0x40b92aac in nsXULDocument::HandleDOMEvent (this=0x81bb4c0, 
    aPresContext=0x81bf660, aEvent=0xbfffe078, aDOMEvent=0xbfffde44, aFlags=4, 
    aEventStatus=0xbfffe0b8) at nsXULDocument.cpp:1971
#25 0x40b7beef in nsXULElement::HandleDOMEvent (this=0x844f7e0, 
    aPresContext=0x81bf660, aEvent=0xbfffe078, aDOMEvent=0xbfffde44, aFlags=4, 
    aEventStatus=0xbfffe0b8) at nsXULElement.cpp:3321
#26 0x40b7beaa in nsXULElement::HandleDOMEvent (this=0x846f6a8, 
    aPresContext=0x81bf660, aEvent=0xbfffe078, aDOMEvent=0xbfffde44, aFlags=4, 
    aEventStatus=0xbfffe0b8) at nsXULElement.cpp:3317
#27 0x40b7beaa in nsXULElement::HandleDOMEvent (this=0x8472080, 
    aPresContext=0x81bf660, aEvent=0xbfffe078, aDOMEvent=0xbfffde44, aFlags=4, 
    aEventStatus=0xbfffe0b8) at nsXULElement.cpp:3317
#28 0x40b7beaa in nsXULElement::HandleDOMEvent (this=0x84720e0, 
    aPresContext=0x81bf660, aEvent=0xbfffe078, aDOMEvent=0xbfffde44, aFlags=4, 
    aEventStatus=0xbfffe0b8) at nsXULElement.cpp:3317
#29 0x40b7beaa in nsXULElement::HandleDOMEvent (this=0x81c51d8, 
    aPresContext=0x81bf660, aEvent=0xbfffe078, aDOMEvent=0xbfffde44, aFlags=4, 
    aEventStatus=0xbfffe0b8) at nsXULElement.cpp:3317
#30 0x40b7beaa in nsXULElement::HandleDOMEvent (this=0x81c54b8, 
    aPresContext=0x81bf660, aEvent=0xbfffe078, aDOMEvent=0xbfffde44, aFlags=4, 
    aEventStatus=0xbfffe0b8) at nsXULElement.cpp:3317
#31 0x40b7beaa in nsXULElement::HandleDOMEvent (this=0x831e100, 
    aPresContext=0x81bf660, aEvent=0xbfffe078, aDOMEvent=0xbfffde44, aFlags=4, 
    aEventStatus=0xbfffe0b8) at nsXULElement.cpp:3317
#32 0x40b7beaa in nsXULElement::HandleDOMEvent (this=0x864f7c8, 
    aPresContext=0x81bf660, aEvent=0xbfffe078, aDOMEvent=0xbfffde44, aFlags=4, 
    aEventStatus=0xbfffe0b8) at nsXULElement.cpp:3317
#33 0x413d1540 in nsGenericElement::HandleDOMEvent (this=0x864f738, 
    aPresContext=0x81bf660, aEvent=0xbfffe078, aDOMEvent=0xbfffde44, aFlags=1, 
    aEventStatus=0xbfffe0b8) at nsGenericElement.cpp:1013
#34 0x411c36dd in nsHTMLInputElement::HandleDOMEvent (this=0x864f718, 
    aPresContext=0x81bf660, aEvent=0xbfffe078, aDOMEvent=0x0, aFlags=1, 
    aEventStatus=0xbfffe0b8) at nsHTMLInputElement.cpp:728
#35 0x41104580 in nsEventStateManager::SendFocusBlur (this=0x86066f0, 
    aPresContext=0x81bf660, aContent=0x864f724) at nsEventStateManager.cpp:2232
#36 0x41103562 in nsEventStateManager::SetContentState (this=0x86066f0, 
    aContent=0x864f724, aState=2) at nsEventStateManager.cpp:2040
#37 0x411c2fcc in nsHTMLInputElement::SetFocus (this=0x864f718, 
    aPresContext=0x81bf660) at nsHTMLInputElement.cpp:613
#38 0x4110166e in nsEventStateManager::ChangeFocus (this=0x86066f0, 
    aFocusContent=0x864f724, aTargetFrame=0x862f598, aSetFocus=1)
    at nsEventStateManager.cpp:1653
#39 0x410fec58 in nsEventStateManager::PostHandleEvent (this=0x86066f0, 
    aPresContext=0x81bf660, aEvent=0xbfffe4e4, aTargetFrame=0x862f598, 
    aStatus=0xbfffe524, aView=0x873b430) at nsEventStateManager.cpp:746
#40 0x41283cf1 in nsEnderEventListener::DispatchMouseEvent (this=0x8740ad8, 
    aEvent=0x87fdb2c, aEventType=302) at nsGfxTextControlFrame.cpp:4199
#41 0x41284131 in nsEnderEventListener::MouseDown (this=0x8740ad8, 
    aEvent=0x87fdb2c) at nsGfxTextControlFrame.cpp:4273
#42 0x410f889c in nsEventListenerManager::HandleEvent (this=0x8740ed8, 
    aPresContext=0x8616cb8, aEvent=0xbfffec10, aDOMEvent=0xbfffe830, aFlags=2, 
    aEventStatus=0xbfffee78) at nsEventListenerManager.cpp:763
#43 0x413b2f04 in nsDocument::HandleDOMEvent (this=0x86169e0, 
    aPresContext=0x8616cb8, aEvent=0xbfffec10, aDOMEvent=0xbfffe830, aFlags=2, 
    aEventStatus=0xbfffee78) at nsDocument.cpp:2643
#44 0x413d164b in nsGenericElement::HandleDOMEvent (this=0x8616bbc, 
    aPresContext=0x8616cb8, aEvent=0xbfffec10, aDOMEvent=0xbfffe830, aFlags=2, 
    aEventStatus=0xbfffee78) at nsGenericElement.cpp:1044
#45 0x411b836d in nsHTMLHtmlElement::HandleDOMEvent (this=0x8616ba8, 
    aPresContext=0x8616cb8, aEvent=0xbfffec10, aDOMEvent=0xbfffe830, aFlags=2, 
    aEventStatus=0xbfffee78) at nsHTMLHtmlElement.cpp:186
#46 0x413d161d in nsGenericElement::HandleDOMEvent (this=0x8616c2c, 
    aPresContext=0x8616cb8, aEvent=0xbfffec10, aDOMEvent=0xbfffe830, aFlags=2, 
    aEventStatus=0xbfffee78) at nsGenericElement.cpp:1037
#47 0x411922b5 in nsHTMLBodyElement::HandleDOMEvent (this=0x8616c18, 
    aPresContext=0x8616cb8, aEvent=0xbfffec10, aDOMEvent=0xbfffe830, aFlags=2, 
    aEventStatus=0xbfffee78) at nsHTMLBodyElement.cpp:844
#48 0x413cdcf1 in nsGenericDOMDataNode::HandleDOMEvent (this=0x85b5d4c, 
    aPresContext=0x8616cb8, aEvent=0xbfffec10, aDOMEvent=0xbfffe830, aFlags=1, 
    aEventStatus=0xbfffee78) at nsGenericDOMDataNode.cpp:777
#49 0x414076cd in nsTextNode::HandleDOMEvent (this=0x85b5d38, 
    aPresContext=0x8616cb8, aEvent=0xbfffec10, aDOMEvent=0x0, aFlags=1, 
    aEventStatus=0xbfffee78) at nsTextNode.cpp:227
#50 0x4115a2b3 in PresShell::HandleEventInternal (this=0x872ba20, 
    aEvent=0xbfffec10, aView=0x873bbb8, aStatus=0xbfffee78)
    at nsPresShell.cpp:3409
#51 0x41159e79 in PresShell::HandleEvent (this=0x872ba20, aView=0x873bbb8, 
    aEvent=0xbfffec10, aEventStatus=0xbfffee78, aHandled=@0xbfffeacc)
    at nsPresShell.cpp:3338
#52 0x417d7e17 in nsView::HandleEvent (this=0x873bbb8, event=0xbfffec10, 
    aEventFlags=8, aStatus=0xbfffee78, aHandled=@0xbfffeacc) at nsView.cpp:761
#53 0x417d7da0 in nsView::HandleEvent (this=0x873b430, event=0xbfffec10, 
    aEventFlags=8, aStatus=0xbfffee78, aHandled=@0xbfffeacc) at nsView.cpp:745
#54 0x417d7da0 in nsView::HandleEvent (this=0x872b638, event=0xbfffec10, 
    aEventFlags=28, aStatus=0xbfffee78, aHandled=@0xbfffeacc) at nsView.cpp:745
#55 0x417eabc3 in nsViewManager2::DispatchEvent (this=0x872b530, 
    aEvent=0xbfffec10, aStatus=0xbfffee78) at nsViewManager2.cpp:1370
#56 0x412751e0 in nsGfxTextControlFrame::RedispatchMouseEventToSubDoc (
    this=0x862f598, aPresContext=0x81bf660, aEvent=0xbfffee38, 
    aEventStatus=0xbfffee78, aAdjustForView=1)
    at nsGfxTextControlFrame.cpp:1061
#57 0x412741da in nsGfxTextControlFrame::HandleEvent (this=0x862f598, 
    aPresContext=0x81bf660, aEvent=0xbfffee38, aEventStatus=0xbfffee78)
    at nsGfxTextControlFrame.cpp:887
#58 0x41283c76 in nsEnderEventListener::DispatchMouseEvent (this=0x8740ad8, 
    aEvent=0x87fdaf4, aEventType=302) at nsGfxTextControlFrame.cpp:4193
#59 0x41284131 in nsEnderEventListener::MouseDown (this=0x8740ad8, 
    aEvent=0x87fdaf4) at nsGfxTextControlFrame.cpp:4273
#60 0x410f889c in nsEventListenerManager::HandleEvent (this=0x8740ed8, 
    aPresContext=0x8616cb8, aEvent=0xbffff5e4, aDOMEvent=0xbffff184, aFlags=2, 
    aEventStatus=0xbffff47c) at nsEventListenerManager.cpp:763
#61 0x413b2f04 in nsDocument::HandleDOMEvent (this=0x86169e0, 
    aPresContext=0x8616cb8, aEvent=0xbffff5e4, aDOMEvent=0xbffff184, aFlags=2, 
    aEventStatus=0xbffff47c) at nsDocument.cpp:2643
#62 0x413d164b in nsGenericElement::HandleDOMEvent (this=0x8616bbc, 
    aPresContext=0x8616cb8, aEvent=0xbffff5e4, aDOMEvent=0xbffff184, aFlags=2, 
    aEventStatus=0xbffff47c) at nsGenericElement.cpp:1044
#63 0x411b836d in nsHTMLHtmlElement::HandleDOMEvent (this=0x8616ba8, 
    aPresContext=0x8616cb8, aEvent=0xbffff5e4, aDOMEvent=0xbffff184, aFlags=2, 
    aEventStatus=0xbffff47c) at nsHTMLHtmlElement.cpp:186
#64 0x413d161d in nsGenericElement::HandleDOMEvent (this=0x8616c2c, 
    aPresContext=0x8616cb8, aEvent=0xbffff5e4, aDOMEvent=0xbffff184, aFlags=2, 
    aEventStatus=0xbffff47c) at nsGenericElement.cpp:1037
#65 0x411922b5 in nsHTMLBodyElement::HandleDOMEvent (this=0x8616c18, 
    aPresContext=0x8616cb8, aEvent=0xbffff5e4, aDOMEvent=0xbffff184, aFlags=2, 
    aEventStatus=0xbffff47c) at nsHTMLBodyElement.cpp:844
#66 0x413cdcf1 in nsGenericDOMDataNode::HandleDOMEvent (this=0x85b5d4c, 
    aPresContext=0x8616cb8, aEvent=0xbffff5e4, aDOMEvent=0xbffff184, aFlags=1, 
    aEventStatus=0xbffff47c) at nsGenericDOMDataNode.cpp:777
#67 0x414076cd in nsTextNode::HandleDOMEvent (this=0x85b5d38, 
    aPresContext=0x8616cb8, aEvent=0xbffff5e4, aDOMEvent=0x0, aFlags=1, 
    aEventStatus=0xbffff47c) at nsTextNode.cpp:227
#68 0x4115a2b3 in PresShell::HandleEventInternal (this=0x872ba20, 
    aEvent=0xbffff5e4, aView=0x873bbb8, aStatus=0xbffff47c)
    at nsPresShell.cpp:3409
#69 0x41159e79 in PresShell::HandleEvent (this=0x872ba20, aView=0x873bbb8, 
    aEvent=0xbffff5e4, aEventStatus=0xbffff47c, aHandled=@0xbffff420)
    at nsPresShell.cpp:3338
#70 0x417d7e17 in nsView::HandleEvent (this=0x873bbb8, event=0xbffff5e4, 
    aEventFlags=8, aStatus=0xbffff47c, aHandled=@0xbffff420) at nsView.cpp:761
#71 0x417d7da0 in nsView::HandleEvent (this=0x873b430, event=0xbffff5e4, 
    aEventFlags=8, aStatus=0xbffff47c, aHandled=@0xbffff420) at nsView.cpp:745
#72 0x417d7da0 in nsView::HandleEvent (this=0x872b638, event=0xbffff5e4, 
    aEventFlags=28, aStatus=0xbffff47c, aHandled=@0xbffff420) at nsView.cpp:745
#73 0x417eabc3 in nsViewManager2::DispatchEvent (this=0x872b530, 
    aEvent=0xbffff5e4, aStatus=0xbffff47c) at nsViewManager2.cpp:1370
#74 0x417d5894 in HandleEvent (aEvent=0xbffff5e4) at nsView.cpp:68
#75 0x407c3ee6 in nsWidget::DispatchEvent (this=0x873b4c0, aEvent=0xbffff5e4, 
    aStatus=@0xbffff518) at nsWidget.cpp:1438
#76 0x407c3b1c in nsWidget::DispatchWindowEvent (this=0x873b4c0, 
    event=0xbffff5e4) at nsWidget.cpp:1329
#77 0x407c3fa0 in nsWidget::DispatchMouseEvent (this=0x873b4c0, 
    aEvent=@0xbffff5e4) at nsWidget.cpp:1465
#78 0x407c5760 in nsWidget::OnButtonPressSignal (this=0x873b4c0, 
    aGdkButtonEvent=0x814d538) at nsWidget.cpp:2168
#79 0x407cb835 in nsWindow::HandleGDKEvent (this=0x873b4c0, event=0x814d538)
    at nsWindow.cpp:1114
#80 0x407bb411 in dispatch_superwin_event (event=0x814d538, window=0x873b4c0)
    at nsGtkEventHandler.cpp:937
#81 0x407bb084 in handle_gdk_event (event=0x814d538, data=0x0)
    at nsGtkEventHandler.cpp:782
#82 0x4093e00b in gdk_event_dispatch () from /usr/lib/libgdk-1.2.so.0
#83 0x4096bbe6 in g_main_dispatch () from /usr/lib/libglib-1.2.so.0
#84 0x4096c1a1 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#85 0x4096c341 in g_main_run () from /usr/lib/libglib-1.2.so.0
#86 0x40893209 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#87 0x407b1f47 in nsAppShell::Run (this=0x80f0ad0) at nsAppShell.cpp:313
#88 0x4068b884 in nsAppShellService::Run (this=0x8115748)
    at nsAppShellService.cpp:365
#89 0x804ec64 in main1 (argc=1, argv=0xbffffa64, splashScreen=0x0)
    at nsAppRunner.cpp:765
#90 0x804f240 in main (argc=1, argv=0xbffffa64) at nsAppRunner.cpp:998
(gdb) 


Comment 3

19 years ago
*** Bug 38863 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

19 years ago
have fix i think... waiting for build to finish
Whiteboard: have fix
(Assignee)

Comment 5

19 years ago
checked in fix
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 6

18 years ago
verified in 10/30 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.