Closed Bug 387243 Opened 14 years ago Closed 13 years ago

Printing and Print Preview takes 20 seconds to load

Categories

(Core :: Print Preview, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: edwardp, Unassigned)

References

()

Details

(Keywords: hang)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a7pre) Gecko/2007070702 SeaMonkey/2.0a1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a7pre) Gecko/2007070702 SeaMonkey/2.0a1pre

In using SeaMonkey 2.0pre1 for Linux, when printing any web page, or utilizing Print Preview, the application will crash completely.

Print Preview:  Window opens, app. hangs.

Printing:  Printing dialog box appears, but CANCEL is greyed out.  Application hangs at this point.



Reproducible: Always

Steps to Reproduce:
1.Print or Print Preview a web page.
2.Application hangs.
3.
Actual Results:  
Application hangs when opening Print Preview or attempting to print any web page.

Expected Results:  
Application should not have hung.
Linux:  openSUSE 10.2 using KDE
Did this also happen with yesterday's nightly?
I tried 2.0 a week and a half ago, not sure of the date, but back then, the same occurred.
oops, seamonkey. please try firefox anyway.

before you start printing, open the error console. do all windows hang or just the one you're using to print (preview)?

if anything appears in error console as a direct result of print (preview), please indicate that.
Assignee: general → nobody
Severity: critical → major
Component: General → Print Preview
Keywords: hang
Product: Mozilla Application Suite → Core
QA Contact: general → printing
Summary: Printing and Print Preview crashes browser → Printing and Print Preview hangs browser
Version: unspecified → Trunk
Failed to load XPCOM component: /home/$user/seamonkey20/seamonkey/extensions/talkback@mozilla.org/components/talkback/XTalkback.ad

The above appeared 4 times in the Error Console upon the first launch of SM 2.0.  

When selecting Print Preview, the browser froze on "Preparing..." then after about 20 seconds (this should be considered VERY slow on a system with a 1.5 GHz CPU), the Print Preview window appeared without any image of the page, but the page number reference and Close button were at the top.

Once the Print Preview window was closed using the Close button, I checked the Error console again and there were no new items.

Can you test a Firefox trunk build and see if it also crashes? If yes, please send a bug report and take a look under ~/.mozilla/firefox/Crash Reports/submitted for the crash report id. The crash report id is included in the file name, as in bp-<crash-id>.txt. Please paste the crash report id in the bug here.
Actually, that only helps with crasher, but you wrote hang. So forget that :).
so it's taking 20 seconds to load print preview? that's your definition of a hang?

reporter: a few things. when you say "2.0" it's not unreasonable for timeless or anyone else to assuming you're talking about a released product. SeaMonkey is barely in alpha, that's not 2.0. 2.0 will not be released for a while.

second, it's appreciated if you would include a url, any url, the simplest url. Please read: http://developer.mozilla.org/en/docs/Bug_writing_guidelines
Effective bug reports are the most likely to be fixed. These guidelines explain how to write such reports.
     * Be precise
     * Be clear - explain it so others can reproduce the bug
     * One bug per report
     * No bug is too trivial to report - small bugs may hide big bugs
     * Clearly separate fact from speculation 

Saying that the application "will crash completely" is not clear, it's not precise, it isn't even accurate. It confuses people (not just timeless, note that Frank too was confused).

Steps to Reproduce: Minimized, easy-to-follow steps that will trigger the bug. Include any special setup steps.
1) View any web page. (I used the default sample page, resource:/res/samples/test0.html)
Note that the suggestion clearly indicates that you *should* include a page. There's a URL field in the guided bug entry, and you really should use it.

Oh, and if it really crashes, please try a current nightly (from July 10 or younger) and when the "Crash! Boom! Bang!" dialog comes up when crashing there, please submit that crash report to us and note that here, as it will give us precise information of what code caused the crash.
URL has been added, not too many graphics on the specified page.  

Hopefully I can make this clearer:  When Print Preview was selected, there was a delay of 20 seconds, which seemed very long given the CPU speed.  During this period, the application hung (froze) completely.  It did not crash (exit abnormally).  

When the Print Preview image finally appeared, the application no longer hung.  I did not see anything listed in the error console after the software was no longer hanging.

I am aware that SeaMonkey 2.0 is still in alpha, but felt that since this is a decent feature of the suite, the problem should be reported.
layout is sync, this is normal. there's nothing remotely remarkable about it.

it takes about 2 seconds here on a Dell Latitude D610 laptop (Intel Pentium M 782MHz/1.86GHz, 1.5GB of ram) running windows xp sp2 with:
Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/200707040404 Minefield/3.0a7pre

it's of course faster by default for me since I use noscript and that page has slightly more than one link if javascript is forbidden.

things you need to indicate:
os vendor/version
cpu vendor/version/speed/processor count
gnome+gtk version
cairo version
xserver vendor/version
graphics card/driver/version + memory specs
system memory (avail, free) + swap specs
how much memory is seamonkey using

*please* test with http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/latest-trunk/seamonkey-2.0a1pre.en-US.linux-i686.tar.bz2
as slowdowns in core will not be improved on branches.
if you feel this is a real problem, please see if any of the releases listed at this site are faster (and if so, indicate which versions and how long they take):
http://releases.mozilla.org/pub/mozilla.org/seamonkey/releases/
http://releases.mozilla.org/pub/mozilla.org/mozilla/releases/
http://archive.mozilla.org/pub/mozilla.org/mozilla/releases/

and again, testing with firefox is appreciated. especially testing builds of seamonkey and firefox from the same day. if seamonkey is significantly slower, that's something that seamonkey developers could actually look into fixing, even for a branch.
Severity: major → normal
Summary: Printing and Print Preview hangs browser → Printing and Print Preview takes 20 seconds to load
Using currently SeaMonkey 2.0 nightly from link in Comment 11.

Build identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a7pre) Gecko/200707140101 SeaMonkey/2.0a1pre

Print Preview continues to hang.  Using this build, the page does not appear.  With the Print Preview window remaining open afterwards, all other Linux applications on the laptop were extremely slow loading and running (Konqueror, OpenOffice.org, Konsole, etc.).  

Running "top", Xorg spiked up to 99.5% CPU usage while the hung Print Preview window was open.

Once the Print Preview window was closed, all other apps then began to run at normal speed and the Xorg CPU percentage gradually reduced down to 0.5%.

OS vendor/version:  openSUSE 10.2
Desktop:  KDE 3.5.5
Kernel:  Linux 2.6.18.8-0.5-default i686
CPU:  Intel Pentium M processor, 1.86 GHz
Memory:  1.50 Gb
Display:  ATI Radeon Mobility M300 (M22) 5460 (PCIE) using "radeon" driver without 3D support
X server:  X.org
GTK: 2
Cairo:  version not known
Memory used (according to "top"): 
176 Mb VIRT
 60 Mb RES
 24 Mb SHR

Otherwise, I have been using the nightlies of SeaMonkey 1.1.2 all along without any problems whatsoever.  Print Preview in 1.1.2 comes up in less than 2 seconds.

I hope this additional information is helpful.
On thunderbird I get a complete hang - bug 386298. Might be related.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a7pre) Gecko/200707150101 SeaMonkey/2.0a1pre

Having same issues with this nightly as with the previous.
Related to Bug 252694?
This could be bug 315687. Edward, could you attach the printing-related preferences from your prefs.js file? You need to locate your profile folder (see http://kb.mozillazine.org/Profile_folder), find the file in there named prefs.js, extract all of the lines that contain "print.", and add them to this bug.

Once you've done that, could you try the workaround from bug 315687:

1) Select file->print to open the print dialog
2) In the dialog, click on the "Properties" button
3) In the printer properties dialog, click "okay"
4) Dismiss the print dialog by clicking "print". You can print to a file if you want.
Kenneth - What is happening, is bug 315687, but in reverse.  Printing works fine, Print Preview is (for the most part) blank.  Print Preview would either display nothing except the icons at the top of the window, or it would briefly display then the print preview image itself would disappear.
Edward, in the original bug report you said that you were getting the hang during printing as well as print preview. Now you say "printing works fine." When did it change from hanging to working correctly?

Did you actually try the workaround that I suggested? Did it make any difference? Could you actually attach your print preferences like I asked? (and when you do so, please note whether the prefs are from before or after trying the workaround)
From build 
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a7pre) Gecko/200707260303 SeaMonkey/2.0a1pre

and before the workaround:

user_pref("print.print_printer", "CUPS/deskjet3900");
user_pref("print.printer_CUPS/deskjet3900.print_bgcolor", true);
user_pref("print.printer_CUPS/deskjet3900.print_bgimages", true);
user_pref("print.printer_CUPS/deskjet3900.print_colorspace", "default");
user_pref("print.printer_CUPS/deskjet3900.print_command", "lpr ${MOZ_PRINTER_NAME:+'-P'}${MOZ_PRINTER_NAME}");
user_pref("print.printer_CUPS/deskjet3900.print_downloadfonts", true);
user_pref("print.printer_CUPS/deskjet3900.print_edge_bottom", 55);
user_pref("print.printer_CUPS/deskjet3900.print_edge_left", 40);
user_pref("print.printer_CUPS/deskjet3900.print_edge_right", 40);
user_pref("print.printer_CUPS/deskjet3900.print_edge_top", 40);
user_pref("print.printer_CUPS/deskjet3900.print_evenpages", true);
user_pref("print.printer_CUPS/deskjet3900.print_footercenter", "");
user_pref("print.printer_CUPS/deskjet3900.print_footerleft", "&PT");
user_pref("print.printer_CUPS/deskjet3900.print_footerright", "&D");
user_pref("print.printer_CUPS/deskjet3900.print_headercenter", "");
user_pref("print.printer_CUPS/deskjet3900.print_headerleft", "&T");
user_pref("print.printer_CUPS/deskjet3900.print_headerright", "&U");
user_pref("print.printer_CUPS/deskjet3900.print_in_color", true);
user_pref("print.printer_CUPS/deskjet3900.print_margin_bottom", "0.5");
user_pref("print.printer_CUPS/deskjet3900.print_margin_left", "0.5");
user_pref("print.printer_CUPS/deskjet3900.print_margin_right", "0.5");
user_pref("print.printer_CUPS/deskjet3900.print_margin_top", "0.7");
user_pref("print.printer_CUPS/deskjet3900.print_oddpages", true);
user_pref("print.printer_CUPS/deskjet3900.print_orientation", 0);
user_pref("print.printer_CUPS/deskjet3900.print_pagedelay", 500);
user_pref("print.printer_CUPS/deskjet3900.print_paper_data", 0);
user_pref("print.printer_CUPS/deskjet3900.print_paper_height", "279.40");
user_pref("print.printer_CUPS/deskjet3900.print_paper_name", "Letter");
user_pref("print.printer_CUPS/deskjet3900.print_paper_size", 0);
user_pref("print.printer_CUPS/deskjet3900.print_paper_size_type", 1);
user_pref("print.printer_CUPS/deskjet3900.print_paper_size_unit", 0);
user_pref("print.printer_CUPS/deskjet3900.print_paper_width", "215.90");
user_pref("print.printer_CUPS/deskjet3900.print_plex_name", "default");
user_pref("print.printer_CUPS/deskjet3900.print_resolution_name", "default");
user_pref("print.printer_CUPS/deskjet3900.print_reversed", false);
user_pref("print.printer_CUPS/deskjet3900.print_scaling", "  1.00");
user_pref("print.printer_CUPS/deskjet3900.print_shrink_to_fit", true);
user_pref("print.printer_CUPS/deskjet3900.print_to_file", false);
user_pref("print.printer_CUPS/deskjet3900.print_to_filename", "/home/epp/mozilla.ps");
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.can_change_colorspace", false);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.can_change_downloadfonts", false);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.can_change_jobtitle", false);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.can_change_num_copies", true);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.can_change_orientation", true);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.can_change_paper_size", true);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.can_change_plex", false);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.can_change_printincolor", true);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.can_change_resolution", false);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.can_change_spoolercommand", false);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.colorspace.0.name", "default");
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.colorspace.count", 1);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.has_special_printerfeatures", true);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.orientation.0.name", "portrait");
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.orientation.1.name", "landscape");
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.orientation.count", 2);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.paper.0.height_mm", 210);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.paper.0.is_inch", false);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.paper.0.name", "A5");
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.paper.0.width_mm", 148);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.paper.1.height_mm", 297);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.paper.1.is_inch", false);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.paper.1.name", "A4");
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.paper.1.width_mm", 210);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.paper.2.height_mm", 420);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.paper.2.is_inch", false);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.paper.2.name", "A3");
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.paper.2.width_mm", 297);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.paper.3.height_mm", 279);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.paper.3.is_inch", true);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.paper.3.name", "Letter");
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.paper.3.width_mm", 215);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.paper.4.height_mm", 355);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.paper.4.is_inch", true);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.paper.4.name", "Legal");
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.paper.4.width_mm", 215);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.paper.5.height_mm", 431);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.paper.5.is_inch", true);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.paper.5.name", "Tabloid");
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.paper.5.width_mm", 279);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.paper.6.height_mm", 254);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.paper.6.is_inch", true);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.paper.6.name", "Executive");
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.paper.6.width_mm", 190);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.paper.count", 7);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.plex.0.name", "default");
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.plex.count", 1);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.resolution.0.name", "default");
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.resolution.count", 1);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.supports_colorspace_change", false);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.supports_downloadfonts_change", false);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.supports_jobtitle_change", false);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.supports_orientation_change", true);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.supports_paper_size_change", true);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.supports_plex_change", false);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.supports_printincolor_change", true);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.supports_resolution_change", false);
user_pref("print.tmp.printerfeatures.CUPS/deskjet3900.supports_spoolercommand_change", false);
user_pref("print.tmp.printerfeatures.PostScript/default.can_change_colorspace", false);
user_pref("print.tmp.printerfeatures.PostScript/default.can_change_downloadfonts", false);
user_pref("print.tmp.printerfeatures.PostScript/default.can_change_jobtitle", false);
user_pref("print.tmp.printerfeatures.PostScript/default.can_change_num_copies", true);
user_pref("print.tmp.printerfeatures.PostScript/default.can_change_orientation", true);
user_pref("print.tmp.printerfeatures.PostScript/default.can_change_paper_size", true);
user_pref("print.tmp.printerfeatures.PostScript/default.can_change_plex", false);
user_pref("print.tmp.printerfeatures.PostScript/default.can_change_printincolor", true);
user_pref("print.tmp.printerfeatures.PostScript/default.can_change_resolution", false);
user_pref("print.tmp.printerfeatures.PostScript/default.can_change_spoolercommand", true);
user_pref("print.tmp.printerfeatures.PostScript/default.colorspace.0.name", "default");
user_pref("print.tmp.printerfeatures.PostScript/default.colorspace.count", 1);
user_pref("print.tmp.printerfeatures.PostScript/default.has_special_printerfeatures", true);
user_pref("print.tmp.printerfeatures.PostScript/default.orientation.0.name", "portrait");
user_pref("print.tmp.printerfeatures.PostScript/default.orientation.1.name", "landscape");
user_pref("print.tmp.printerfeatures.PostScript/default.orientation.count", 2);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.0.height_mm", 210);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.0.is_inch", false);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.0.name", "A5");
user_pref("print.tmp.printerfeatures.PostScript/default.paper.0.width_mm", 148);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.1.height_mm", 297);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.1.is_inch", false);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.1.name", "A4");
user_pref("print.tmp.printerfeatures.PostScript/default.paper.1.width_mm", 210);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.2.height_mm", 420);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.2.is_inch", false);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.2.name", "A3");
user_pref("print.tmp.printerfeatures.PostScript/default.paper.2.width_mm", 297);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.3.height_mm", 279);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.3.is_inch", true);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.3.name", "Letter");
user_pref("print.tmp.printerfeatures.PostScript/default.paper.3.width_mm", 215);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.4.height_mm", 355);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.4.is_inch", true);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.4.name", "Legal");
user_pref("print.tmp.printerfeatures.PostScript/default.paper.4.width_mm", 215);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.5.height_mm", 431);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.5.is_inch", true);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.5.name", "Tabloid");
user_pref("print.tmp.printerfeatures.PostScript/default.paper.5.width_mm", 279);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.6.height_mm", 254);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.6.is_inch", true);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.6.name", "Executive");
user_pref("print.tmp.printerfeatures.PostScript/default.paper.6.width_mm", 190);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.count", 7);
user_pref("print.tmp.printerfeatures.PostScript/default.plex.0.name", "default");
user_pref("print.tmp.printerfeatures.PostScript/default.plex.count", 1);
user_pref("print.tmp.printerfeatures.PostScript/default.resolution.0.name", "default");
user_pref("print.tmp.printerfeatures.PostScript/default.resolution.count", 1);
user_pref("print.tmp.printerfeatures.PostScript/default.supports_colorspace_change", false);
user_pref("print.tmp.printerfeatures.PostScript/default.supports_downloadfonts_change", false);
user_pref("print.tmp.printerfeatures.PostScript/default.supports_jobtitle_change", false);
user_pref("print.tmp.printerfeatures.PostScript/default.supports_orientation_change", true);
user_pref("print.tmp.printerfeatures.PostScript/default.supports_paper_size_change", true);
user_pref("print.tmp.printerfeatures.PostScript/default.supports_plex_change", false);
user_pref("print.tmp.printerfeatures.PostScript/default.supports_printincolor_change", true);
user_pref("print.tmp.printerfeatures.PostScript/default.supports_resolution_change", false);
user_pref("print.tmp.printerfeatures.PostScript/default.supports_spoolercommand_change", true);

Comfirming that printing itself works.  The hanging (or delay) that I referred to is probably due to the amount of graphics that is on a web page.  Some pages with 90% text will go to the printer almost instantaneously (the Printing dialog only appears for two seconds or less).

For other pages with mostly graphics, this same dialog will be on the screen for several seconds, before the progress bar will appear. 


Also in this same nightly, Print Preview is NOT hanging now.  This was done after your workaround.
I just discovered two new issue related to printing, the headers are chopped off on both left and right sides of the paper and the footers do not print at all at the bottom of the paper.  The other issue is when the orientation is changed from Portrait to Landscape in the Page Setup it continues to print Portrait, headers are still chopped off, but the printing starts in the top quarter of the paper.

This may have to be filed as a new bug.
(In reply to comment #19)
> user_pref("print.printer_CUPS/deskjet3900.print_paper_height", "279.40");
> user_pref("print.printer_CUPS/deskjet3900.print_paper_size_unit", 0);
> user_pref("print.printer_CUPS/deskjet3900.print_paper_width", "215.90");

That's bug 315687. The paper size unit is set to 0 (inches) but the actual sizes are in millimeters. This leads the printing code to format the print job for 18x23 foot piece of paper. My guess is that the hang and other symptoms are caused by the printing code allocating a huge block of memory. The workaround resets the paper size to something sane.

I suggest resolving this as a dupe of bug 315687.
(In reply to comment #21)
> The other issue is when the orientation is
> changed from Portrait to Landscape in the Page Setup it continues to print
> Portrait, headers are still chopped off, but the printing starts in the top
> quarter of the paper.

This may be bug 381631, which was fixed July 16th. If you can produce the problem with a recent nightly build, please open a new bug report.
(In reply to comment #23)
> (In reply to comment #21)
> > The other issue is when the orientation is
> > changed from Portrait to Landscape in the Page Setup it continues to print
> > Portrait, headers are still chopped off, but the printing starts in the top
> > quarter of the paper.
> 
> This may be bug 381631, which was fixed July 16th. If you can produce the
> problem with a recent nightly build, please open a new bug report.

Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.9a8pre) Gecko/2007090804
Minefield/3.0a8pre

In the above nightly, the problem is not present.


I decided to try the latest nightly on my laptop (1.86 GHz CPU). 

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2pre) Gecko/2007112002 SeaMonkey/2.0a1pre

I'm happy to report that Print Preview did NOT crash, nor was it delayed, it came right up.  Printing is still an issue though, headers and footers are not printing, despite the settings in Page Setup (bug 336672).
Closing bug, problem has been corrected since bug report was filed.  Headers and footers are printing.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.