After DAP (download accelerator plus) is uninstalled, Firefox still try to use it

RESOLVED INVALID

Status

()

RESOLVED INVALID
11 years ago
10 years ago

People

(Reporter: bob-moenich, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

I used to use DAP on my computer to download all files. I recently wanted to change to a new download manager and have uninstalled Download Accelerator Plus.  Firefox keeps looking for DAP everytime I try to download anything so now it won't let me download.  I have installed "Free Download Manager" and its plug-in but Firefox still looks for DAP and I can't do anything.


Reproducible: Always

Steps to Reproduce:
1.I select an item to download
2.Firefox brings up a page that says it can't find Download Accelerator Plus
3.Then it tells me to go back and try again
Actual Results:  
I, now, can not download anything when I am in Firefox.

Expected Results:  
I expect Firefox to recognize the new download manager and it's plug-in

I expect it to allow me to download with "Free Download Manager"

Comment 1

11 years ago
do you use the Flashgot extension?
(Reporter)

Comment 2

11 years ago
No, I do not have Flashgot.  Is it necessary?

Comment 3

11 years ago
No it's not necessary but i need to know if something could "steal" downloads.

The solution is in the DAP FAQs
http://www.speedbit.com/faq/#8

here is the relevant part:
After DAP is uninstalled the MoZilla browser it is still trying to use it for downloads

solution:
Kindly locate the npdap.dll file under the "Plugins" folder of the Mozilla FireFox installation directory in the hard drive (C:\Program Files\Mozilla FireFox\plugins) and delete it. Now the MoZilla FireFox download manager will be used for downloads.

marking invalid because it's DAP known bug (plugin not removed on uninstall), the new plugin manager in firefox 3 will however help in solving problems like this
updating title to clear the problem for future dupes
Severity: major → normal
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
Summary: Firefox will not let me change download managers. → After DAP (download accelerator plus) is uninstalled, Firefox still try to use it
(Reporter)

Comment 4

11 years ago
Got it.  Thanks Marc, I have deleted the dll file and also have installed flashgot. Everything is great now.  I want to thank you very much for all your help.  Sincerely. Bob
Resolution: INVALID → FIXED

Comment 5

11 years ago
sorry but this is not a FIXED BUG, but it's INVALID because there is no patch here, don't change that please :)
Resolution: FIXED → INVALID
(In reply to comment #4)
> Got it.  Thanks Marc, I have deleted the dll file and also have installed
> flashgot. Everything is great now.  I want to thank you very much for all your
> help.  Sincerely. Bob
FYI, you didn't need to get FlashGot - it should work without it.
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.