Restyle the tabstrip

VERIFIED FIXED in Firefox 3 beta2

Status

()

Firefox
Tabbed Browser
P5
normal
VERIFIED FIXED
10 years ago
8 years ago

People

(Reporter: rflint, Assigned: rflint)

Tracking

(Depends on: 1 bug, {perf})

Trunk
Firefox 3 beta2
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 +
in-testsuite -
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Quasi-meta bug to cover the work needed to:
 - Eliminate the fixed height images (bug 350194)
 - Draw borders with border-radius where appropriate
 - Reduce the number of separate images needed
 - Reduce Ts/Txul impact

Updated

10 years ago
Keywords: perf
Depends on: 393734

Updated

10 years ago
Flags: blocking-firefox3?

Comment 1

10 years ago
Border-radius isn't anti-aliased on Linux, is it?
Depends on: 322475
(In reply to comment #1)
> Border-radius isn't anti-aliased on Linux, is it?
> 

I don't believe so and mconnor asked me to check that out just yesterday ;)

Background layering would be nice, but that's not likely to happen for 1.9. I was hoping to just get away with using border-image.
Depends on: 378217

Updated

10 years ago
Depends on: 16380

Comment 3

10 years ago
I was testing with padding-left / padding-right (i.e. no extra xul boxes), one background image and border-radius on Windows, and compared to the current appearance I couldn't really tell a difference. If border-radius could be fixed on Linux, I think that would be the ideal solution.
(In reply to comment #3)
True, it's barely noticeable: http://screwedbydesign.com/images/csstabs.png (note: really old image) and something we might be willing to do without if it comes down to it.
I'd rather use native tabs on Linux if we can't get the current tabs done, because this is a real perf win...
Flags: blocking-firefox3? → blocking-firefox3+

Updated

10 years ago
Target Milestone: Firefox 3 → Firefox 3 M10

Updated

10 years ago
Target Milestone: Firefox 3 M10 → Firefox 3 M11
Blocks: 401931

Updated

10 years ago
Priority: -- → P5

Updated

10 years ago
Blocks: 392870
Created attachment 288618 [details] [diff] [review]
Patch

This takes care of winstripe and gnomestripe (already landed) - I'll file a followup for sticking a band-aid on pinstripe until the new theme's in.
Attachment #288618 - Flags: review?(mconnor)

Comment 7

10 years ago
I think you should use rgba() or native ThreeD* colors; either way would be better than static opaque colors.

Comment 8

10 years ago
(In reply to comment #7)
> I think you should use rgba() or native ThreeD* colors; either way would be
> better than static opaque colors.

for the tab borders
Yes, that's my plan - but since rgba() hasn't really been used at all in the UI, I want an established perf baseline with the other bits from this patch before mucking with it.
OK, but for the selected tab we should probably use ThreeDShadow anyway.
(In reply to comment #10)
> OK, but for the selected tab we should probably use ThreeDShadow anyway.

or ThreeDDarkShadow actually
Duplicate of this bug: 404069

Updated

10 years ago
Blocks: 404069
Blocks: 404167
Comment on attachment 288618 [details] [diff] [review]
Patch

I'm a tad nervous about the colors for the borders, but I'm otherwise ok with this.

I assume this doesn't break Mac, correct?
Attachment #288618 - Flags: review?(mconnor) → review+
Depends on: 404769
Depends on: 404770
mozilla/browser/base/content/browser.css 	1.40
mozilla/browser/base/content/tabbrowser.xml 	1.251
mozilla/browser/themes/winstripe/browser/browser.css 	1.135
mozilla/browser/themes/winstripe/browser/jar.mn 	1.61
mozilla/browser/themes/winstripe/browser/tabbrowser/tab-active-bkgnd.png 	1.1
mozilla/browser/themes/winstripe/browser/tabbrowser/tab-bkgnd.png 	1.1 
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: Firefox 3 Mx → Firefox 3 M10
Blocks: 404774
The windows box is still a bit jumpy (though talos seems to confirm similar drops), but so far it looks like the results are as follows:

Ts before: ~1870ms
Ts after: ~1830ms

Txul before: ~469ms
Txul after: ~450ms

Updated

10 years ago
Depends on: 24998

Updated

10 years ago
No longer depends on: 322475, 378217

Comment 16

10 years ago
This was a 2% Ts win and 4% Txul improvement even though the tab bar isn't shown by default?  Wow.
Blocks: 405670
Blocks: 405673

Updated

10 years ago
No longer blocks: 405673
Depends on: 405673

Updated

10 years ago
No longer blocks: 405670
Depends on: 405670
Depends on: 406202

Comment 17

10 years ago
Hi ryan, do you have a testcase for this bug so QA can verify this fix?
this is mostly code cleanup.
Flags: in-litmus-

Updated

10 years ago
Depends on: 407996
No longer depends on: 407996

Updated

10 years ago
Depends on: 407996

Comment 19

10 years ago
Dao, since this is code cleanup, can you confirm this is fixed in latest builds?  Thanks.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2007121405 Minefield/3.0b3pre
Status: RESOLVED → VERIFIED

Updated

10 years ago
Depends on: 409523

Updated

10 years ago
Blocks: 409553
No longer blocks: 409553
No longer depends on: 409523
You need to log in before you can comment on or make changes to this bug.