Cryptic error message provided when no certificate is available for client SSL authentication

RESOLVED DUPLICATE of bug 107491

Status

()

RESOLVED DUPLICATE of bug 107491
12 years ago
12 years ago

People

(Reporter: pxc, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en) AppleWebKit/419.2.1 (KHTML, like Gecko) Safari/419.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

When a Web site requires client SSL authentication for access, and there is no client certificate in the firefox key store or only an expired certificate, a popup alert dialog is displayed with the error message "<web site url> has received an incorrect or unexpected message. Error Code: -12227".
This error message should be changed to make it more user friendly.

Reproducible: Always

Steps to Reproduce:
1.Attempt to access Web server with client SSL required
2.Popup error message dialog is displayed.  No Web site content is loaded.
Actual Results:  
See Details.

Expected Results:  
The popup error message should be more useful, e.g. "Unable to establish SSL connection.  A client certificate is required."

See Details.

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 107491
You need to log in before you can comment on or make changes to this bug.