Closed Bug 387385 Opened 15 years ago Closed 15 years ago

Remove files from the VirtualStore on uninstall / in-place upgrade / software update

Categories

(Firefox :: Installer, defect)

2.0 Branch
x86
Windows Vista
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 3 alpha7

People

(Reporter: robert.strong.bugs, Assigned: robert.strong.bugs)

Details

(Keywords: verified1.8.1.8)

Attachments

(1 file, 2 obsolete files)

While testing Bug 387373 I noticed that when I opened the install.log in the app dir it contained bogus information. It turned out that it was the install.log in the VirtualStore.
Flags: blocking-firefox3?
Summary: Remove files from the VirtualStore on uninstall / in-place upgrade → Remove files from the VirtualStore on uninstall / in-place upgrade / software update
Attached patch wrong patch (obsolete) — Splinter Review
Attachment #272360 - Flags: review?(sspitzer)
Attachment #272360 - Attachment description: patch → wrong patch
Attachment #272360 - Attachment is obsolete: true
Attachment #272360 - Flags: review?(sspitzer)
Attached patch patch (not safe enough) (obsolete) — Splinter Review
Attachment #272361 - Flags: review?(sspitzer)
Attachment #272361 - Attachment description: patch → patch (not safe enough)
Attachment #272361 - Attachment is obsolete: true
Attachment #272361 - Flags: review?(sspitzer)
Target Milestone: --- → Firefox 3 M7
Version: Trunk → 2.0 Branch
Attachment #272366 - Flags: review?(sspitzer) → review+
Checked in to trunk

Checking in mozilla/toolkit/mozapps/installer/windows/nsis/common.nsh;
/cvsroot/mozilla/toolkit/mozapps/installer/windows/nsis/common.nsh,v  <--  common.nsh
new revision: 1.17; previous revision: 1.16
done
Checking in mozilla/browser/installer/windows/nsis/installer.nsi;
/cvsroot/mozilla/browser/installer/windows/nsis/installer.nsi,v  <--  installer.nsi
new revision: 1.29; previous revision: 1.28
done
Checking in mozilla/browser/installer/windows/nsis/uninstaller.nsi;
/cvsroot/mozilla/browser/installer/windows/nsis/uninstaller.nsi,v  <--  uninstaller.nsi
new revision: 1.6; previous revision: 1.5
done
Checking in mozilla/browser/installer/windows/nsis/shared.nsh;
/cvsroot/mozilla/browser/installer/windows/nsis/shared.nsh,v  <--  shared.nsh
new revision: 1.10; previous revision: 1.9
done
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Flags: blocking-firefox3?
Attachment #272366 - Flags: approval1.8.1.6?
To verify:
1. On Vista install a nightly from before this patch landed into the c:\Program Files\Mozilla Firefox\ directory
2. Open the local Mozilla Firefox directory.
   C:\Users\<username>\AppData\Local\VirtualStore\Program Files\Mozilla Firefox\
3. Install a nightly with this patch applied.
4. The following directory should be removed.
   C:\Users\<username>\AppData\Local\VirtualStore\Program Files\Mozilla Firefox\
(In reply to comment #5)
> To verify:
> 1. On Vista install a nightly from before this patch landed into the c:\Program
> Files\Mozilla Firefox\ directory
Since we now include a manifest this should be a branch build (2.0.0.5 will do) and not a trunk nightly. The rest is the same.
Why is this important to fix on the branch? We've lived with it, I'd rather not change install code if we don't have to.
With the recent landing of Bug 378598 this is probably not as important for the branch since the manifest will prevent Firefox from reading from the VirtualStore. The only problem I know of is that applications that don't have a manifest will continue to open the file located in the VirtualStore when the user opens a file located in the app dir if there is a copy of the file in the VirtualStore. So, if the uninstall.log is edited in any way by a non manifested app there will be a copy made in the VirtualStore and the uninstaller which does not have a manifest will read the one from the VirtualStore during uninstall. I don't know of any apps that modify the uninstall.log so this is rather an edgecase. I do know of app's modifying the install.log as noted in comment #0 which caused some confusion while troubleshooting.

On the other hand the patch has several safegaurds to make it do the right thing so it may be worth it to fix the edgecases.
Comment on attachment 272366 [details] [diff] [review]
patch with a lot of safeguards (finally)

approved for 1.8.1.7, a=dveditz for release-drivers
Attachment #272366 - Flags: approval1.8.1.7? → approval1.8.1.7+
Checked in to MOZILLA_1_8_BRANCH

Checking in mozilla/toolkit/mozapps/installer/windows/nsis/common.nsh;
/cvsroot/mozilla/toolkit/mozapps/installer/windows/nsis/common.nsh,v  <--  common.nsh
new revision: 1.2.2.20; previous revision: 1.2.2.19
done
Checking in mozilla/browser/installer/windows/nsis/installer.nsi;
/cvsroot/mozilla/browser/installer/windows/nsis/installer.nsi,v  <--  installer.nsi
new revision: 1.3.2.27; previous revision: 1.3.2.26
done
Checking in mozilla/browser/installer/windows/nsis/uninstaller.nsi;
/cvsroot/mozilla/browser/installer/windows/nsis/uninstaller.nsi,v  <--  uninstaller.nsi
new revision: 1.1.2.7; previous revision: 1.1.2.6
done
Checking in mozilla/browser/installer/windows/nsis/shared.nsh;
/cvsroot/mozilla/browser/installer/windows/nsis/shared.nsh,v  <--  shared.nsh
new revision: 1.3.2.10; previous revision: 1.3.2.9
done
Keywords: fixed1.8.1.8
hi rob, verified fixed 1.8.1.8 using Firefox 2.0.0.5 (Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.5) Gecko/2007071317 Firefox/2.0.0.5) and the latest Firefox 1.8 Nightly Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.8pre) Gecko/2007093004 BonEcho/2.0.0.8pre while following the steps to reproduce from comment #6 

(Note for the test with 2.0.0.5 and 1.8 Nightly you need to change the install dir for the 1.8 Nighlty to c:\Program
Files\Mozilla Firefox\ )

-> adding verified keyword
You need to log in before you can comment on or make changes to this bug.