Not able to start Firefox with multiple (system) users

RESOLVED DUPLICATE of bug 296363

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 296363
11 years ago
11 years ago

People

(Reporter: Kondala Rao, Unassigned)

Tracking

2.0 Branch
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Build Identifier: 2.0.0.4

Not able to open firefox two instances this same comand line on sosris

Reproducible: Always

Steps to Reproduce:
1.one user login to solaris machine with login name: user1
2.Second user also login same machine same login name: user1

3.open firefox by first user
4.second user can't use open firefox

Actual Results:  
Comand line 
>./firefox & ----- this open firefox
>./firefox ------ this open a alert firefox already open or not responding 

There is no problem with mozilla, this open profile atleast 

Expected Results:  
>./firefox & ----- this open firefox
>./firefox ------ this also should  open firefox
(Reporter)

Updated

11 years ago
Severity: normal → critical
OS: Other → Solaris
Hardware: Other → Sun
Version: unspecified → 2.0 Branch

Comment 1

11 years ago
http://kb.mozillazine.org/Profile_in_use

The problem is that you can't share a profile between 2 different instances of Firefox. Either you need to use 2 different users, or each user needs to use it's own profile. You can start firefox for instance like this :

./firefox -P first &
./firefox -P second

You can create additional profiles like this :
./firefox -profilemanager

Updated

11 years ago
Severity: critical → normal
Summary: Not abler to start firfox multiple instance → Not able to start Firefox with multiple (system) users

Comment 2

11 years ago
I thinke it's not a bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

11 years ago
Yes, This is a bug. Are you stoping to open two firefox window? Is it is a feature?
(Reporter)

Comment 4

11 years ago
We are having one script call thit firefox like this 
/opt/sfw/lib/firefox/firefox $url
First Exceed session it's working and user open second Exceed session with same username it's not working . Please help me is there anyway to resolve this?
Mozilla use to alleast open profile windown. 
(Reporter)

Updated

11 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 5

11 years ago
Try using the "-no-remote" command line option, or setting an environment variable "MOZ_NO_REMOTE" to "1". If that helps, please close this bug as INVALID.
Thanks.

Comment 6

11 years ago
Or maybe not invalid. Not sure what is meant, sorry.
(Reporter)

Comment 7

11 years ago
Can i create profile through command line? Please help me to show script used in GUI to create a new profile.
Thanks
Kondala Rao

Comment 8

11 years ago
(In reply to comment #7)
> Can i create profile through command line? Please help me to show script used
> in GUI to create a new profile.
> Thanks
> Kondala Rao
> 

1.$ firefox -profilemanager # or $ firefox -P
2.Pop out a dialog
3.Create a new profile named "test"
4.$ firefox -P test         #launch test profile



(Reporter)

Comment 9

11 years ago
>firefox & on 0.0 display
>firefox & on 1.0 display 


also not working with same message. It is some problem 

even you can't start fireforx two times
>firefox &
>firefox &
(Reporter)

Comment 10

11 years ago
I want to create pofile with out popup. any command line binary/script 

Comment 12

11 years ago
Isn't it a dup of bug 296396?

Comment 13

11 years ago
sorry, I made a mistake, it should be bug 296363
(Reporter)

Comment 14

11 years ago
Please let me know is it is a bug ? if it is how much time you will take to fix this. Thanks

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 296363
You need to log in before you can comment on or make changes to this bug.