Closed Bug 387454 Opened 14 years ago Closed 14 years ago

no version info in Minefield's xul.dll on Windows

Categories

(Toolkit Graveyard :: XULRunner, defect)

x86
Windows XP
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.9beta3

People

(Reporter: info, Assigned: benjamin)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007070904 Minefield/3.0a7pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007070904 Minefield/3.0a7pre

My nightly Minefield has an 8MB xul.dll file, but for some reason it has no Version information.

Reproducible: Always

Steps to Reproduce:
1. Right-click on C:\Program Files\Minefield\xul.dll, choose Properties
Actual Results:  
No Version tab, no version information; the Summary tab's fields are blank.

Expected Results:  
It would be useful to know what version of XULRunner/libxul Firefox uses.

Maybe this bug belongs in Toolkit/XULRunner.  But FWIW my Joost beta has a tiny C:\Program Files\Joost\xulrunner\xul.dll with full version info (1.9.20070.52311), so perhaps it's just the way Firefox builds libxul.

(*Congratulations* on XULRunner-based Firefox!)
The XULRunner nightly build in http://ftp.mozilla.org/pub/mozilla.org/xulrunner/nightly/latest-trunk/ has the same issue; attempting to change to Toolkit/XULRunner.
Component: Build Config → XULRunner
Product: Firefox → Toolkit
Version: unspecified → Trunk
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 386740
This is in fact not a duplicate. Fix forthcoming.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Because we were using RESFILE the normal module.rc wasn't being used... this changes to use RCINCLUDE so that we combine the widget resources with the default version resource.
Assignee: nobody → benjamin
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #296954 - Flags: review?(ted.mielczarek)
Attachment #296954 - Flags: review?(ted.mielczarek) → review+
Attachment #296954 - Flags: approval1.9?
Attachment #296954 - Flags: approval1.9? → approval1.9+
Fixed on trunk.
Target Milestone: --- → mozilla1.9 M11
Status: ASSIGNED → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → FIXED
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.