Empty <%APPDATA%\Mozilla> directory created on startup, looking for <%APPDATA%\Mozilla\Plugins>

RESOLVED DUPLICATE of bug 378854

Status

RESOLVED DUPLICATE of bug 378854
12 years ago
11 years ago

People

(Reporter: sgautherie, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a7pre) Gecko/200707100303 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

On first launch, SeaMonkey creates empty <%APPDATA%\Mozilla> directory (if it doesn't already exists),
with "APPDATA=C:\Documents and Settings\<WindowsUsername>\Application Data".

That's useless as it will be using <%APPDATA%\mozilla.org> to store its profiles.

***

{{
Newsgroups: mozilla.dev.apps.seamonkey
Date: Fri, 08 Jun 2007 16:28:50 +0100
From: Mark Banner <bugzilla@nospam.standard8.demon.co.uk>


Bruno Escherl wrote:
> I had a closer look with Sysinternals' ProcessMonitor. The Migrator is 
> definitely reading registry.dat (but I wonder why it wants to access 
> %APPDATA%\Mozilla\Plugins at start).

Hmm, that's useful to know (the plugins bit) I was wondering what may be 
causing it to create a Mozilla folder in %APPDATA%.
}}
OS: Windows 2000 → All
Hardware: PC → All
(Reporter)

Comment 1

12 years ago
Created attachment 271683 [details]
ProcessMonitor log on that directory

FWIW.
I knew about it just had forgotten about it so thanks for filing. Its an xulrunner/startup issue, see bug 378854 (adding dep).
Depends on: 378854
(Reporter)

Comment 3

12 years ago
I thought about this, but didn't find that other bug.
Do you want to keep this one open/dependent, or resolve it duplicate ?
I'm going to close this bug as duplicate of bug 378854.

Reason being with SeaMonkey changing back to .mozilla (bug 393620) this doesn't directly affect us any more. As bug 378854 covers the core issue, then we don't need to worry about it in a SeaMonkey specific bug.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
No longer depends on: 378854
Resolution: --- → DUPLICATE
Duplicate of bug: 378854
You need to log in before you can comment on or make changes to this bug.