Mozilla Firefox renders fonts completely unlike any other GTK application

RESOLVED FIXED

Status

()

Firefox
Shell Integration
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Kurt H Maier, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

On a stock installation of Slackware (any version), Firefox doesn't render fonts like other GTK apps do.  It honors the .gtkrc-2.0 file's "gtk-font-name" line.  It honors changes to fonts.conf (and symlinks in fonts/conf.d).  But none of the menus look like any other menu from any other GTK application.

Reproducible: Always

Steps to Reproduce:
1. Install Slackware.
2. Run firefox.
3. Run any other GTK application.

Actual Results:  
Firefox's fonts are "fuzzier" with or without a bytecode interpreter enabled.  

Expected Results:  
Firefox's UI fonts should look like other GTK apps.

screenshot highlighting the difference: http://img239.imageshack.us/img239/5402/shotre5.png

On this system, the bytecode interpreter has been enabled.
This bug has been around as long as I've used Firefox on linux.

Comment 1

11 years ago
Is it better on trunk?  Font selection and rendering have been pretty much rewritten since Firefox 2.0.0.x.
(Reporter)

Comment 2

11 years ago
It is fixed in trunk.  Sorry.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.