Can't open detached image which name is long and strange

RESOLVED DUPLICATE of bug 350825

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 350825
11 years ago
8 years ago

People

(Reporter: lijuan wang, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Created attachment 271790 [details]
image

snv_68_vemillion_69_dev X86
Thunderbird version 2.0.0.4 (20070703)

Reproduce steps:
1. Open a message with attachments :"1.jpg" and "u=1908531333,2646181854&gp=2.jpg"
2. In the attachment pane, bring up the context menu of "1.jpg", detach it to /export/home/work/Document
3. In the attachment pane, bring up the context menu of "u=1908531333,2646181854&gp=2.jpg", detach it to /export/home/work/Document
4. In the attachment pane, bring up the context menu of them and open them.

Acutal result:
After step#2,#3: The images are saved in /export/home/work/Document
After step#4: "1.jpg" is opened successfully.
the other image can't be opened. The error information is as follows:
"File not found
The file /export/home/work/Documents/u=4172966704 cannot be found. Please check the location and try again."

Expected result:
After step#4: The two images can be opened.
(Reporter)

Comment 1

11 years ago
I tried these steps on thunderbird trunk version 3.0a1pre (2007071003)
After step#4: Neither of the images can be opened.
The error information like this:
"File not found
The file /export/home/work/Documents/1.jpg&filename=1.jpg cannot be found. Please check the location and try again."
"File not found
The file /export/home/work/Documents/u=4172966704&filename=u=4172966704,2932593494&gp=2.jpg cannot be found. Please check the location and try again."

(Reporter)

Comment 2

11 years ago
Can be reproduced on windows XP thunderbird2.0.0.4(20070604)
OS: SunOS → All
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 350825
You need to log in before you can comment on or make changes to this bug.