DEBUG: crash [@ strlen] from [@ ListFloats] when dumping frame tree

RESOLVED FIXED

Status

()

Core
Layout: Floats
RESOLVED FIXED
11 years ago
7 years ago

People

(Reporter: mats, Assigned: mats)

Tracking

({crash, testcase})

Trunk
x86
Linux
crash, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Assignee)

Description

11 years ago
DEBUG: crash [@ strlen] from [@ ListFloats] when dumping frame tree

STEPS TO REPRODUCE
1. run "firefox -layoutdebug URL"
2. dump the frame tree

(URL is Testcase #1 in bug 375462)
(Assignee)

Comment 1

11 years ago
Created attachment 271804 [details] [diff] [review]
Patch rev. 1

There's a %s without a the corresponding char* arg that cause the crash.
Also, I'd like a message that stands out a frame dump if the float happens
to be null, yet I don't want to assert since I often debug with
XPCOM_DEBUG_BREAK=trap and I wouldn't want a break for a frame dump
(which I also add to the code when debugging).
Attachment #271804 - Flags: superreview?(roc)
Attachment #271804 - Flags: review?(roc)
Attachment #271804 - Flags: superreview?(roc)
Attachment #271804 - Flags: superreview+
Attachment #271804 - Flags: review?(roc)
Attachment #271804 - Flags: review+
(Assignee)

Comment 2

11 years ago
Bug 388358 fixed the fprintf arg list already, I checked in the rest.

mozilla/layout/generic/nsLineBox.cpp 	1.121

-> FIXED
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Crash Signature: [@ strlen] [@ ListFloats]
You need to log in before you can comment on or make changes to this bug.