If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Build failure with --enable-accessibility [@nsDocAccessibleWrap]

RESOLVED DUPLICATE of bug 386978

Status

()

Core
Disability Access APIs
RESOLVED DUPLICATE of bug 386978
10 years ago
10 years ago

People

(Reporter: philippe (part-time), Assigned: Aaron Leventhal)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Both Minefield and Camino (trunk) builds fail to build with --enable-accessibility.

/Users/phiw/camino-build/mozilla/accessible/src/mac/nsDocAccessibleWrap.mm:44: error: ISO C++ forbids declaration of 'nsDocAccessibleWrap' with no type
/Users/phiw/camino-build/mozilla/accessible/src/mac/nsDocAccessibleWrap.mm:44: error: no 'int nsDocAccessible::nsDocAccessibleWrap(nsIDOMNode*, nsIWeakReference*)' member function declared in class 'nsDocAccessible'
/Users/phiw/camino-build/mozilla/accessible/src/mac/nsDocAccessibleWrap.mm: In member function 'int nsDocAccessible::nsDocAccessibleWrap(nsIDOMNode*, nsIWeakReference*)':
/Users/phiw/camino-build/mozilla/accessible/src/mac/nsDocAccessibleWrap.mm:44: error: only constructors take base initializers
/Users/phiw/camino-build/mozilla/accessible/src/mac/nsDocAccessibleWrap.mm:45: error: type 'class nsDocAccessible' is not a direct base of 'nsDocAccessible'
/Users/phiw/camino-build/mozilla/accessible/src/mac/nsDocAccessibleWrap.mm: At global scope:
/Users/phiw/camino-build/mozilla/accessible/src/mac/nsDocAccessibleWrap.mm:54: error: no 'nsresult nsDocAccessible::FireToolkitEvent(PRUint32, nsIAccessible*, void*)' member function declared in class 'nsDocAccessible'
/Users/phiw/camino-build/mozilla/accessible/src/mac/nsDocAccessibleWrap.mm: In member function 'int nsDocAccessible::nsDocAccessibleWrap(nsIDOMNode*, nsIWeakReference*)':
/Users/phiw/camino-build/mozilla/accessible/src/mac/nsDocAccessibleWrap.mm:47: warning: control reaches end of non-void function

Regressed somewhere between 20070702 and 20070706
(I'm not sure when exactly, as the Camino trunk has been on fire for most of the time - a Camino trunk build made on 20070702 was successful, a Minefield build on 20070706 ~3:30 am PDT failed).

Possibly a regression of bug 378468.

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 386978
You need to log in before you can comment on or make changes to this bug.