Timezone settings not applied after restart.

VERIFIED DUPLICATE of bug 314339

Status

Calendar
Internal Components
VERIFIED DUPLICATE of bug 314339
11 years ago
11 years ago

People

(Reporter: Sander Marechal, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.4) Gecko/20070508 Iceweasel/2.0.0.4 (Debian-2.0.0.4-0etch1)
Build Identifier: Lightning 0.5 and 0.7pre nightly from 2007-07-10 on Thunderbird 1.5.0.12

The timezones are not applied correctly to events using Lightning 0.5 or 0.7pre nightly from 2007-07-10 on Thunderbird 1.5.0.12.

In my personal calendar I have several reoccurring events and a few normal events. All the recurring events were sent from Outlook 2000 (I will attach the ics file). My timezone setting is Europe/Amsterdam (currently +0200 due to DST). When I accept the event in Thunderbird it is added with the correct time to my calendar. Changing the timezone preferences correctly moves the added events to the new correct time.

After closing and restarting Thunderbird all the reoccurring events that I added previously are shown on their UCT time, not my +0200 time. Changing the timezone preference does not move the events up and down anymore. When I add another event (be it manually or another ics from Outlook) all the events suddenly "jump" to the correct timezone settings. So, if the reoccurring event is at 10:15 it is first incorrectly shown at 10:15 instead of 12:15. When I add another, unrelated event then the reoccurring event suddenly does display at 12:15.

When I close and start thunderbird yet again, the reoccurring events are shown at their UTC time again. However, the event that I added manually to make the items "jump" to the correct time, *is* shown at the correct +0200 time. When I now start changing my timezone preference the event that I added manually does move up and down while the reoccurring events from Outlook do not.

Reproducible: Always

Steps to Reproduce:
1. Set a timezone that's not UTC
2. Add the attached ics
3. Restart thunderbird
4. Observe wrong event placement
5. Add an event manually and observe the other event "jumping" to correct time
6. Restart again
7. Play with timezone preference and observe one event moving, the other not
Actual Results:  
The reoccurring events do not honour timezone settings after restart

Expected Results:  
Events should display at correct time according to timezone
(Reporter)

Comment 1

11 years ago
Created attachment 271811 [details]
reoccurring event sent from Outlook
Foreign timezone information lost after restart -> Bug 314339.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 314339

Updated

11 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.