If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add no title bookmark adds an empty titled bookmark

RESOLVED DUPLICATE of bug 407292

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 407292
10 years ago
8 years ago

People

(Reporter: tracy, Assigned: Ehsan)

Tracking

({uiwanted})

Trunk
Firefox 3 beta3
uiwanted
Points:
---
Bug Flags:
in-litmus +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

10 years ago
Discovered this verifying bug 379552.  Need confirmation that this exist on Windows.  My machine is currently in the shop.

STR:

1. Use the test page from that bug; https://bugzilla.mozilla.org/attachment.cgi?id=262682
2. Select Bookmarks > Bookmark This Page...
3. Notice in the resulting add bookmark dialog that the Name: field is empty. Leave it that way, select Bookmarks Toolbar, then click "Add"

Tested results:
An empty titled bookmark (yet functional) is added to the toolbar. In the bookmarks organizer this bookmark has "(no title)"

Expected results:
As in bug 379552, the no title bookmark should take the URL as its title

test case http://litmus.mozilla.org/show_test.cgi?searchType=by_id&id=4453 added to
Litmus 3.0 FFT
Flags: in-testsuite+

Updated

10 years ago
Flags: in-testsuite+ → in-litmus+
Confirming on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007072101 Minefield/3.0a7pre.
OS: Mac OS X → All
Hardware: Macintosh → All
Created attachment 273290 [details] [diff] [review]
Replace empty titles with the URI, if provided

Fixing this problem by replacing the empty titles (or non-string titles) with the URI, if one is provided.
Assignee: nobody → ehsan.akhgari
Status: NEW → ASSIGNED
Attachment #273290 - Flags: review?(mano)
Created attachment 273294 [details] [diff] [review]
Replace empty titles with the URI, if provided, in the places transaction

Oops, the previous patch did the title check in the wrong place.  Here is a patch to do it in the places transactions services, before adding the bookmark.
Attachment #273290 - Attachment is obsolete: true
Attachment #273294 - Flags: review?(mano)
Attachment #273290 - Flags: review?(mano)
Wasn't this a "bug" in Fx2 too? I've seen people using untitled bookmarks on purpose very often (esp. when adding the item to the toolbar folder).
(In reply to comment #4)
> Wasn't this a "bug" in Fx2 too? I've seen people using untitled bookmarks on
> purpose very often (esp. when adding the item to the toolbar folder).
> 

Hmmm, to me an untitled bookmark looks like an untitled file.  I don't think just because Firefox 2 had the same bug we should leave it unfixed.
Well, they were used this way for the bookmarks toolbar. One could have a lot of items in the toolbar and identify them by their favicons.

I think a better plan is to show the history-title for the item under the menu and tree bindings (rather than the the "(no title)" label), and keep the toolbar as is. This needs ui-review though.
Keywords: uiwanted
Attachment #273294 - Flags: review?(mano) → review-
(In reply to comment #6)
> I think a better plan is to show the history-title for the item under the menu
> and tree bindings (rather than the the "(no title)" label), and keep the
> toolbar as is. This needs ui-review though.
> 

Hmmm.  Forgive my ignorance, but what is history-title?  How should I obtain it for an item?
On a page without a title, such as https://bugzilla.mozilla.org/attachment.cgi?id=262682, Firefox 2.0.0.6 inserts the URL as the title. Trunk does not do this, using "(no title)" instead. We should replicate the Firefox 2.0.0.6 behavior unless we plan on changing it for a reason.
Comment on attachment 273294 [details] [diff] [review]
Replace empty titles with the URI, if provided, in the places transaction

(In reply to comment #8)
> On a page without a title, such as
> https://bugzilla.mozilla.org/attachment.cgi?id=262682, Firefox 2.0.0.6 inserts
> the URL as the title. Trunk does not do this, using "(no title)" instead. We
> should replicate the Firefox 2.0.0.6 behavior unless we plan on changing it for
> a reason.
> 

This patch does exactly this, hence requesting review (again) and ui-review.
Attachment #273294 - Flags: ui-review?(beltzner)
Attachment #273294 - Flags: review?(abillings)
Attachment #273294 - Flags: review-
Whiteboard: [has patch] [needs review abillings, beltzner]
Target Milestone: --- → Firefox 3 M11
abillings can't review this. You probably want Mano instead.
Whiteboard: [has patch] [needs review abillings, beltzner] → [has patch] [needs review Mano, beltzner]
Comment on attachment 273294 [details] [diff] [review]
Replace empty titles with the URI, if provided, in the places transaction

Callers should do this, otherwise this would break adding title-less bookmarks to the toolbar, for example.
Attachment #273294 - Flags: review?(abillings) → review-
notice, i have a similar patch in Bug 407292 that touch up views instead of transaction, and does not touch up toolbar should be safer for third party users...

and probably these bugs are dupes, DOH!
i think that we should retain that bug and mark this as dupe because there we have betltzner blocking, what do you think Ehsan?
Yeah, definitely looks like a dupe of bug 407292.  Marking as such...  Thanks for bringing this to my attention, Marco.

BTW, I have a small comment on your patch which I'll comment about on that bug.   :-)
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 407292
Whiteboard: [has patch] [needs review Mano, beltzner]
Attachment #273294 - Flags: ui-review?(beltzner)
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.