text size increase then decrease within a table cell can cause text to disappear

RESOLVED WORKSFORME

Status

()

Core
Layout: Tables
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: Becky Gibson, Unassigned)

Tracking

({testcase})

1.8 Branch
x86
Windows XP
testcase
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

two inline divs within a table cell.   If increase the text size via view text size increase some of the text no longer displays.  If you next select view text size decrease, the text which disappeared does not re-display. Using view text size normal also does not work. 

Reproducible: Always

Steps to Reproduce:
Here is example code:
<HTML lang="en">
<BODY>
<p>press <b>ctrl +</b> followed by <b>ctrl -</b>(or view text size increase followed by view text size decrease)  to make sure everything looks the same afterwards:</p>
<div>Example below is in a fieldset:</div>
<fieldset style="display:inline;border:1px solid black;">
	<div style="float:left;height:100%;">stays</div><div style="float:left;height:100%;">together</div>
</fieldset>
<br>
<div>Example that does not work is a table cell</div>
<table style="padding:0px;border:1px solid black;"><tr><td>
	<div style="float:left;height:100%;">breaks</div><div style="float:left;height:100%;">apart and disappears</div>
</td></tr></table>
</BODY>
</HTML>

Run file. Notice the text displayed in the table cell that displays: "breaksapart and disappears". The word breaks is in one div and "apart and disappears" is in another div (both with style="float:left").
Select View Text Size Increase.  
Actual Results:  
Notice that only the word "breaks" is displayed when the text size increases.
Select View Text Size Decrease or View Text Size normal. The text size is returned to normal but the word "breaks" is still the only thing displayed. 

Expected Results:  
Don't expect the words to disappear with text size is increased.  AND when text size is restored to normal, expect all of the text (breaksapart and disappears) to display again.
(Reporter)

Comment 1

11 years ago
Created attachment 271906 [details]
demonstates that text resizing does not work properly in table cell

Comment 2

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007071105 Minefield/3.0a7pre

This appears to work for me on Windows trunk. Can you test in a trunk build? http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/

Comment 3

11 years ago
WFM on Trunk too, confirming as Branch only for the moment, probably a table layout problem?
Change version if you can reproduce on Trunk too
Status: UNCONFIRMED → NEW
Component: Disability Access → Layout: Tables
Ever confirmed: true
Product: Firefox → Core
QA Contact: disability.access → layout.tables
Version: unspecified → 1.8 Branch

Comment 4

11 years ago
General policy thus far has been to just resolve non-critical bugs that only occur on the 1.8 branch (and not trunk) as WORKSFORME, since the chances of them getting fixed on branch is very low.

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Flags: in-testsuite?
Keywords: testcase
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.