browser.tabs.tabMinWidth is ignored when value is 1 or 0

RESOLVED INVALID

Status

()

Firefox
Tabbed Browser
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Joe Bayes, Unassigned)

Tracking

2.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.4) Gecko/20070603 Fedora/2.0.0.4-2.fc7 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.4) Gecko/20070603 Fedora/2.0.0.4-2.fc7 Firefox/2.0.0.4

When I set browser.tabs.tabMinWidth to either 1 or 0, I expect that tabs will scroll only when they are less than 0 or 1 pixels wide (i.e. never -- I'm trying to disable the feature). 

Instead, when I set browser.tabs.tabMinWidth to either 1 or 0, the tabs start to scroll off the side of the screen once I open up 20 windows or so (when the tabs are about 40 pixels wide). 

I quit and restarted firefox after changing the setting. 

Reproducible: Always

Steps to Reproduce:
1. about:config and set browser.tabs.tabMinWidth to 0
2. Restart Firefox.
3. Open a bunch of tabs. On my screen, "a bunch" is about 20 or 25. 

Actual Results:  
Tabs scroll off the side of the screen, so that only 20 tabs are visible at once.

Expected Results:  
All 25 tabs should have been displayed, with each one being very skinny.

Comment 1

10 years ago
It's not ignored, there is just a limit on how small a tab can be. There are two images (to the left and right of the favicon) which are both 8px wide, as well as the favicon that cannot shrink any smaller than 16px. 

I'd say this is INVALID or WONTFIX based on the design of the tabbar.
OS: Linux → All
Hardware: PC → All
Version: unspecified → 2.0 Branch
(Reporter)

Comment 2

10 years ago
So, is there no way to restore the default 1.5 behavior, where the tabs just got really small, displayed only the portion of the icon/text that would fit, and didn't hide themselves off the sides of the screen? 

If not, then that's a shame, as I really liked the old behavior. 

There are quite a few web pages that claim that setting browser.tabs.tabMinWidth to 0 will disable tab scrolling. (For example, http://lifehacker.com/software/firefox-2/firefox-2-tip--disable-or-modify-tab-scrolling-208251.php ). This leads me to believe that tab scrolling was disable-able at some point in the past (since 2.0 came out). Perhaps we could figure out what was changed, and see if we could change it back?

Note that the current behavior contradicts the documentation at http://kb.mozillazine.org/Browser.tabs.tabMinWidth . (Specifically, "Possible values and their effects: Any positive integer value of pixels. Browser tabs may shrink to this value, but may not become any narrower.")

AFAIK, that's the closest thing that firefox has to documentation, so at the very least, if the current behavior is here to stay, the documentation should be changed. 

Comment 3

10 years ago
I've updated the documentation on the MozillaZine Knowledge Base. 

To answer your question, yes, this probably worked before the new theme for Firefox 2 landed. Before the theme, we were using "native" tabs, whereas with the new theme, we use images to create the tab's look.

The only way I could think of disabling this would be to use some theme which reverts the new changes to the tabbar (although, I don't know if this is even possible).
(Reporter)

Comment 4

10 years ago
For the next person to get bitten by this:

While it doesn't disable the offending behavior, putting 

.tabbrowser-tabs .tab-icon { display: none }

into your userChrome.css file will approximately double the number of tabs you can have open (at the cost of removing the icons in the tab bar.)

Perhaps there is a way to disable the 8px pictures on either side of the icon as well. 

Comment 5

10 years ago
Resolving this as INVALID, as this works as designed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.