STATE_EXPANDABLE isn't exposed correctly

RESOLVED FIXED

Status

()

Core
Disability Access APIs
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Joanmarie Diggs, Assigned: surkov)

Tracking

(Blocks: 2 bugs, {access})

Trunk
x86
Linux
access
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

11 years ago
Steps to reproduce:

1. Launch Thunderbird and Accerciser
2. Select "Local Folders" (or any other expandable table cell) in Thunderbird
3. Use Accerciser's Interface Viewer to examine the states of the object you chose in step 2.

Expected results:  "Expandable" would be included in the list of states.

Actual results: "Expandable" is not included in the list of states.
(Assignee)

Comment 1

11 years ago
Created attachment 272114 [details] [diff] [review]
patch

it's a bit strange but treeitem accessible doesn't call nsAccessible::GetState(). I'm not sure why exactly. It leads we can loose some states like in this bug.
Assignee: aaronleventhal → surkov.alexander
Status: NEW → ASSIGNED
Attachment #272114 - Flags: review?(ginn.chen)
(Assignee)

Comment 2

11 years ago
Created attachment 272115 [details] [diff] [review]
patch

correct patch
Attachment #272114 - Attachment is obsolete: true
Attachment #272115 - Flags: review?(ginn.chen)
Attachment #272114 - Flags: review?(ginn.chen)
(Assignee)

Comment 3

11 years ago
Created attachment 272122 [details] [diff] [review]
states patch

It looks we never set some extra states because we call nsAccessible::GetState() in begin of nsAccClass::GetState(). So I guess we should set these states after nsAccClass::GetState(). Correct?
Attachment #272122 - Flags: review?(ginn.chen)
(Assignee)

Comment 4

11 years ago
Comment on attachment 272115 [details] [diff] [review]
patch

reduce the number of reviews from Ginn.
Attachment #272115 - Flags: review?(ginn.chen) → review?(aaronleventhal)
(Assignee)

Updated

11 years ago
Attachment #272122 - Flags: review?(ginn.chen) → review?(aaronleventhal)

Comment 5

11 years ago
Comment on attachment 272115 [details] [diff] [review]
patch

This patch is okay, the other one isn't.
Attachment #272115 - Flags: review?(aaronleventhal) → review+

Comment 6

11 years ago
Comment on attachment 272122 [details] [diff] [review]
states patch

We need this code in nsAccessible::GetState() because of states set in ARIA.
Attachment #272122 - Flags: review?(aaronleventhal) → review-
(Assignee)

Comment 7

11 years ago
(In reply to comment #6)
> (From update of attachment 272122 [details] [diff] [review])
> We need this code in nsAccessible::GetState() because of states set in ARIA.
> 

Sorry? We can't keep this in nsAccessible::GetState() because these states won't be setted if related states are defined in successors of nsAccessible. Why we can't set them after all states are calculated?

Comment 8

11 years ago
Okay, you can move it to GetFinalState() -- does that make sense?
(Assignee)

Comment 9

11 years ago
(In reply to comment #8)
> Okay, you can move it to GetFinalState() -- does that make sense?
> 

I moved there because we add those states after another states are generated on all accessible objects. I guess it makes more sense than ignore states that will be setted on successors of nsAccessible. Though in this case we can't use them in successors at all. Now we don't use them.

Comment 10

11 years ago
Comment on attachment 272122 [details] [diff] [review]
states patch

My mistake. What you did is correct, I didn't see the 2nd part of the patch.
Attachment #272122 - Flags: review- → review+
(Assignee)

Comment 11

11 years ago
both patches was checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Summary: "Expandable" tree table cells should expose STATE_EXPANDABLE → STATE_EXPANDABLE isn't exposed correctly
You need to log in before you can comment on or make changes to this bug.