Camino 1.5 crashes on launch for one particular user account on computer.

VERIFIED INVALID

Status

Camino Graveyard
General
--
critical
VERIFIED INVALID
11 years ago
11 years ago

People

(Reporter: Stephanie Smith, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en) AppleWebKit/419 (KHTML, like Gecko) Safari/419.3
Build Identifier: 

Summary pretty much covers it. 

Beginning earlier today, Camino consistently crashes upon launch (after the main window displays, but before the home page is loaded) for one particular user on one particular computer. Presumably this is some sort of environment issue; other users on the computer (with the same home page) are not able to reproduce the problem. 

Before today, the user was able to run Camino without trouble. No obvious changes to the system or account were made in the meantime.

We've tried rebooting, wiping out the ~/Library/Application Support/ Camino directory, un- and re-installing Camino, but the problem remains. I'm hoping that something in the Problem Report will point to the issue, or somebody will be able to suggest a fix or work-around. I suspect the actualy problem is obscure and possibly unique. We're less looking for a "bug fix", and more looking for a way to make Camino work again ;)

The user account which is affected is a mobile account. The user can log in to other computers on the network with the same account, and launch Camino successfully.

Reproducible: Always

Steps to Reproduce:
1. Log in as user "arakune" on machine "Son_Of_Mr_Gosh"
2. Launch Camino
Actual Results:  
Camino launches, but crashes before the home page can display.

Expected Results:  
Camino should have launched, loaded the default home page, and remained open in a usable state.

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_INVALID_ADDRESS (0x0001) at 0xbf7ffffc

Account is a mobile account, which syncs ~/Library back to the OS X server on login/logout. The change (from "working" to "not working") occured several hours after a login. Unfortunately, we can't recall whether Camino had been successfully launched since that login. (i.e., we don't know if this is a problem that was introduced with a home directory sync.)

Camino was tested on the same computer using a local account, and it worked.

The same preference files (~/Library/Application Support/Camino/) but a seperate install of Camino was also tested on 2 different computers (by logging in locally to the server, and by logging in as a network non-mobile user on a laptop), and both worked.
(Reporter)

Comment 1

11 years ago
Created attachment 272097 [details]
Problem Report from OS
The crash log consists almost entirely of the third-party add-on 1passwd crashing (and thereby crashing Camino), so this is INVALID (i.e., not a bug in Camino).  

Check for 1passwd in the user's ~/Library/InputManagers, ~/Library/InputManagers/SIMBL and either remove it, or upgrade to the latest version (older versions of 1passwd were known to crash Camino at launch).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

11 years ago
Aah! Curious that 1passwd wasn't crashing Camino before (we've been using them together for several months). But that's something to look at elsewhere.

Thanks for pointing out what should have been obvious!

Updated

11 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.