Closed Bug 387999 Opened 13 years ago Closed 11 years ago

theme preview image is squished when using splitter

Categories

(Toolkit :: Add-ons Manager, defect)

x86
Windows XP
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla1.9.1b1

People

(Reporter: mcdavis941.bugs, Unassigned)

References

Details

(Keywords: polish, Whiteboard: [fixed by bug 423469])

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007070804 Minefield/3.0a7pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007070804 Minefield/3.0a7pre

With the themes view of the Add-ons Manager, if you move the splitter (between the list of themes and the theme preview) to the right, it squishes the theme preview image along the x axis.  

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Version: unspecified → Trunk
Confirming, on Branch the image does not resize and a scrollbar appears
on trunk it resize horizontally, sometimes a scrollbar appears too, while it should resize mantaining ratio
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: polish
note: bug 267831 may also be related in that this is most likely due to a core or widget change
Summary: theme preview image is squished when using splitter on 3.0a7 → theme preview image is squished when using splitter
I can confirm on Linux.
confirmed on Mac OS X 10.5.2
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008042317 Minefield/3.0pre ID:2008042317
Requesting blocking because Bug 428677 blocked also.
Flags: blocking-firefox3?
change os to all.
We just need to set a size for preview images, and then lock the right hand side to that minwidth. Doesn't block, but easy fix IMO.
Flags: blocking-firefox3? → blocking-firefox3-
Product: Firefox → Toolkit
Whiteboard: [good first bug]
Easier would be to make the theme preview image box scrollable, so that the image will not be squished...
It's a little tricky here, b/c the themePreviewArea box has some wierd styling (width:0px) and it won't seem to behave when it's changed, ie if you give it a min-width the splitter will just snap to the right when that min-width is reached, and if you give the deck only a min-width it'll maintain it's width and just produce scrollbars when the splitter passes that min-width, eventually just completely closing...

Any further ideas?
Remove that styling and replace by a more normal scrollable view...
Fixed by bug 423469
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Whiteboard: [good first bug]
Target Milestone: --- → mozilla1.9.1b1
Whiteboard: [fixed by bug 423469]
verified fixed using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081014 Minefield/3.1b2pre. Also verified on Windows Vista.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.