PROPFIND truncates URL parameters

RESOLVED FIXED in 0.7

Status

Calendar
Provider: CalDAV
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Jakub Klos, Assigned: Bruno Browning)

Tracking

unspecified

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1;  Embedded Web Browser from: http://bsalsa.com/; .NET CLR 2.0.50727; .NET CLR 1.1.4322)
Build Identifier: 0.7 pre

When created a new caldav remote calendar with the URL containing parameters (such as http://server/webdav/?param=value) then PROPFIND will do a query just to the URI without the params:
http://server/webdav/
REPORT on the other hand contains the full URL. So it seems to be related only to PROPFIND

Reproducible: Always

Steps to Reproduce:
1. Create remote a remote calendar http://server/webdav/?param=value
2. Restart thunderbird and see the caldav server logs
3. you will notice PROPIND truncated the URL but REPORT has the complete URL


Expected Results:  
All webdav/caldav commands should always preserve the full URL
(Assignee)

Comment 1

11 years ago
Created attachment 273275 [details] [diff] [review]
propfind correct uri

went ahead and renamed function, as previously discussed, at the same time
Assignee: nobody → browning
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #273275 - Flags: review?(daniel.boelzle)

Updated

11 years ago
Attachment #273275 - Flags: review?(daniel.boelzle) → review+

Comment 2

11 years ago
Checked in on HEAD and MOZILLA_1_8_BRANCH.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.7
You need to log in before you can comment on or make changes to this bug.