Problems with tooltips/context menus in same popupset

RESOLVED FIXED in mozilla1.0

Status

()

Core
XUL
P2
normal
RESOLVED FIXED
18 years ago
17 years ago

People

(Reporter: Mike Pinkerton (not reading bugmail), Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Trunk
mozilla1.0
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

18 years ago
Go into the mail folderpane, hover over one of the folders until its tooltip 
appears. Now context-click.

expected:
- context menu for that folder should appear and stay on the screen

actual:
- context menu appears and disappears. Looks like a bad interaction with the 
tooltip.

I see this on mac, assuming putterman sees this on win32.
(Assignee)

Comment 1

18 years ago
for m17, considering for beta2
Status: NEW → ASSIGNED
Keywords: nsbeta2
Target Milestone: --- → M17
(Assignee)

Comment 2

18 years ago
ok, this is caused by the fact that they are in the same popupsetframe and only 
one popup in a set can be active at a time. In the course of displaying the 
context menu, nsPopupSetFrame::MarkAsGenerated() unsets the |menugenerated| 
attribute on the tooltip and causes it to go bye-bye.

I need to talk to hyatt about this, cc'ing him.
Priority: P3 → P2
(Assignee)

Comment 3

18 years ago
i have a fix for this...basically moving the folder tooltip into its own 
popupset. I'll check it in when the tree opens.
Whiteboard: fix in hand

Comment 4

18 years ago
thanks for finding that.  That's good to know.  The fix is fine since as far as 
I know there was no reason to have it in the same popupset other than I didn't 
create another one.  For now on I'll keep tooltips separated from context menus.
(Assignee)

Comment 5

18 years ago
well, i was thinking about this...while there's no reason why they should be both 
visible at the same time, the fact that the context menu vanishes is bad bad 
bad....maybe i'll look at this a little more and see if i can't fix the original 
problem so they can be in the same popupset.
Whiteboard: fix in hand
(Assignee)

Comment 6

18 years ago
there are several bugs here. the first is that on macos, the activate/deactivate 
event sequence is confused so that the contextmenu gets hidden as the tooltip 
disappears. on win32, the context menu displays, but as soon as you try to mouse 
into it, it vanishes.

the workaround is to use different popupsets, but this should be made to work 
eventually.
Summary: Context menus don't display when a tooltip is visible → Problems with tooltips/context menus in same popupset

Comment 7

18 years ago
I actually never intended for it to be possible to have multiple popups in a 
popup showing simultaneously.  If we want to support it, cool, but I assumed 
that popupsets would be for mutually exclusive popups.

Comment 8

18 years ago
should have read "multiple popups in a popupset showing..."
(Assignee)

Comment 9

18 years ago
this doesn't need to be beta2.
Keywords: nsbeta2
Target Milestone: M17 → M18

Comment 10

18 years ago
mass-moving all bugs to m21 that are not dofood+, or nsbeta2+
Target Milestone: M18 → M21

Comment 11

18 years ago
nominate for nsbeta3.  External user reported this so it may be a common 
occurrence.  For PDT team, effect on the user: appears that the context for mail 
is not working since the context menu disappears right away after it is invoked.
Keywords: nsbeta3

Comment 12

18 years ago
*** Bug 43249 has been marked as a duplicate of this bug. ***

Comment 13

18 years ago
*** Bug 42612 has been marked as a duplicate of this bug. ***

Comment 14

18 years ago
Mike, did you ever check in the fix to mail? If not, perhaps I should just file 
a bug on myself to remove them from the same popupset so that this isn't as high 
a priority for you?
(Assignee)

Comment 15

18 years ago
i'm pretty sure i checked in the fix a while ago to mail, but we still have the 
problem that items in the same popupset clobber each other.
(Assignee)

Comment 16

18 years ago
workaround is good enough for shipping, pushing out.
Keywords: nsbeta3
Target Milestone: M21 → Future

Comment 17

17 years ago
WORKSFORME. I don't see this bug on win32 build 2000100520.
(Assignee)

Updated

17 years ago
Target Milestone: Future → mozilla1.0
(Assignee)

Comment 18

17 years ago
hyatt fixed this this week with his popup retooling.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.